<!DOCTYPE html>
<html lang="en-US" prefix="og: http://ogp.me/ns#">
<head><link rel="stylesheet" type="text/css" href="http://massispost.com/wp-content/cache/minify/07d08.css" media="all" />

	<meta property="fb:pages" content="116412075092856" />
	<meta charset="UTF-8">
	<meta http-equiv="X-UA-Compatible" content="IE=edge">
	<meta name="viewport" content="width=device-width, initial-scale=1">
	<title>Truth, Justice &amp; Remembrance Prevail in Times Square | Armenian News By MassisPost</title>
	<link rel="profile" href="http://gmpg.org/xfn/11" />
		<link rel="alternate" type="application/rss+xml" title="Armenian News By MassisPost RSS Feed" href="http://massispost.com/feed/" />
	<link rel="alternate" type="application/atom+xml" title="Armenian News By MassisPost Atom Feed" href="http://massispost.com/feed/atom/" />
	<link rel="pingback" href="http://massispost.com/xmlrpc.php" />
	<!--[if lt IE 9]>
	<script src="http://massispost.com/wp-content/themes/soledad/js/html5.js"></script>
	<style type="text/css">
		.featured-carousel .item { opacity: 1; }
	</style>
	<![endif]-->
	
<!-- This site is optimized with the Yoast SEO plugin v3.8 - https://yoast.com/wordpress/plugins/seo/ -->
<link rel="canonical" href="http://massispost.com/2017/04/truth-justice-remembrance-prevail-times-square/" />
<meta property="og:locale" content="en_US" />
<meta property="og:type" content="article" />
<meta property="og:title" content="Truth, Justice &amp; Remembrance Prevail in Times Square | Armenian News By MassisPost" />
<meta property="og:description" content="By Taleen Babayan The vow to Keep the Promise was in full effect on Sunday, April 23 as an impressive number gathered&hellip;" />
<meta property="og:url" content="http://massispost.com/2017/04/truth-justice-remembrance-prevail-times-square/" />
<meta property="og:site_name" content="Armenian News By MassisPost" />
<meta property="article:publisher" content="https://www.facebook.com/MassisPost/" />
<meta property="article:section" content="Armenian" />
<meta property="article:published_time" content="2017-04-24T18:07:17+00:00" />
<meta property="og:image" content="http://massispost.com/wp-content/uploads/2017/04/04232017_Lohr-Jones_102AGCTS_06.jpg" />
<meta property="og:image:width" content="850" />
<meta property="og:image:height" content="525" />
<meta name="twitter:card" content="summary" />
<meta name="twitter:description" content="By Taleen Babayan The vow to Keep the Promise was in full effect on Sunday, April 23 as an impressive number gathered&hellip;" />
<meta name="twitter:title" content="Truth, Justice &amp; Remembrance Prevail in Times Square | Armenian News By MassisPost" />
<meta name="twitter:site" content="@MassisPost" />
<meta name="twitter:image" content="https://i2.wp.com/massispost.com/wp-content/uploads/2017/04/04232017_Lohr-Jones_102AGCTS_06.jpg?fit=850%2C525" />
<meta name="twitter:creator" content="@MassisPost" />
<!-- / Yoast SEO plugin. -->

<link rel='dns-prefetch' href='//s0.wp.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="Armenian News By MassisPost &raquo; Feed" href="http://massispost.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="Armenian News By MassisPost &raquo; Comments Feed" href="http://massispost.com/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="Armenian News By MassisPost &raquo; Truth, Justice &#038; Remembrance Prevail in Times Square Comments Feed" href="http://massispost.com/2017/04/truth-justice-remembrance-prevail-times-square/feed/" />
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.2.1\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.2.1\/svg\/","svgExt":".svg","source":{"concatemoji":"http:\/\/massispost.com\/wp-includes\/js\/wp-emoji-release.min.js"}};
			!function(a,b,c){function d(a){var b,c,d,e,f=String.fromCharCode;if(!k||!k.fillText)return!1;switch(k.clearRect(0,0,j.width,j.height),k.textBaseline="top",k.font="600 32px Arial",a){case"flag":return k.fillText(f(55356,56826,55356,56819),0,0),!(j.toDataURL().length<3e3)&&(k.clearRect(0,0,j.width,j.height),k.fillText(f(55356,57331,65039,8205,55356,57096),0,0),b=j.toDataURL(),k.clearRect(0,0,j.width,j.height),k.fillText(f(55356,57331,55356,57096),0,0),c=j.toDataURL(),b!==c);case"emoji4":return k.fillText(f(55357,56425,55356,57341,8205,55357,56507),0,0),d=j.toDataURL(),k.clearRect(0,0,j.width,j.height),k.fillText(f(55357,56425,55356,57341,55357,56507),0,0),e=j.toDataURL(),d!==e}return!1}function e(a){var c=b.createElement("script");c.src=a,c.defer=c.type="text/javascript",b.getElementsByTagName("head")[0].appendChild(c)}var f,g,h,i,j=b.createElement("canvas"),k=j.getContext&&j.getContext("2d");for(i=Array("flag","emoji4"),c.supports={everything:!0,everythingExceptFlag:!0},h=0;h<i.length;h++)c.supports[i[h]]=d(i[h]),c.supports.everything=c.supports.everything&&c.supports[i[h]],"flag"!==i[h]&&(c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&c.supports[i[h]]);c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&!c.supports.flag,c.DOMReady=!1,c.readyCallback=function(){c.DOMReady=!0},c.supports.everything||(g=function(){c.readyCallback()},b.addEventListener?(b.addEventListener("DOMContentLoaded",g,!1),a.addEventListener("load",g,!1)):(a.attachEvent("onload",g),b.attachEvent("onreadystatechange",function(){"complete"===b.readyState&&c.readyCallback()})),f=c.source||{},f.concatemoji?e(f.concatemoji):f.wpemoji&&f.twemoji&&(e(f.twemoji),e(f.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>






<link rel='https://api.w.org/' href='http://massispost.com/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://massispost.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="http://massispost.com/wp-includes/wlwmanifest.xml" /> 
<meta name="generator" content="WordPress 4.7.4" />
<link rel='shortlink' href='http://massispost.com/?p=27073' />
<link rel="alternate" type="application/json+oembed" href="http://massispost.com/wp-json/oembed/1.0/embed?url=http%3A%2F%2Fmassispost.com%2F2017%2F04%2Ftruth-justice-remembrance-prevail-times-square%2F" />
<link rel="alternate" type="text/xml+oembed" href="http://massispost.com/wp-json/oembed/1.0/embed?url=http%3A%2F%2Fmassispost.com%2F2017%2F04%2Ftruth-justice-remembrance-prevail-times-square%2F&#038;format=xml" />
<!-- afb Instant Articles -->
			<meta property="fb:pages" content="116412075092856" />
<link rel='dns-prefetch' href='//jetpack.wordpress.com'>
<link rel='dns-prefetch' href='//s0.wp.com'>
<link rel='dns-prefetch' href='//s1.wp.com'>
<link rel='dns-prefetch' href='//s2.wp.com'>
<link rel='dns-prefetch' href='//public-api.wordpress.com'>
<link rel='dns-prefetch' href='//0.gravatar.com'>
<link rel='dns-prefetch' href='//1.gravatar.com'>
<link rel='dns-prefetch' href='//2.gravatar.com'>
<link rel='dns-prefetch' href='//i0.wp.com'>
<link rel='dns-prefetch' href='//i1.wp.com'>
<link rel='dns-prefetch' href='//i2.wp.com'>
    <style type="text/css">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</style>
    		<style type="text/css">.recentcomments a{display:inline !important;padding:0 !important;margin:0 !important;}</style>
		<link rel="amphtml" href="http://massispost.com/2017/04/truth-justice-remembrance-prevail-times-square/amp/" /><meta property="fb:pages" content="116412075092856" />

</head>

<body class="post-template-default single single-post postid-27073 single-format-gallery penci-body-boxed">

<a id="close-sidebar-nav" class="header-3"><i class="fa fa-close"></i></a>

<nav id="sidebar-nav" class="header-3">

			<div id="sidebar-nav-logo">
							<a href="http://massispost.com/"><img src="http://massispost.com/wp-content/uploads/2016/03/massismainnewB.png" alt="Armenian News By MassisPost" /></a>
					</div>
	
	
	<ul id="menu-massispost" class="menu"><li id="menu-item-23224" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-23224"><a href="http://massispost.com">Home</a></li>
<li id="menu-item-3216" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent penci-mega-menu menu-item-3216"><a href="http://massispost.com/category/news/">News</a>
<ul class="sub-menu">
	<li id="menu-item-0" class="menu-item-0"><div class="penci-megamenu">		
		<div class="penci-content-megamenu">
			<div class="penci-mega-latest-posts col-mn-5 mega-row-1">
								<div class="penci-mega-row penci-mega-3 row-active">
											<div class="penci-mega-post">
							<div class="penci-mega-thumbnail">
																<span class="mega-cat-name">
																			News																	</span>
																<a href="http://massispost.com/2017/04/armenian-council-america-message-delivered-natalie-sarafian-times-square-commemoration/" title="Armenian Council of America Message Delivered by Natalie Sarafian During Times Square Commemoration">
																																																																													<img width="585" height="390" src="https://i1.wp.com/massispost.com/wp-content/uploads/2017/04/Natalie-4-24-2017-NY-Times-Square..jpg?resize=585%2C390" class="attachment-penci-thumb size-penci-thumb wp-post-image" alt="" />								</a>
							</div>
							<div class="penci-mega-meta">
								<h3 class="post-mega-title">
									<a href="http://massispost.com/2017/04/armenian-council-america-message-delivered-natalie-sarafian-times-square-commemoration/">Armenian Council of America Message Delivered by Natalie Sarafian During Times Square Commemoration</a>
								</h3>
																<p class="penci-mega-date">April 24, 2017</p>
															</div>
						</div>
											<div class="penci-mega-post">
							<div class="penci-mega-thumbnail">
																<span class="mega-cat-name">
																			News																	</span>
																<a href="http://massispost.com/2017/04/truth-justice-remembrance-prevail-times-square/" title="Truth, Justice &#038; Remembrance Prevail in Times Square">
																																																																						<i class="fa fa-picture-o"></i>
																												<img width="585" height="390" src="https://i2.wp.com/massispost.com/wp-content/uploads/2017/04/04232017_Lohr-Jones_102AGCTS_06.jpg?resize=585%2C390" class="attachment-penci-thumb size-penci-thumb wp-post-image" alt="" />								</a>
							</div>
							<div class="penci-mega-meta">
								<h3 class="post-mega-title">
									<a href="http://massispost.com/2017/04/truth-justice-remembrance-prevail-times-square/">Truth, Justice &#038; Remembrance Prevail in Times Square</a>
								</h3>
																<p class="penci-mega-date">April 24, 2017</p>
															</div>
						</div>
											<div class="penci-mega-post">
							<div class="penci-mega-thumbnail">
																<span class="mega-cat-name">
																			News																	</span>
																<a href="http://massispost.com/2017/04/2017-aurora-prize-finalists-announced/" title="2017 Aurora Prize Finalists Announced">
																																																																													<img width="585" height="390" src="https://i1.wp.com/massispost.com/wp-content/uploads/2017/04/2017_finalists_Aurora.jpg?resize=585%2C390" class="attachment-penci-thumb size-penci-thumb wp-post-image" alt="" srcset="https://i1.wp.com/massispost.com/wp-content/uploads/2017/04/2017_finalists_Aurora.jpg?w=800 800w, https://i1.wp.com/massispost.com/wp-content/uploads/2017/04/2017_finalists_Aurora.jpg?resize=300%2C200 300w, https://i1.wp.com/massispost.com/wp-content/uploads/2017/04/2017_finalists_Aurora.jpg?resize=768%2C511 768w, https://i1.wp.com/massispost.com/wp-content/uploads/2017/04/2017_finalists_Aurora.jpg?resize=585%2C389 585w" sizes="(max-width: 585px) 100vw, 585px" />								</a>
							</div>
							<div class="penci-mega-meta">
								<h3 class="post-mega-title">
									<a href="http://massispost.com/2017/04/2017-aurora-prize-finalists-announced/">2017 Aurora Prize Finalists Announced</a>
								</h3>
																<p class="penci-mega-date">April 24, 2017</p>
															</div>
						</div>
											<div class="penci-mega-post">
							<div class="penci-mega-thumbnail">
																<span class="mega-cat-name">
																			News																	</span>
																<a href="http://massispost.com/2017/04/erdogan-sends-message-condolences-turkish-armenian-community/" title="Erdogan Sends Message of Condolences to the Turkish-Armenian Community">
																																																																													<img width="585" height="390" src="https://i1.wp.com/massispost.com/wp-content/uploads/2017/04/erdogan.jpg?resize=585%2C390" class="attachment-penci-thumb size-penci-thumb wp-post-image" alt="" />								</a>
							</div>
							<div class="penci-mega-meta">
								<h3 class="post-mega-title">
									<a href="http://massispost.com/2017/04/erdogan-sends-message-condolences-turkish-armenian-community/">Erdogan Sends Message of Condolences to the Turkish-Armenian Community</a>
								</h3>
																<p class="penci-mega-date">April 24, 2017</p>
															</div>
						</div>
											<div class="penci-mega-post">
							<div class="penci-mega-thumbnail">
																<span class="mega-cat-name">
																			News																	</span>
																<a href="http://massispost.com/2017/04/president-trump-issues-statement-commemorating-meds-yeghern/" title="President Trump Issues Statement Commemorating  “Meds Yeghern”">
																																																																													<img width="585" height="390" src="https://i1.wp.com/massispost.com/wp-content/uploads/2016/11/Trump.jpg?resize=585%2C390" class="attachment-penci-thumb size-penci-thumb wp-post-image" alt="" />								</a>
							</div>
							<div class="penci-mega-meta">
								<h3 class="post-mega-title">
									<a href="http://massispost.com/2017/04/president-trump-issues-statement-commemorating-meds-yeghern/">President Trump Issues Statement Commemorating  “Meds Yeghern”</a>
								</h3>
																<p class="penci-mega-date">April 24, 2017</p>
															</div>
						</div>
									</div>
							</div>
		</div>

		</div></li>
</ul>
</li>
<li id="menu-item-3217" class="menu-item menu-item-type-taxonomy menu-item-object-category penci-mega-menu menu-item-3217"><a href="http://massispost.com/category/armenia/">Armenia</a>
<ul class="sub-menu">
	<li class="menu-item-0"><div class="penci-megamenu">				<div class="penci-mega-child-categories">
							<a class="mega-cat-child cat-active" href="http://massispost.com/category/armenia/" data-id="penci-mega-5">All</a>
							<a class="mega-cat-child" href="http://massispost.com/category/armenia/artsakh/" data-id="penci-mega-8">Artsakh</a>
					</div>
		
		<div class="penci-content-megamenu">
			<div class="penci-mega-latest-posts col-mn-4 mega-row-1">
								<div class="penci-mega-row penci-mega-5 row-active">
											<div class="penci-mega-post">
							<div class="penci-mega-thumbnail">
																<span class="mega-cat-name">
																			Armenia																	</span>
																<a href="http://massispost.com/2017/04/2017-aurora-prize-finalists-announced/" title="2017 Aurora Prize Finalists Announced">
																																																																													<img width="585" height="390" src="https://i1.wp.com/massispost.com/wp-content/uploads/2017/04/2017_finalists_Aurora.jpg?resize=585%2C390" class="attachment-penci-thumb size-penci-thumb wp-post-image" alt="" srcset="https://i1.wp.com/massispost.com/wp-content/uploads/2017/04/2017_finalists_Aurora.jpg?w=800 800w, https://i1.wp.com/massispost.com/wp-content/uploads/2017/04/2017_finalists_Aurora.jpg?resize=300%2C200 300w, https://i1.wp.com/massispost.com/wp-content/uploads/2017/04/2017_finalists_Aurora.jpg?resize=768%2C511 768w, https://i1.wp.com/massispost.com/wp-content/uploads/2017/04/2017_finalists_Aurora.jpg?resize=585%2C389 585w" sizes="(max-width: 585px) 100vw, 585px" />								</a>
							</div>
							<div class="penci-mega-meta">
								<h3 class="post-mega-title">
									<a href="http://massispost.com/2017/04/2017-aurora-prize-finalists-announced/">2017 Aurora Prize Finalists Announced</a>
								</h3>
																<p class="penci-mega-date">April 24, 2017</p>
															</div>
						</div>
											<div class="penci-mega-post">
							<div class="penci-mega-thumbnail">
																<span class="mega-cat-name">
																			Armenia																	</span>
																<a href="http://massispost.com/2017/04/sarkisian-promises-radical-changes-armenia/" title="Sarkisian Again Promises ‘Radical Changes’ In Armenia">
																																																																													<img width="585" height="390" src="https://i0.wp.com/massispost.com/wp-content/uploads/2017/04/sarkisian.jpg?resize=585%2C390" class="attachment-penci-thumb size-penci-thumb wp-post-image" alt="" srcset="https://i0.wp.com/massispost.com/wp-content/uploads/2017/04/sarkisian.jpg?w=850 850w, https://i0.wp.com/massispost.com/wp-content/uploads/2017/04/sarkisian.jpg?resize=300%2C200 300w, https://i0.wp.com/massispost.com/wp-content/uploads/2017/04/sarkisian.jpg?resize=768%2C511 768w, https://i0.wp.com/massispost.com/wp-content/uploads/2017/04/sarkisian.jpg?resize=585%2C390 585w" sizes="(max-width: 585px) 100vw, 585px" />								</a>
							</div>
							<div class="penci-mega-meta">
								<h3 class="post-mega-title">
									<a href="http://massispost.com/2017/04/sarkisian-promises-radical-changes-armenia/">Sarkisian Again Promises ‘Radical Changes’ In Armenia</a>
								</h3>
																<p class="penci-mega-date">April 21, 2017</p>
															</div>
						</div>
											<div class="penci-mega-post">
							<div class="penci-mega-thumbnail">
																<span class="mega-cat-name">
																			Armenia																	</span>
																<a href="http://massispost.com/2017/04/winners-first-open-call-artist-armenia-art-foundation-announced/" title="Winners of the First Open Call for Artist of Armenia Art Foundation Announced">
																																																																													<img width="585" height="390" src="https://i1.wp.com/massispost.com/wp-content/uploads/2017/04/ArmenianArtsFoundation.jpg?resize=585%2C390" class="attachment-penci-thumb size-penci-thumb wp-post-image" alt="" />								</a>
							</div>
							<div class="penci-mega-meta">
								<h3 class="post-mega-title">
									<a href="http://massispost.com/2017/04/winners-first-open-call-artist-armenia-art-foundation-announced/">Winners of the First Open Call for Artist of Armenia Art Foundation Announced</a>
								</h3>
																<p class="penci-mega-date">April 19, 2017</p>
															</div>
						</div>
											<div class="penci-mega-post">
							<div class="penci-mega-thumbnail">
																<span class="mega-cat-name">
																			Artsakh																	</span>
																<a href="http://massispost.com/2017/04/irans-defense-minister-warns-attempts-resolve-karabakh-conflict-force/" title="Iran’s Defense Minister Warns Against Attempts to Resolve Karabakh Conflict by Force">
																																																																													<img width="585" height="390" src="https://i2.wp.com/massispost.com/wp-content/uploads/2017/04/Iran-Defense-Minister.jpg?resize=585%2C390" class="attachment-penci-thumb size-penci-thumb wp-post-image" alt="" />								</a>
							</div>
							<div class="penci-mega-meta">
								<h3 class="post-mega-title">
									<a href="http://massispost.com/2017/04/irans-defense-minister-warns-attempts-resolve-karabakh-conflict-force/">Iran’s Defense Minister Warns Against Attempts to Resolve Karabakh Conflict by Force</a>
								</h3>
																<p class="penci-mega-date">April 17, 2017</p>
															</div>
						</div>
									</div>
								<div class="penci-mega-row penci-mega-8">
											<div class="penci-mega-post">
							<div class="penci-mega-thumbnail">
																<span class="mega-cat-name">
																			Artsakh																	</span>
																<a href="http://massispost.com/2017/04/irans-defense-minister-warns-attempts-resolve-karabakh-conflict-force/" title="Iran’s Defense Minister Warns Against Attempts to Resolve Karabakh Conflict by Force">
																																																																													<img width="585" height="390" src="https://i2.wp.com/massispost.com/wp-content/uploads/2017/04/Iran-Defense-Minister.jpg?resize=585%2C390" class="attachment-penci-thumb size-penci-thumb wp-post-image" alt="" />								</a>
							</div>
							<div class="penci-mega-meta">
								<h3 class="post-mega-title">
									<a href="http://massispost.com/2017/04/irans-defense-minister-warns-attempts-resolve-karabakh-conflict-force/">Iran’s Defense Minister Warns Against Attempts to Resolve Karabakh Conflict by Force</a>
								</h3>
																<p class="penci-mega-date">April 17, 2017</p>
															</div>
						</div>
											<div class="penci-mega-post">
							<div class="penci-mega-thumbnail">
																<span class="mega-cat-name">
																			Artsakh																	</span>
																<a href="http://massispost.com/2017/04/restoration-works-mosque-shushi-line-withprovisions-international-conventions/" title="Restoration Works of Mosque in Shushi Are in Line With Provisions of International Conventions">
																																																																													<img width="585" height="390" src="https://i1.wp.com/massispost.com/wp-content/uploads/2017/04/shushi-mosque.jpg?resize=585%2C390" class="attachment-penci-thumb size-penci-thumb wp-post-image" alt="" />								</a>
							</div>
							<div class="penci-mega-meta">
								<h3 class="post-mega-title">
									<a href="http://massispost.com/2017/04/restoration-works-mosque-shushi-line-withprovisions-international-conventions/">Restoration Works of Mosque in Shushi Are in Line With Provisions of International Conventions</a>
								</h3>
																<p class="penci-mega-date">April 14, 2017</p>
															</div>
						</div>
											<div class="penci-mega-post">
							<div class="penci-mega-thumbnail">
																<span class="mega-cat-name">
																			Artsakh																	</span>
																<a href="http://massispost.com/2017/04/nagorno-karabakh-conflict-cannot-settled-military-means-french-mfa-statement/" title="Nagorno Karabakh Conflict Cannot be Settled by Military Means: French MFA Statement">
																																																																													<img width="585" height="390" src="https://i1.wp.com/massispost.com/wp-content/uploads/2017/04/french-mfa.jpg?resize=585%2C390" class="attachment-penci-thumb size-penci-thumb wp-post-image" alt="" srcset="https://i1.wp.com/massispost.com/wp-content/uploads/2017/04/french-mfa.jpg?resize=300%2C201 300w, https://i1.wp.com/massispost.com/wp-content/uploads/2017/04/french-mfa.jpg?resize=585%2C390 585w" sizes="(max-width: 585px) 100vw, 585px" />								</a>
							</div>
							<div class="penci-mega-meta">
								<h3 class="post-mega-title">
									<a href="http://massispost.com/2017/04/nagorno-karabakh-conflict-cannot-settled-military-means-french-mfa-statement/">Nagorno Karabakh Conflict Cannot be Settled by Military Means: French MFA Statement</a>
								</h3>
																<p class="penci-mega-date">April 6, 2017</p>
															</div>
						</div>
											<div class="penci-mega-post">
							<div class="penci-mega-thumbnail">
																<span class="mega-cat-name">
																			Artsakh																	</span>
																<a href="http://massispost.com/2017/04/spirit-firm-will-unshakeable-artsakh-president-bako-sahakyan/" title="‘Our Spirit is Firm, Our Will is Unshakeable’-Artsakh President Bako Sahakyan">
																																																																													<img width="585" height="390" src="https://i1.wp.com/massispost.com/wp-content/uploads/2016/08/bako-sahakian.jpg?resize=585%2C390" class="attachment-penci-thumb size-penci-thumb wp-post-image" alt="" />								</a>
							</div>
							<div class="penci-mega-meta">
								<h3 class="post-mega-title">
									<a href="http://massispost.com/2017/04/spirit-firm-will-unshakeable-artsakh-president-bako-sahakyan/">‘Our Spirit is Firm, Our Will is Unshakeable’-Artsakh President Bako Sahakyan</a>
								</h3>
																<p class="penci-mega-date">April 1, 2017</p>
															</div>
						</div>
									</div>
							</div>
		</div>

		</div></li>
</ul>
</li>
<li id="menu-item-3220" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent penci-mega-menu menu-item-3220"><a href="http://massispost.com/category/community/">Community</a>
<ul class="sub-menu">
	<li class="menu-item-0"><div class="penci-megamenu">		
		<div class="penci-content-megamenu">
			<div class="penci-mega-latest-posts col-mn-5 mega-row-1">
								<div class="penci-mega-row penci-mega-6 row-active">
											<div class="penci-mega-post">
							<div class="penci-mega-thumbnail">
																<span class="mega-cat-name">
																			Community																	</span>
																<a href="http://massispost.com/2017/04/armenian-council-america-message-delivered-natalie-sarafian-times-square-commemoration/" title="Armenian Council of America Message Delivered by Natalie Sarafian During Times Square Commemoration">
																																																																													<img width="585" height="390" src="https://i1.wp.com/massispost.com/wp-content/uploads/2017/04/Natalie-4-24-2017-NY-Times-Square..jpg?resize=585%2C390" class="attachment-penci-thumb size-penci-thumb wp-post-image" alt="" />								</a>
							</div>
							<div class="penci-mega-meta">
								<h3 class="post-mega-title">
									<a href="http://massispost.com/2017/04/armenian-council-america-message-delivered-natalie-sarafian-times-square-commemoration/">Armenian Council of America Message Delivered by Natalie Sarafian During Times Square Commemoration</a>
								</h3>
																<p class="penci-mega-date">April 24, 2017</p>
															</div>
						</div>
											<div class="penci-mega-post">
							<div class="penci-mega-thumbnail">
																<span class="mega-cat-name">
																			Community																	</span>
																<a href="http://massispost.com/2017/04/truth-justice-remembrance-prevail-times-square/" title="Truth, Justice &#038; Remembrance Prevail in Times Square">
																																																																						<i class="fa fa-picture-o"></i>
																												<img width="585" height="390" src="https://i2.wp.com/massispost.com/wp-content/uploads/2017/04/04232017_Lohr-Jones_102AGCTS_06.jpg?resize=585%2C390" class="attachment-penci-thumb size-penci-thumb wp-post-image" alt="" />								</a>
							</div>
							<div class="penci-mega-meta">
								<h3 class="post-mega-title">
									<a href="http://massispost.com/2017/04/truth-justice-remembrance-prevail-times-square/">Truth, Justice &#038; Remembrance Prevail in Times Square</a>
								</h3>
																<p class="penci-mega-date">April 24, 2017</p>
															</div>
						</div>
											<div class="penci-mega-post">
							<div class="penci-mega-thumbnail">
																<span class="mega-cat-name">
																			Community																	</span>
																<a href="http://massispost.com/2017/04/agbu-hye-geen-young-circle-annual-international-conference-evaluating-changes-within-armenian-family/" title="AGBU Hye Geen &#038; the Young Circle Annual International Conference Evaluating Changes Within the Armenian Family">
																																																																													<img width="585" height="390" src="https://i1.wp.com/massispost.com/wp-content/uploads/2017/04/HayGeen.jpg?resize=585%2C390" class="attachment-penci-thumb size-penci-thumb wp-post-image" alt="" />								</a>
							</div>
							<div class="penci-mega-meta">
								<h3 class="post-mega-title">
									<a href="http://massispost.com/2017/04/agbu-hye-geen-young-circle-annual-international-conference-evaluating-changes-within-armenian-family/">AGBU Hye Geen &#038; the Young Circle Annual International Conference Evaluating Changes Within the Armenian Family</a>
								</h3>
																<p class="penci-mega-date">April 19, 2017</p>
															</div>
						</div>
											<div class="penci-mega-post">
							<div class="penci-mega-thumbnail">
																<span class="mega-cat-name">
																			Community																	</span>
																<a href="http://massispost.com/2017/04/20-million-gift-creates-promise-institute-human-rights-ucla-school-law/" title="$20 Million Gift Creates Promise Institute for Human Rights at UCLA School of Law">
																																																																													<img width="585" height="390" src="https://i1.wp.com/massispost.com/wp-content/uploads/2017/04/EsrailianandMnookin_mid.jpg?resize=585%2C390" class="attachment-penci-thumb size-penci-thumb wp-post-image" alt="" srcset="https://i1.wp.com/massispost.com/wp-content/uploads/2017/04/EsrailianandMnookin_mid.jpg?w=850 850w, https://i1.wp.com/massispost.com/wp-content/uploads/2017/04/EsrailianandMnookin_mid.jpg?resize=300%2C200 300w, https://i1.wp.com/massispost.com/wp-content/uploads/2017/04/EsrailianandMnookin_mid.jpg?resize=768%2C511 768w, https://i1.wp.com/massispost.com/wp-content/uploads/2017/04/EsrailianandMnookin_mid.jpg?resize=585%2C390 585w" sizes="(max-width: 585px) 100vw, 585px" />								</a>
							</div>
							<div class="penci-mega-meta">
								<h3 class="post-mega-title">
									<a href="http://massispost.com/2017/04/20-million-gift-creates-promise-institute-human-rights-ucla-school-law/">$20 Million Gift Creates Promise Institute for Human Rights at UCLA School of Law</a>
								</h3>
																<p class="penci-mega-date">April 18, 2017</p>
															</div>
						</div>
											<div class="penci-mega-post">
							<div class="penci-mega-thumbnail">
																<span class="mega-cat-name">
																			Community																	</span>
																<a href="http://massispost.com/2017/04/los-angeles-county-proclaims-armenian-genocide-day-remembrance/" title="Los Angeles County Proclaims Armenian Genocide Day of Remembrance">
																																																																													<img width="585" height="390" src="https://i2.wp.com/massispost.com/wp-content/uploads/2017/04/HS7_7018.jpg?resize=585%2C390" class="attachment-penci-thumb size-penci-thumb wp-post-image" alt="" srcset="https://i2.wp.com/massispost.com/wp-content/uploads/2017/04/HS7_7018.jpg?resize=585%2C390 585w, https://i2.wp.com/massispost.com/wp-content/uploads/2017/04/HS7_7018.jpg?zoom=2&amp;resize=585%2C390 1170w" sizes="(max-width: 585px) 100vw, 585px" />								</a>
							</div>
							<div class="penci-mega-meta">
								<h3 class="post-mega-title">
									<a href="http://massispost.com/2017/04/los-angeles-county-proclaims-armenian-genocide-day-remembrance/">Los Angeles County Proclaims Armenian Genocide Day of Remembrance</a>
								</h3>
																<p class="penci-mega-date">April 18, 2017</p>
															</div>
						</div>
									</div>
							</div>
		</div>

		</div></li>
</ul>
</li>
<li id="menu-item-3218" class="menu-item menu-item-type-taxonomy menu-item-object-category penci-mega-menu menu-item-3218"><a href="http://massispost.com/category/world/">World</a>
<ul class="sub-menu">
	<li class="menu-item-0"><div class="penci-megamenu">		
		<div class="penci-content-megamenu">
			<div class="penci-mega-latest-posts col-mn-5 mega-row-1">
								<div class="penci-mega-row penci-mega-4 row-active">
											<div class="penci-mega-post">
							<div class="penci-mega-thumbnail">
																<span class="mega-cat-name">
																			World																	</span>
																<a href="http://massispost.com/2017/04/erdogan-sends-message-condolences-turkish-armenian-community/" title="Erdogan Sends Message of Condolences to the Turkish-Armenian Community">
																																																																													<img width="585" height="390" src="https://i1.wp.com/massispost.com/wp-content/uploads/2017/04/erdogan.jpg?resize=585%2C390" class="attachment-penci-thumb size-penci-thumb wp-post-image" alt="" />								</a>
							</div>
							<div class="penci-mega-meta">
								<h3 class="post-mega-title">
									<a href="http://massispost.com/2017/04/erdogan-sends-message-condolences-turkish-armenian-community/">Erdogan Sends Message of Condolences to the Turkish-Armenian Community</a>
								</h3>
																<p class="penci-mega-date">April 24, 2017</p>
															</div>
						</div>
											<div class="penci-mega-post">
							<div class="penci-mega-thumbnail">
																<span class="mega-cat-name">
																			World																	</span>
																<a href="http://massispost.com/2017/04/justin-trudeau-pays-tribute-armenian-genocide-victims/" title="Justin Trudeau Pays Tribute to Armenian Genocide Victims">
																																																																													<img width="585" height="390" src="https://i0.wp.com/massispost.com/wp-content/uploads/2017/04/Justin-Trudeau.jpg?resize=585%2C390" class="attachment-penci-thumb size-penci-thumb wp-post-image" alt="" />								</a>
							</div>
							<div class="penci-mega-meta">
								<h3 class="post-mega-title">
									<a href="http://massispost.com/2017/04/justin-trudeau-pays-tribute-armenian-genocide-victims/">Justin Trudeau Pays Tribute to Armenian Genocide Victims</a>
								</h3>
																<p class="penci-mega-date">April 22, 2017</p>
															</div>
						</div>
											<div class="penci-mega-post">
							<div class="penci-mega-thumbnail">
																<span class="mega-cat-name">
																			World																	</span>
																<a href="http://massispost.com/2017/04/eu-observers-claim-irregularities-possible-vote-tampering-turkish-referendum/" title="EU Observers Claim Irregularities, Possible Vote Tampering In Turkish Referendum">
																																																																													<img width="585" height="390" src="https://i1.wp.com/massispost.com/wp-content/uploads/2017/04/Protsts-Turkey.jpg?resize=585%2C390" class="attachment-penci-thumb size-penci-thumb wp-post-image" alt="" />								</a>
							</div>
							<div class="penci-mega-meta">
								<h3 class="post-mega-title">
									<a href="http://massispost.com/2017/04/eu-observers-claim-irregularities-possible-vote-tampering-turkish-referendum/">EU Observers Claim Irregularities, Possible Vote Tampering In Turkish Referendum</a>
								</h3>
																<p class="penci-mega-date">April 18, 2017</p>
															</div>
						</div>
											<div class="penci-mega-post">
							<div class="penci-mega-thumbnail">
																<span class="mega-cat-name">
																			World																	</span>
																<a href="http://massispost.com/2017/04/irans-defense-minister-warns-attempts-resolve-karabakh-conflict-force/" title="Iran’s Defense Minister Warns Against Attempts to Resolve Karabakh Conflict by Force">
																																																																													<img width="585" height="390" src="https://i2.wp.com/massispost.com/wp-content/uploads/2017/04/Iran-Defense-Minister.jpg?resize=585%2C390" class="attachment-penci-thumb size-penci-thumb wp-post-image" alt="" />								</a>
							</div>
							<div class="penci-mega-meta">
								<h3 class="post-mega-title">
									<a href="http://massispost.com/2017/04/irans-defense-minister-warns-attempts-resolve-karabakh-conflict-force/">Iran’s Defense Minister Warns Against Attempts to Resolve Karabakh Conflict by Force</a>
								</h3>
																<p class="penci-mega-date">April 17, 2017</p>
															</div>
						</div>
											<div class="penci-mega-post">
							<div class="penci-mega-thumbnail">
																<span class="mega-cat-name">
																			World																	</span>
																<a href="http://massispost.com/2017/04/bagrat-estukyan-turkeys-armenian-community-voted-no-constitutional-referendum/" title="Bagrat Estukyan: Turkey’s Armenian Community Voted “No” in Constitutional Referendum">
																																																																													<img width="585" height="390" src="https://i1.wp.com/massispost.com/wp-content/uploads/2017/04/referandum-Yes-No.jpg?resize=585%2C390" class="attachment-penci-thumb size-penci-thumb wp-post-image" alt="" />								</a>
							</div>
							<div class="penci-mega-meta">
								<h3 class="post-mega-title">
									<a href="http://massispost.com/2017/04/bagrat-estukyan-turkeys-armenian-community-voted-no-constitutional-referendum/">Bagrat Estukyan: Turkey’s Armenian Community Voted “No” in Constitutional Referendum</a>
								</h3>
																<p class="penci-mega-date">April 17, 2017</p>
															</div>
						</div>
									</div>
							</div>
		</div>

		</div></li>
</ul>
</li>
<li id="menu-item-3228" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent penci-mega-menu menu-item-3228"><a href="http://massispost.com/category/armenian-genocide/">Armenian Genocide</a>
<ul class="sub-menu">
	<li class="menu-item-0"><div class="penci-megamenu">		
		<div class="penci-content-megamenu">
			<div class="penci-mega-latest-posts col-mn-5 mega-row-1">
								<div class="penci-mega-row penci-mega-12 row-active">
											<div class="penci-mega-post">
							<div class="penci-mega-thumbnail">
																<span class="mega-cat-name">
																			Armenian Genocide																	</span>
																<a href="http://massispost.com/2017/04/armenian-council-america-message-delivered-natalie-sarafian-times-square-commemoration/" title="Armenian Council of America Message Delivered by Natalie Sarafian During Times Square Commemoration">
																																																																													<img width="585" height="390" src="https://i1.wp.com/massispost.com/wp-content/uploads/2017/04/Natalie-4-24-2017-NY-Times-Square..jpg?resize=585%2C390" class="attachment-penci-thumb size-penci-thumb wp-post-image" alt="" />								</a>
							</div>
							<div class="penci-mega-meta">
								<h3 class="post-mega-title">
									<a href="http://massispost.com/2017/04/armenian-council-america-message-delivered-natalie-sarafian-times-square-commemoration/">Armenian Council of America Message Delivered by Natalie Sarafian During Times Square Commemoration</a>
								</h3>
																<p class="penci-mega-date">April 24, 2017</p>
															</div>
						</div>
											<div class="penci-mega-post">
							<div class="penci-mega-thumbnail">
																<span class="mega-cat-name">
																			Armenian Genocide																	</span>
																<a href="http://massispost.com/2017/04/truth-justice-remembrance-prevail-times-square/" title="Truth, Justice &#038; Remembrance Prevail in Times Square">
																																																																						<i class="fa fa-picture-o"></i>
																												<img width="585" height="390" src="https://i2.wp.com/massispost.com/wp-content/uploads/2017/04/04232017_Lohr-Jones_102AGCTS_06.jpg?resize=585%2C390" class="attachment-penci-thumb size-penci-thumb wp-post-image" alt="" />								</a>
							</div>
							<div class="penci-mega-meta">
								<h3 class="post-mega-title">
									<a href="http://massispost.com/2017/04/truth-justice-remembrance-prevail-times-square/">Truth, Justice &#038; Remembrance Prevail in Times Square</a>
								</h3>
																<p class="penci-mega-date">April 24, 2017</p>
															</div>
						</div>
											<div class="penci-mega-post">
							<div class="penci-mega-thumbnail">
																<span class="mega-cat-name">
																			Armenian Genocide																	</span>
																<a href="http://massispost.com/2017/04/erdogan-sends-message-condolences-turkish-armenian-community/" title="Erdogan Sends Message of Condolences to the Turkish-Armenian Community">
																																																																													<img width="585" height="390" src="https://i1.wp.com/massispost.com/wp-content/uploads/2017/04/erdogan.jpg?resize=585%2C390" class="attachment-penci-thumb size-penci-thumb wp-post-image" alt="" />								</a>
							</div>
							<div class="penci-mega-meta">
								<h3 class="post-mega-title">
									<a href="http://massispost.com/2017/04/erdogan-sends-message-condolences-turkish-armenian-community/">Erdogan Sends Message of Condolences to the Turkish-Armenian Community</a>
								</h3>
																<p class="penci-mega-date">April 24, 2017</p>
															</div>
						</div>
											<div class="penci-mega-post">
							<div class="penci-mega-thumbnail">
																<span class="mega-cat-name">
																			Armenian Genocide																	</span>
																<a href="http://massispost.com/2017/04/president-trump-issues-statement-commemorating-meds-yeghern/" title="President Trump Issues Statement Commemorating  “Meds Yeghern”">
																																																																													<img width="585" height="390" src="https://i1.wp.com/massispost.com/wp-content/uploads/2016/11/Trump.jpg?resize=585%2C390" class="attachment-penci-thumb size-penci-thumb wp-post-image" alt="" />								</a>
							</div>
							<div class="penci-mega-meta">
								<h3 class="post-mega-title">
									<a href="http://massispost.com/2017/04/president-trump-issues-statement-commemorating-meds-yeghern/">President Trump Issues Statement Commemorating  “Meds Yeghern”</a>
								</h3>
																<p class="penci-mega-date">April 24, 2017</p>
															</div>
						</div>
											<div class="penci-mega-post">
							<div class="penci-mega-thumbnail">
																<span class="mega-cat-name">
																			Armenian Genocide																	</span>
																<a href="http://massispost.com/2017/04/lost-evidence-armenian-genocide-discovered-jerusalem-archive/" title="Lost Evidence of Armenian Genocide Discovered in Jerusalem Archive">
																																																																													<img width="585" height="390" src="https://i2.wp.com/massispost.com/wp-content/uploads/2017/04/Hunchakian_gallows-1.jpg?resize=585%2C390" class="attachment-penci-thumb size-penci-thumb wp-post-image" alt="" />								</a>
							</div>
							<div class="penci-mega-meta">
								<h3 class="post-mega-title">
									<a href="http://massispost.com/2017/04/lost-evidence-armenian-genocide-discovered-jerusalem-archive/">Lost Evidence of Armenian Genocide Discovered in Jerusalem Archive</a>
								</h3>
																<p class="penci-mega-date">April 23, 2017</p>
															</div>
						</div>
									</div>
							</div>
		</div>

		</div></li>
</ul>
</li>
<li id="menu-item-3223" class="menu-item menu-item-type-taxonomy menu-item-object-category penci-mega-menu menu-item-3223"><a href="http://massispost.com/category/commentary/">Commentary</a>
<ul class="sub-menu">
	<li class="menu-item-0"><div class="penci-megamenu">		
		<div class="penci-content-megamenu">
			<div class="penci-mega-latest-posts col-mn-5 mega-row-1">
								<div class="penci-mega-row penci-mega-9 row-active">
											<div class="penci-mega-post">
							<div class="penci-mega-thumbnail">
																<span class="mega-cat-name">
																			Commentary																	</span>
																<a href="http://massispost.com/2017/04/armenians-didnt-arrive-accident-promise-largely/" title="Armenians Didn’t Arrive Here by Accident. ‘The Promise’ is Largely Why">
																																																																													<img width="585" height="390" src="https://i2.wp.com/massispost.com/wp-content/uploads/2016/09/the-promise-trailer.jpg?resize=585%2C390" class="attachment-penci-thumb size-penci-thumb wp-post-image" alt="" />								</a>
							</div>
							<div class="penci-mega-meta">
								<h3 class="post-mega-title">
									<a href="http://massispost.com/2017/04/armenians-didnt-arrive-accident-promise-largely/">Armenians Didn’t Arrive Here by Accident. ‘The Promise’ is Largely Why</a>
								</h3>
																<p class="penci-mega-date">April 17, 2017</p>
															</div>
						</div>
											<div class="penci-mega-post">
							<div class="penci-mega-thumbnail">
																<span class="mega-cat-name">
																			Commentary																	</span>
																<a href="http://massispost.com/2017/04/zoryan-institute-reflects-regressive-trends-human-rights-genocide-awareness-month/" title="The Zoryan Institute Reflects on the Regressive Trends in Human Rights during Genocide Awareness Month">
																																																																													<img width="585" height="304" src="https://i2.wp.com/massispost.com/wp-content/uploads/2017/04/UnitedToEndGenocide.jpg?resize=585%2C304" class="attachment-penci-thumb size-penci-thumb wp-post-image" alt="" />								</a>
							</div>
							<div class="penci-mega-meta">
								<h3 class="post-mega-title">
									<a href="http://massispost.com/2017/04/zoryan-institute-reflects-regressive-trends-human-rights-genocide-awareness-month/">The Zoryan Institute Reflects on the Regressive Trends in Human Rights during Genocide Awareness Month</a>
								</h3>
																<p class="penci-mega-date">April 13, 2017</p>
															</div>
						</div>
											<div class="penci-mega-post">
							<div class="penci-mega-thumbnail">
																<span class="mega-cat-name">
																			Commentary																	</span>
																<a href="http://massispost.com/2017/03/pro-turkish-journalist-stephen-kinzers-assault-armenian-genocide-armenians/" title="Pro-Turkish Journalist Stephen Kinzer’s Assault on the Armenian Genocide and Armenians">
																																																																													<img width="585" height="390" src="https://i1.wp.com/massispost.com/wp-content/uploads/2017/03/Stephen-Kinzer.jpg?resize=585%2C390" class="attachment-penci-thumb size-penci-thumb wp-post-image" alt="" />								</a>
							</div>
							<div class="penci-mega-meta">
								<h3 class="post-mega-title">
									<a href="http://massispost.com/2017/03/pro-turkish-journalist-stephen-kinzers-assault-armenian-genocide-armenians/">Pro-Turkish Journalist Stephen Kinzer’s Assault on the Armenian Genocide and Armenians</a>
								</h3>
																<p class="penci-mega-date">March 29, 2017</p>
															</div>
						</div>
											<div class="penci-mega-post">
							<div class="penci-mega-thumbnail">
																<span class="mega-cat-name">
																			Commentary																	</span>
																<a href="http://massispost.com/2017/03/patriarchal-election-deja-vu-turkey-government-meddling-election-inevitable-not-decisive/" title="Patriarchal Election Déjà Vu in Turkey: Government Meddling in the Election is Inevitable, But Not Decisive">
																																																																													<img width="585" height="390" src="https://i1.wp.com/massispost.com/wp-content/uploads/2017/03/Armenian-Patriarchate-Istanbul.jpg?resize=585%2C390" class="attachment-penci-thumb size-penci-thumb wp-post-image" alt="" />								</a>
							</div>
							<div class="penci-mega-meta">
								<h3 class="post-mega-title">
									<a href="http://massispost.com/2017/03/patriarchal-election-deja-vu-turkey-government-meddling-election-inevitable-not-decisive/">Patriarchal Election Déjà Vu in Turkey: Government Meddling in the Election is Inevitable, But Not Decisive</a>
								</h3>
																<p class="penci-mega-date">March 27, 2017</p>
															</div>
						</div>
											<div class="penci-mega-post">
							<div class="penci-mega-thumbnail">
																<span class="mega-cat-name">
																			Commentary																	</span>
																<a href="http://massispost.com/2017/03/returning-greater-armenia-civilizational-path-armenians/" title="Returning to Greater Armenia: Civilizational Path of Armenians">
																																																																													<img width="585" height="390" src="https://i2.wp.com/massispost.com/wp-content/uploads/2017/03/1440949157_tigran-765x510.jpg?resize=585%2C390" class="attachment-penci-thumb size-penci-thumb wp-post-image" alt="" srcset="https://i2.wp.com/massispost.com/wp-content/uploads/2017/03/1440949157_tigran-765x510.jpg?resize=765%2C510 765w, https://i2.wp.com/massispost.com/wp-content/uploads/2017/03/1440949157_tigran-765x510.jpg?resize=300%2C200 300w, https://i2.wp.com/massispost.com/wp-content/uploads/2017/03/1440949157_tigran-765x510.jpg?resize=585%2C390 585w" sizes="(max-width: 585px) 100vw, 585px" />								</a>
							</div>
							<div class="penci-mega-meta">
								<h3 class="post-mega-title">
									<a href="http://massispost.com/2017/03/returning-greater-armenia-civilizational-path-armenians/">Returning to Greater Armenia: Civilizational Path of Armenians</a>
								</h3>
																<p class="penci-mega-date">March 12, 2017</p>
															</div>
						</div>
									</div>
							</div>
		</div>

		</div></li>
</ul>
</li>
<li id="menu-item-23223" class="menu-item menu-item-type-taxonomy menu-item-object-category penci-mega-menu menu-item-23223"><a href="http://massispost.com/category/culture/">Arts &#038; Culture</a>
<ul class="sub-menu">
	<li class="menu-item-0"><div class="penci-megamenu">		
		<div class="penci-content-megamenu">
			<div class="penci-mega-latest-posts col-mn-5 mega-row-1">
								<div class="penci-mega-row penci-mega-10 row-active">
											<div class="penci-mega-post">
							<div class="penci-mega-thumbnail">
																<span class="mega-cat-name">
																			Arts &amp; Culture																	</span>
																<a href="http://massispost.com/2017/04/winners-first-open-call-artist-armenia-art-foundation-announced/" title="Winners of the First Open Call for Artist of Armenia Art Foundation Announced">
																																																																													<img width="585" height="390" src="https://i1.wp.com/massispost.com/wp-content/uploads/2017/04/ArmenianArtsFoundation.jpg?resize=585%2C390" class="attachment-penci-thumb size-penci-thumb wp-post-image" alt="" />								</a>
							</div>
							<div class="penci-mega-meta">
								<h3 class="post-mega-title">
									<a href="http://massispost.com/2017/04/winners-first-open-call-artist-armenia-art-foundation-announced/">Winners of the First Open Call for Artist of Armenia Art Foundation Announced</a>
								</h3>
																<p class="penci-mega-date">April 19, 2017</p>
															</div>
						</div>
											<div class="penci-mega-post">
							<div class="penci-mega-thumbnail">
																<span class="mega-cat-name">
																			Arts &amp; Culture																	</span>
																<a href="http://massispost.com/2017/04/armenians-didnt-arrive-accident-promise-largely/" title="Armenians Didn’t Arrive Here by Accident. ‘The Promise’ is Largely Why">
																																																																													<img width="585" height="390" src="https://i2.wp.com/massispost.com/wp-content/uploads/2016/09/the-promise-trailer.jpg?resize=585%2C390" class="attachment-penci-thumb size-penci-thumb wp-post-image" alt="" />								</a>
							</div>
							<div class="penci-mega-meta">
								<h3 class="post-mega-title">
									<a href="http://massispost.com/2017/04/armenians-didnt-arrive-accident-promise-largely/">Armenians Didn’t Arrive Here by Accident. ‘The Promise’ is Largely Why</a>
								</h3>
																<p class="penci-mega-date">April 17, 2017</p>
															</div>
						</div>
											<div class="penci-mega-post">
							<div class="penci-mega-thumbnail">
																<span class="mega-cat-name">
																			Arts &amp; Culture																	</span>
																<a href="http://massispost.com/2017/04/adaa-antaeus-theatre-present-two-reading-events/" title="ADAA and Antaeus Theatre Present Two Reading Events">
																																																																													<img width="585" height="390" src="https://i2.wp.com/massispost.com/wp-content/uploads/2017/04/ADAA.jpg?resize=585%2C390" class="attachment-penci-thumb size-penci-thumb wp-post-image" alt="" />								</a>
							</div>
							<div class="penci-mega-meta">
								<h3 class="post-mega-title">
									<a href="http://massispost.com/2017/04/adaa-antaeus-theatre-present-two-reading-events/">ADAA and Antaeus Theatre Present Two Reading Events</a>
								</h3>
																<p class="penci-mega-date">April 17, 2017</p>
															</div>
						</div>
											<div class="penci-mega-post">
							<div class="penci-mega-thumbnail">
																<span class="mega-cat-name">
																			Arts &amp; Culture																	</span>
																<a href="http://massispost.com/2017/04/crows-desert-screening-april-23-warner-grand-theater-san-pedro/" title="&#8220;Crows Of The Desert&#8230;&#8221; Screening April 23 at Warner Grand Theater in San Pedro">
																																																																													<img width="585" height="390" src="https://i1.wp.com/massispost.com/wp-content/uploads/2017/04/crowsofthedesert.jpg?resize=585%2C390" class="attachment-penci-thumb size-penci-thumb wp-post-image" alt="" />								</a>
							</div>
							<div class="penci-mega-meta">
								<h3 class="post-mega-title">
									<a href="http://massispost.com/2017/04/crows-desert-screening-april-23-warner-grand-theater-san-pedro/">&#8220;Crows Of The Desert&#8230;&#8221; Screening April 23 at Warner Grand Theater in San Pedro</a>
								</h3>
																<p class="penci-mega-date">April 13, 2017</p>
															</div>
						</div>
											<div class="penci-mega-post">
							<div class="penci-mega-thumbnail">
																<span class="mega-cat-name">
																			Arts &amp; Culture																	</span>
																<a href="http://massispost.com/2017/04/master-oudist-richard-hagopian-present-melodic-rhythmic-considerations-oud-performance/" title="Master Oudist Richard Hagopian to Present “Melodic and Rhythmic Considerations in Oud Performance”">
																										</a>
							</div>
							<div class="penci-mega-meta">
								<h3 class="post-mega-title">
									<a href="http://massispost.com/2017/04/master-oudist-richard-hagopian-present-melodic-rhythmic-considerations-oud-performance/">Master Oudist Richard Hagopian to Present “Melodic and Rhythmic Considerations in Oud Performance”</a>
								</h3>
																<p class="penci-mega-date">April 13, 2017</p>
															</div>
						</div>
									</div>
							</div>
		</div>

		</div></li>
</ul>
</li>
<li id="menu-item-23232" class="menu-item menu-item-type-taxonomy menu-item-object-category penci-mega-menu menu-item-23232"><a href="http://massispost.com/category/sports/">Sports</a>
<ul class="sub-menu">
	<li class="menu-item-0"><div class="penci-megamenu">		
		<div class="penci-content-megamenu">
			<div class="penci-mega-latest-posts col-mn-5 mega-row-1">
								<div class="penci-mega-row penci-mega-186 row-active">
											<div class="penci-mega-post">
							<div class="penci-mega-thumbnail">
																<span class="mega-cat-name">
																			Sports																	</span>
																<a href="http://massispost.com/2017/04/arthur-abraham-beats-robin-krasniqi-unanimous-decision/" title="Arthur Abraham Beats Robin Krasniqi in Unanimous Decision">
																																																																													<img width="585" height="390" src="https://i1.wp.com/massispost.com/wp-content/uploads/2017/04/abraham-krasniqi-1.jpg?resize=585%2C390" class="attachment-penci-thumb size-penci-thumb wp-post-image" alt="" />								</a>
							</div>
							<div class="penci-mega-meta">
								<h3 class="post-mega-title">
									<a href="http://massispost.com/2017/04/arthur-abraham-beats-robin-krasniqi-unanimous-decision/">Arthur Abraham Beats Robin Krasniqi in Unanimous Decision</a>
								</h3>
																<p class="penci-mega-date">April 23, 2017</p>
															</div>
						</div>
											<div class="penci-mega-post">
							<div class="penci-mega-thumbnail">
																<span class="mega-cat-name">
																			Sports																	</span>
																<a href="http://massispost.com/2017/04/simon-martirosyan-wins-gold-european-weightlifting-championships/" title="Simon Martirosyan Wins Gold at European Weightlifting Championships">
																																																																													<img width="585" height="390" src="https://i1.wp.com/massispost.com/wp-content/uploads/2017/04/Simon-Martirosyan.jpg?resize=585%2C390" class="attachment-penci-thumb size-penci-thumb wp-post-image" alt="" srcset="https://i1.wp.com/massispost.com/wp-content/uploads/2017/04/Simon-Martirosyan.jpg?w=1024 1024w, https://i1.wp.com/massispost.com/wp-content/uploads/2017/04/Simon-Martirosyan.jpg?resize=300%2C200 300w, https://i1.wp.com/massispost.com/wp-content/uploads/2017/04/Simon-Martirosyan.jpg?resize=768%2C512 768w, https://i1.wp.com/massispost.com/wp-content/uploads/2017/04/Simon-Martirosyan.jpg?resize=585%2C390 585w" sizes="(max-width: 585px) 100vw, 585px" />								</a>
							</div>
							<div class="penci-mega-meta">
								<h3 class="post-mega-title">
									<a href="http://massispost.com/2017/04/simon-martirosyan-wins-gold-european-weightlifting-championships/">Simon Martirosyan Wins Gold at European Weightlifting Championships</a>
								</h3>
																<p class="penci-mega-date">April 10, 2017</p>
															</div>
						</div>
											<div class="penci-mega-post">
							<div class="penci-mega-thumbnail">
																<span class="mega-cat-name">
																			Sports																	</span>
																<a href="http://massispost.com/2017/03/armenia-beat-kazakhstan-2-0-world-cup-qualifier/" title="Armenia Beat Kazakhstan 2-0 in World Cup Qualifier">
																																																																													<img width="585" height="390" src="https://i2.wp.com/massispost.com/wp-content/uploads/2017/03/Armenia-Kazakhstan.jpg?resize=585%2C390" class="attachment-penci-thumb size-penci-thumb wp-post-image" alt="" />								</a>
							</div>
							<div class="penci-mega-meta">
								<h3 class="post-mega-title">
									<a href="http://massispost.com/2017/03/armenia-beat-kazakhstan-2-0-world-cup-qualifier/">Armenia Beat Kazakhstan 2-0 in World Cup Qualifier</a>
								</h3>
																<p class="penci-mega-date">March 26, 2017</p>
															</div>
						</div>
											<div class="penci-mega-post">
							<div class="penci-mega-thumbnail">
																<span class="mega-cat-name">
																			Sports																	</span>
																<a href="http://massispost.com/2017/03/henrikh-mkhitaryan-receives-armenias-footballer-year-award/" title="Henrikh Mkhitaryan Receives Armenia’s Footballer of the Year Award">
																																																																													<img width="585" height="390" src="https://i2.wp.com/massispost.com/wp-content/uploads/2017/03/mkhitaryan-1.jpg?resize=585%2C390" class="attachment-penci-thumb size-penci-thumb wp-post-image" alt="" />								</a>
							</div>
							<div class="penci-mega-meta">
								<h3 class="post-mega-title">
									<a href="http://massispost.com/2017/03/henrikh-mkhitaryan-receives-armenias-footballer-year-award/">Henrikh Mkhitaryan Receives Armenia’s Footballer of the Year Award</a>
								</h3>
																<p class="penci-mega-date">March 24, 2017</p>
															</div>
						</div>
											<div class="penci-mega-post">
							<div class="penci-mega-thumbnail">
																<span class="mega-cat-name">
																			Sports																	</span>
																<a href="http://massispost.com/2017/03/henrikh-mkhitaryan-wins-third-goal-month-manchester-united/" title="Henrikh Mkhitaryan Wins Third Goal of the Month for Manchester United">
																														<i class="fa fa-play"></i>
																																																																				<img width="585" height="390" src="https://i2.wp.com/massispost.com/wp-content/uploads/2017/03/mkhitaryan.jpg?resize=585%2C390" class="attachment-penci-thumb size-penci-thumb wp-post-image" alt="" />								</a>
							</div>
							<div class="penci-mega-meta">
								<h3 class="post-mega-title">
									<a href="http://massispost.com/2017/03/henrikh-mkhitaryan-wins-third-goal-month-manchester-united/">Henrikh Mkhitaryan Wins Third Goal of the Month for Manchester United</a>
								</h3>
																<p class="penci-mega-date">March 9, 2017</p>
															</div>
						</div>
									</div>
							</div>
		</div>

		</div></li>
</ul>
</li>
<li id="menu-item-23225" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-23225"><a href="http://massispost.com/am">Հայերէն</a></li>
</ul></nav>

<!-- .wrapper-boxed -->
<div class="wrapper-boxed header-style-header-3 enable-boxed">

<!-- Top Bar -->
	<div class="penci-top-bar">
	<div class="container">
		<div class="penci-headline">
										<span class="headline-title">Top Posts</span>
										<div class="penci-topbar-social">
					<div class="inner-header-social">
			<a href="https://www.facebook.com/MassisPost/?fref=ts" target="_blank"><i class="fa fa-facebook"></i></a>
				<a href="https://twitter.com/massispost" target="_blank"><i class="fa fa-twitter"></i></a>
				<a href="https://plus.google.com/103247076034057621040/" target="_blank"><i class="fa fa-google-plus"></i></a>
										<a href="https://www.youtube.com/user/MassisPost" target="_blank"><i class="fa fa-youtube-play"></i></a>
				<a href="mailto:info@massispost.com"><i class="fa fa-envelope-o"></i></a>
								<a href="http://massispost.com/feed" target="_blank"><i class="fa fa-rss"></i></a>
	</div>				</div>
											<div class="penci-headline-posts" data-auto="true" data-autotime="3000" data-speed="300" data-direction="vertical">
													<div>
								<a class="penci-topbar-post-title" href="http://massispost.com/2017/04/armenian-council-america-message-delivered-natalie-sarafian-times-square-commemoration/">Armenian Council of America Message Delivered by Natalie...</a>
							</div>
													<div>
								<a class="penci-topbar-post-title" href="http://massispost.com/2017/04/truth-justice-remembrance-prevail-times-square/">Truth, Justice &#038; Remembrance Prevail in Times Square</a>
							</div>
													<div>
								<a class="penci-topbar-post-title" href="http://massispost.com/2017/04/erdogan-sends-message-condolences-turkish-armenian-community/">Erdogan Sends Message of Condolences to the Turkish-Armenian...</a>
							</div>
													<div>
								<a class="penci-topbar-post-title" href="http://massispost.com/2017/04/president-trump-issues-statement-commemorating-meds-yeghern/">President Trump Issues Statement Commemorating “Meds Yeghern”</a>
							</div>
													<div>
								<a class="penci-topbar-post-title" href="http://massispost.com/2017/04/lost-evidence-armenian-genocide-discovered-jerusalem-archive/">Lost Evidence of Armenian Genocide Discovered in Jerusalem...</a>
							</div>
													<div>
								<a class="penci-topbar-post-title" href="http://massispost.com/2017/04/justin-trudeau-pays-tribute-armenian-genocide-victims/">Justin Trudeau Pays Tribute to Armenian Genocide Victims</a>
							</div>
													<div>
								<a class="penci-topbar-post-title" href="http://massispost.com/2017/04/garo-paylan-calls-research-armenian-genocide-era-deportation-law/">Garo Paylan Calls for Research Into Armenian Genocide-Era...</a>
							</div>
													<div>
								<a class="penci-topbar-post-title" href="http://massispost.com/2017/04/sarkisian-promises-radical-changes-armenia/">Sarkisian Again Promises ‘Radical Changes’ In Armenia</a>
							</div>
													<div>
								<a class="penci-topbar-post-title" href="http://massispost.com/2017/04/20-million-gift-creates-promise-institute-human-rights-ucla-school-law/">$20 Million Gift Creates Promise Institute for Human...</a>
							</div>
													<div>
								<a class="penci-topbar-post-title" href="http://massispost.com/2017/04/bagrat-estukyan-turkeys-armenian-community-voted-no-constitutional-referendum/">Bagrat Estukyan: Turkey’s Armenian Community Voted “No” in...</a>
							</div>
											</div>
									</div>
	</div>
</div>

<header id="header" class="header-header-3 has-bottom-line"><!-- #header -->
		<div class="inner-header">
		<div class="container align-left-logo">

			<div id="logo">
															<h2>
							<a href="http://massispost.com/"><img src="http://massispost.com/wp-content/uploads/2016/07/massismainnewB.jpg" alt="Armenian News By MassisPost" /></a>
						</h2>
												</div>

			
			
					</div>
	</div>
	
			<!-- Navigation -->
		<nav id="navigation" class="header-layout-bottom header-3">
			<div class="container">
				<div class="button-menu-mobile header-3"><i class="fa fa-bars"></i></div>
								<ul id="menu-massispost-1" class="menu"><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-23224"><a href="http://massispost.com">Home</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent penci-mega-menu menu-item-3216"><a href="http://massispost.com/category/news/">News</a>
<ul class="sub-menu">
	<li class="menu-item-0"><div class="penci-megamenu">		
		<div class="penci-content-megamenu">
			<div class="penci-mega-latest-posts col-mn-5 mega-row-1">
								<div class="penci-mega-row penci-mega-3 row-active">
											<div class="penci-mega-post">
							<div class="penci-mega-thumbnail">
																<span class="mega-cat-name">
																			News																	</span>
																<a href="http://massispost.com/2017/04/armenian-council-america-message-delivered-natalie-sarafian-times-square-commemoration/" title="Armenian Council of America Message Delivered by Natalie Sarafian During Times Square Commemoration">
																																																																													<img width="585" height="390" src="https://i1.wp.com/massispost.com/wp-content/uploads/2017/04/Natalie-4-24-2017-NY-Times-Square..jpg?resize=585%2C390" class="attachment-penci-thumb size-penci-thumb wp-post-image" alt="" />								</a>
							</div>
							<div class="penci-mega-meta">
								<h3 class="post-mega-title">
									<a href="http://massispost.com/2017/04/armenian-council-america-message-delivered-natalie-sarafian-times-square-commemoration/">Armenian Council of America Message Delivered by Natalie Sarafian During Times Square Commemoration</a>
								</h3>
																<p class="penci-mega-date">April 24, 2017</p>
															</div>
						</div>
											<div class="penci-mega-post">
							<div class="penci-mega-thumbnail">
																<span class="mega-cat-name">
																			News																	</span>
																<a href="http://massispost.com/2017/04/truth-justice-remembrance-prevail-times-square/" title="Truth, Justice &#038; Remembrance Prevail in Times Square">
																																																																						<i class="fa fa-picture-o"></i>
																												<img width="585" height="390" src="https://i2.wp.com/massispost.com/wp-content/uploads/2017/04/04232017_Lohr-Jones_102AGCTS_06.jpg?resize=585%2C390" class="attachment-penci-thumb size-penci-thumb wp-post-image" alt="" />								</a>
							</div>
							<div class="penci-mega-meta">
								<h3 class="post-mega-title">
									<a href="http://massispost.com/2017/04/truth-justice-remembrance-prevail-times-square/">Truth, Justice &#038; Remembrance Prevail in Times Square</a>
								</h3>
																<p class="penci-mega-date">April 24, 2017</p>
															</div>
						</div>
											<div class="penci-mega-post">
							<div class="penci-mega-thumbnail">
																<span class="mega-cat-name">
																			News																	</span>
																<a href="http://massispost.com/2017/04/2017-aurora-prize-finalists-announced/" title="2017 Aurora Prize Finalists Announced">
																																																																													<img width="585" height="390" src="https://i1.wp.com/massispost.com/wp-content/uploads/2017/04/2017_finalists_Aurora.jpg?resize=585%2C390" class="attachment-penci-thumb size-penci-thumb wp-post-image" alt="" srcset="https://i1.wp.com/massispost.com/wp-content/uploads/2017/04/2017_finalists_Aurora.jpg?w=800 800w, https://i1.wp.com/massispost.com/wp-content/uploads/2017/04/2017_finalists_Aurora.jpg?resize=300%2C200 300w, https://i1.wp.com/massispost.com/wp-content/uploads/2017/04/2017_finalists_Aurora.jpg?resize=768%2C511 768w, https://i1.wp.com/massispost.com/wp-content/uploads/2017/04/2017_finalists_Aurora.jpg?resize=585%2C389 585w" sizes="(max-width: 585px) 100vw, 585px" />								</a>
							</div>
							<div class="penci-mega-meta">
								<h3 class="post-mega-title">
									<a href="http://massispost.com/2017/04/2017-aurora-prize-finalists-announced/">2017 Aurora Prize Finalists Announced</a>
								</h3>
																<p class="penci-mega-date">April 24, 2017</p>
															</div>
						</div>
											<div class="penci-mega-post">
							<div class="penci-mega-thumbnail">
																<span class="mega-cat-name">
																			News																	</span>
																<a href="http://massispost.com/2017/04/erdogan-sends-message-condolences-turkish-armenian-community/" title="Erdogan Sends Message of Condolences to the Turkish-Armenian Community">
																																																																													<img width="585" height="390" src="https://i1.wp.com/massispost.com/wp-content/uploads/2017/04/erdogan.jpg?resize=585%2C390" class="attachment-penci-thumb size-penci-thumb wp-post-image" alt="" />								</a>
							</div>
							<div class="penci-mega-meta">
								<h3 class="post-mega-title">
									<a href="http://massispost.com/2017/04/erdogan-sends-message-condolences-turkish-armenian-community/">Erdogan Sends Message of Condolences to the Turkish-Armenian Community</a>
								</h3>
																<p class="penci-mega-date">April 24, 2017</p>
															</div>
						</div>
											<div class="penci-mega-post">
							<div class="penci-mega-thumbnail">
																<span class="mega-cat-name">
																			News																	</span>
																<a href="http://massispost.com/2017/04/president-trump-issues-statement-commemorating-meds-yeghern/" title="President Trump Issues Statement Commemorating  “Meds Yeghern”">
																																																																													<img width="585" height="390" src="https://i1.wp.com/massispost.com/wp-content/uploads/2016/11/Trump.jpg?resize=585%2C390" class="attachment-penci-thumb size-penci-thumb wp-post-image" alt="" />								</a>
							</div>
							<div class="penci-mega-meta">
								<h3 class="post-mega-title">
									<a href="http://massispost.com/2017/04/president-trump-issues-statement-commemorating-meds-yeghern/">President Trump Issues Statement Commemorating  “Meds Yeghern”</a>
								</h3>
																<p class="penci-mega-date">April 24, 2017</p>
															</div>
						</div>
									</div>
							</div>
		</div>

		</div></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category penci-mega-menu menu-item-3217"><a href="http://massispost.com/category/armenia/">Armenia</a>
<ul class="sub-menu">
	<li class="menu-item-0"><div class="penci-megamenu">				<div class="penci-mega-child-categories">
							<a class="mega-cat-child cat-active" href="http://massispost.com/category/armenia/" data-id="penci-mega-5">All</a>
							<a class="mega-cat-child" href="http://massispost.com/category/armenia/artsakh/" data-id="penci-mega-8">Artsakh</a>
					</div>
		
		<div class="penci-content-megamenu">
			<div class="penci-mega-latest-posts col-mn-4 mega-row-1">
								<div class="penci-mega-row penci-mega-5 row-active">
											<div class="penci-mega-post">
							<div class="penci-mega-thumbnail">
																<span class="mega-cat-name">
																			Armenia																	</span>
																<a href="http://massispost.com/2017/04/2017-aurora-prize-finalists-announced/" title="2017 Aurora Prize Finalists Announced">
																																																																													<img width="585" height="390" src="https://i1.wp.com/massispost.com/wp-content/uploads/2017/04/2017_finalists_Aurora.jpg?resize=585%2C390" class="attachment-penci-thumb size-penci-thumb wp-post-image" alt="" srcset="https://i1.wp.com/massispost.com/wp-content/uploads/2017/04/2017_finalists_Aurora.jpg?w=800 800w, https://i1.wp.com/massispost.com/wp-content/uploads/2017/04/2017_finalists_Aurora.jpg?resize=300%2C200 300w, https://i1.wp.com/massispost.com/wp-content/uploads/2017/04/2017_finalists_Aurora.jpg?resize=768%2C511 768w, https://i1.wp.com/massispost.com/wp-content/uploads/2017/04/2017_finalists_Aurora.jpg?resize=585%2C389 585w" sizes="(max-width: 585px) 100vw, 585px" />								</a>
							</div>
							<div class="penci-mega-meta">
								<h3 class="post-mega-title">
									<a href="http://massispost.com/2017/04/2017-aurora-prize-finalists-announced/">2017 Aurora Prize Finalists Announced</a>
								</h3>
																<p class="penci-mega-date">April 24, 2017</p>
															</div>
						</div>
											<div class="penci-mega-post">
							<div class="penci-mega-thumbnail">
																<span class="mega-cat-name">
																			Armenia																	</span>
																<a href="http://massispost.com/2017/04/sarkisian-promises-radical-changes-armenia/" title="Sarkisian Again Promises ‘Radical Changes’ In Armenia">
																																																																													<img width="585" height="390" src="https://i0.wp.com/massispost.com/wp-content/uploads/2017/04/sarkisian.jpg?resize=585%2C390" class="attachment-penci-thumb size-penci-thumb wp-post-image" alt="" srcset="https://i0.wp.com/massispost.com/wp-content/uploads/2017/04/sarkisian.jpg?w=850 850w, https://i0.wp.com/massispost.com/wp-content/uploads/2017/04/sarkisian.jpg?resize=300%2C200 300w, https://i0.wp.com/massispost.com/wp-content/uploads/2017/04/sarkisian.jpg?resize=768%2C511 768w, https://i0.wp.com/massispost.com/wp-content/uploads/2017/04/sarkisian.jpg?resize=585%2C390 585w" sizes="(max-width: 585px) 100vw, 585px" />								</a>
							</div>
							<div class="penci-mega-meta">
								<h3 class="post-mega-title">
									<a href="http://massispost.com/2017/04/sarkisian-promises-radical-changes-armenia/">Sarkisian Again Promises ‘Radical Changes’ In Armenia</a>
								</h3>
																<p class="penci-mega-date">April 21, 2017</p>
															</div>
						</div>
											<div class="penci-mega-post">
							<div class="penci-mega-thumbnail">
																<span class="mega-cat-name">
																			Armenia																	</span>
																<a href="http://massispost.com/2017/04/winners-first-open-call-artist-armenia-art-foundation-announced/" title="Winners of the First Open Call for Artist of Armenia Art Foundation Announced">
																																																																													<img width="585" height="390" src="https://i1.wp.com/massispost.com/wp-content/uploads/2017/04/ArmenianArtsFoundation.jpg?resize=585%2C390" class="attachment-penci-thumb size-penci-thumb wp-post-image" alt="" />								</a>
							</div>
							<div class="penci-mega-meta">
								<h3 class="post-mega-title">
									<a href="http://massispost.com/2017/04/winners-first-open-call-artist-armenia-art-foundation-announced/">Winners of the First Open Call for Artist of Armenia Art Foundation Announced</a>
								</h3>
																<p class="penci-mega-date">April 19, 2017</p>
															</div>
						</div>
											<div class="penci-mega-post">
							<div class="penci-mega-thumbnail">
																<span class="mega-cat-name">
																			Artsakh																	</span>
																<a href="http://massispost.com/2017/04/irans-defense-minister-warns-attempts-resolve-karabakh-conflict-force/" title="Iran’s Defense Minister Warns Against Attempts to Resolve Karabakh Conflict by Force">
																																																																													<img width="585" height="390" src="https://i2.wp.com/massispost.com/wp-content/uploads/2017/04/Iran-Defense-Minister.jpg?resize=585%2C390" class="attachment-penci-thumb size-penci-thumb wp-post-image" alt="" />								</a>
							</div>
							<div class="penci-mega-meta">
								<h3 class="post-mega-title">
									<a href="http://massispost.com/2017/04/irans-defense-minister-warns-attempts-resolve-karabakh-conflict-force/">Iran’s Defense Minister Warns Against Attempts to Resolve Karabakh Conflict by Force</a>
								</h3>
																<p class="penci-mega-date">April 17, 2017</p>
															</div>
						</div>
									</div>
								<div class="penci-mega-row penci-mega-8">
											<div class="penci-mega-post">
							<div class="penci-mega-thumbnail">
																<span class="mega-cat-name">
																			Artsakh																	</span>
																<a href="http://massispost.com/2017/04/irans-defense-minister-warns-attempts-resolve-karabakh-conflict-force/" title="Iran’s Defense Minister Warns Against Attempts to Resolve Karabakh Conflict by Force">
																																																																													<img width="585" height="390" src="https://i2.wp.com/massispost.com/wp-content/uploads/2017/04/Iran-Defense-Minister.jpg?resize=585%2C390" class="attachment-penci-thumb size-penci-thumb wp-post-image" alt="" />								</a>
							</div>
							<div class="penci-mega-meta">
								<h3 class="post-mega-title">
									<a href="http://massispost.com/2017/04/irans-defense-minister-warns-attempts-resolve-karabakh-conflict-force/">Iran’s Defense Minister Warns Against Attempts to Resolve Karabakh Conflict by Force</a>
								</h3>
																<p class="penci-mega-date">April 17, 2017</p>
															</div>
						</div>
											<div class="penci-mega-post">
							<div class="penci-mega-thumbnail">
																<span class="mega-cat-name">
																			Artsakh																	</span>
																<a href="http://massispost.com/2017/04/restoration-works-mosque-shushi-line-withprovisions-international-conventions/" title="Restoration Works of Mosque in Shushi Are in Line With Provisions of International Conventions">
																																																																													<img width="585" height="390" src="https://i1.wp.com/massispost.com/wp-content/uploads/2017/04/shushi-mosque.jpg?resize=585%2C390" class="attachment-penci-thumb size-penci-thumb wp-post-image" alt="" />								</a>
							</div>
							<div class="penci-mega-meta">
								<h3 class="post-mega-title">
									<a href="http://massispost.com/2017/04/restoration-works-mosque-shushi-line-withprovisions-international-conventions/">Restoration Works of Mosque in Shushi Are in Line With Provisions of International Conventions</a>
								</h3>
																<p class="penci-mega-date">April 14, 2017</p>
															</div>
						</div>
											<div class="penci-mega-post">
							<div class="penci-mega-thumbnail">
																<span class="mega-cat-name">
																			Artsakh																	</span>
																<a href="http://massispost.com/2017/04/nagorno-karabakh-conflict-cannot-settled-military-means-french-mfa-statement/" title="Nagorno Karabakh Conflict Cannot be Settled by Military Means: French MFA Statement">
																																																																													<img width="585" height="390" src="https://i1.wp.com/massispost.com/wp-content/uploads/2017/04/french-mfa.jpg?resize=585%2C390" class="attachment-penci-thumb size-penci-thumb wp-post-image" alt="" srcset="https://i1.wp.com/massispost.com/wp-content/uploads/2017/04/french-mfa.jpg?resize=300%2C201 300w, https://i1.wp.com/massispost.com/wp-content/uploads/2017/04/french-mfa.jpg?resize=585%2C390 585w" sizes="(max-width: 585px) 100vw, 585px" />								</a>
							</div>
							<div class="penci-mega-meta">
								<h3 class="post-mega-title">
									<a href="http://massispost.com/2017/04/nagorno-karabakh-conflict-cannot-settled-military-means-french-mfa-statement/">Nagorno Karabakh Conflict Cannot be Settled by Military Means: French MFA Statement</a>
								</h3>
																<p class="penci-mega-date">April 6, 2017</p>
															</div>
						</div>
											<div class="penci-mega-post">
							<div class="penci-mega-thumbnail">
																<span class="mega-cat-name">
																			Artsakh																	</span>
																<a href="http://massispost.com/2017/04/spirit-firm-will-unshakeable-artsakh-president-bako-sahakyan/" title="‘Our Spirit is Firm, Our Will is Unshakeable’-Artsakh President Bako Sahakyan">
																																																																													<img width="585" height="390" src="https://i1.wp.com/massispost.com/wp-content/uploads/2016/08/bako-sahakian.jpg?resize=585%2C390" class="attachment-penci-thumb size-penci-thumb wp-post-image" alt="" />								</a>
							</div>
							<div class="penci-mega-meta">
								<h3 class="post-mega-title">
									<a href="http://massispost.com/2017/04/spirit-firm-will-unshakeable-artsakh-president-bako-sahakyan/">‘Our Spirit is Firm, Our Will is Unshakeable’-Artsakh President Bako Sahakyan</a>
								</h3>
																<p class="penci-mega-date">April 1, 2017</p>
															</div>
						</div>
									</div>
							</div>
		</div>

		</div></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent penci-mega-menu menu-item-3220"><a href="http://massispost.com/category/community/">Community</a>
<ul class="sub-menu">
	<li class="menu-item-0"><div class="penci-megamenu">		
		<div class="penci-content-megamenu">
			<div class="penci-mega-latest-posts col-mn-5 mega-row-1">
								<div class="penci-mega-row penci-mega-6 row-active">
											<div class="penci-mega-post">
							<div class="penci-mega-thumbnail">
																<span class="mega-cat-name">
																			Community																	</span>
																<a href="http://massispost.com/2017/04/armenian-council-america-message-delivered-natalie-sarafian-times-square-commemoration/" title="Armenian Council of America Message Delivered by Natalie Sarafian During Times Square Commemoration">
																																																																													<img width="585" height="390" src="https://i1.wp.com/massispost.com/wp-content/uploads/2017/04/Natalie-4-24-2017-NY-Times-Square..jpg?resize=585%2C390" class="attachment-penci-thumb size-penci-thumb wp-post-image" alt="" />								</a>
							</div>
							<div class="penci-mega-meta">
								<h3 class="post-mega-title">
									<a href="http://massispost.com/2017/04/armenian-council-america-message-delivered-natalie-sarafian-times-square-commemoration/">Armenian Council of America Message Delivered by Natalie Sarafian During Times Square Commemoration</a>
								</h3>
																<p class="penci-mega-date">April 24, 2017</p>
															</div>
						</div>
											<div class="penci-mega-post">
							<div class="penci-mega-thumbnail">
																<span class="mega-cat-name">
																			Community																	</span>
																<a href="http://massispost.com/2017/04/truth-justice-remembrance-prevail-times-square/" title="Truth, Justice &#038; Remembrance Prevail in Times Square">
																																																																						<i class="fa fa-picture-o"></i>
																												<img width="585" height="390" src="https://i2.wp.com/massispost.com/wp-content/uploads/2017/04/04232017_Lohr-Jones_102AGCTS_06.jpg?resize=585%2C390" class="attachment-penci-thumb size-penci-thumb wp-post-image" alt="" />								</a>
							</div>
							<div class="penci-mega-meta">
								<h3 class="post-mega-title">
									<a href="http://massispost.com/2017/04/truth-justice-remembrance-prevail-times-square/">Truth, Justice &#038; Remembrance Prevail in Times Square</a>
								</h3>
																<p class="penci-mega-date">April 24, 2017</p>
															</div>
						</div>
											<div class="penci-mega-post">
							<div class="penci-mega-thumbnail">
																<span class="mega-cat-name">
																			Community																	</span>
																<a href="http://massispost.com/2017/04/agbu-hye-geen-young-circle-annual-international-conference-evaluating-changes-within-armenian-family/" title="AGBU Hye Geen &#038; the Young Circle Annual International Conference Evaluating Changes Within the Armenian Family">
																																																																													<img width="585" height="390" src="https://i1.wp.com/massispost.com/wp-content/uploads/2017/04/HayGeen.jpg?resize=585%2C390" class="attachment-penci-thumb size-penci-thumb wp-post-image" alt="" />								</a>
							</div>
							<div class="penci-mega-meta">
								<h3 class="post-mega-title">
									<a href="http://massispost.com/2017/04/agbu-hye-geen-young-circle-annual-international-conference-evaluating-changes-within-armenian-family/">AGBU Hye Geen &#038; the Young Circle Annual International Conference Evaluating Changes Within the Armenian Family</a>
								</h3>
																<p class="penci-mega-date">April 19, 2017</p>
															</div>
						</div>
											<div class="penci-mega-post">
							<div class="penci-mega-thumbnail">
																<span class="mega-cat-name">
																			Community																	</span>
																<a href="http://massispost.com/2017/04/20-million-gift-creates-promise-institute-human-rights-ucla-school-law/" title="$20 Million Gift Creates Promise Institute for Human Rights at UCLA School of Law">
																																																																													<img width="585" height="390" src="https://i1.wp.com/massispost.com/wp-content/uploads/2017/04/EsrailianandMnookin_mid.jpg?resize=585%2C390" class="attachment-penci-thumb size-penci-thumb wp-post-image" alt="" srcset="https://i1.wp.com/massispost.com/wp-content/uploads/2017/04/EsrailianandMnookin_mid.jpg?w=850 850w, https://i1.wp.com/massispost.com/wp-content/uploads/2017/04/EsrailianandMnookin_mid.jpg?resize=300%2C200 300w, https://i1.wp.com/massispost.com/wp-content/uploads/2017/04/EsrailianandMnookin_mid.jpg?resize=768%2C511 768w, https://i1.wp.com/massispost.com/wp-content/uploads/2017/04/EsrailianandMnookin_mid.jpg?resize=585%2C390 585w" sizes="(max-width: 585px) 100vw, 585px" />								</a>
							</div>
							<div class="penci-mega-meta">
								<h3 class="post-mega-title">
									<a href="http://massispost.com/2017/04/20-million-gift-creates-promise-institute-human-rights-ucla-school-law/">$20 Million Gift Creates Promise Institute for Human Rights at UCLA School of Law</a>
								</h3>
																<p class="penci-mega-date">April 18, 2017</p>
															</div>
						</div>
											<div class="penci-mega-post">
							<div class="penci-mega-thumbnail">
																<span class="mega-cat-name">
																			Community																	</span>
																<a href="http://massispost.com/2017/04/los-angeles-county-proclaims-armenian-genocide-day-remembrance/" title="Los Angeles County Proclaims Armenian Genocide Day of Remembrance">
																																																																													<img width="585" height="390" src="https://i2.wp.com/massispost.com/wp-content/uploads/2017/04/HS7_7018.jpg?resize=585%2C390" class="attachment-penci-thumb size-penci-thumb wp-post-image" alt="" srcset="https://i2.wp.com/massispost.com/wp-content/uploads/2017/04/HS7_7018.jpg?resize=585%2C390 585w, https://i2.wp.com/massispost.com/wp-content/uploads/2017/04/HS7_7018.jpg?zoom=2&amp;resize=585%2C390 1170w" sizes="(max-width: 585px) 100vw, 585px" />								</a>
							</div>
							<div class="penci-mega-meta">
								<h3 class="post-mega-title">
									<a href="http://massispost.com/2017/04/los-angeles-county-proclaims-armenian-genocide-day-remembrance/">Los Angeles County Proclaims Armenian Genocide Day of Remembrance</a>
								</h3>
																<p class="penci-mega-date">April 18, 2017</p>
															</div>
						</div>
									</div>
							</div>
		</div>

		</div></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category penci-mega-menu menu-item-3218"><a href="http://massispost.com/category/world/">World</a>
<ul class="sub-menu">
	<li class="menu-item-0"><div class="penci-megamenu">		
		<div class="penci-content-megamenu">
			<div class="penci-mega-latest-posts col-mn-5 mega-row-1">
								<div class="penci-mega-row penci-mega-4 row-active">
											<div class="penci-mega-post">
							<div class="penci-mega-thumbnail">
																<span class="mega-cat-name">
																			World																	</span>
																<a href="http://massispost.com/2017/04/erdogan-sends-message-condolences-turkish-armenian-community/" title="Erdogan Sends Message of Condolences to the Turkish-Armenian Community">
																																																																													<img width="585" height="390" src="https://i1.wp.com/massispost.com/wp-content/uploads/2017/04/erdogan.jpg?resize=585%2C390" class="attachment-penci-thumb size-penci-thumb wp-post-image" alt="" />								</a>
							</div>
							<div class="penci-mega-meta">
								<h3 class="post-mega-title">
									<a href="http://massispost.com/2017/04/erdogan-sends-message-condolences-turkish-armenian-community/">Erdogan Sends Message of Condolences to the Turkish-Armenian Community</a>
								</h3>
																<p class="penci-mega-date">April 24, 2017</p>
															</div>
						</div>
											<div class="penci-mega-post">
							<div class="penci-mega-thumbnail">
																<span class="mega-cat-name">
																			World																	</span>
																<a href="http://massispost.com/2017/04/justin-trudeau-pays-tribute-armenian-genocide-victims/" title="Justin Trudeau Pays Tribute to Armenian Genocide Victims">
																																																																													<img width="585" height="390" src="https://i0.wp.com/massispost.com/wp-content/uploads/2017/04/Justin-Trudeau.jpg?resize=585%2C390" class="attachment-penci-thumb size-penci-thumb wp-post-image" alt="" />								</a>
							</div>
							<div class="penci-mega-meta">
								<h3 class="post-mega-title">
									<a href="http://massispost.com/2017/04/justin-trudeau-pays-tribute-armenian-genocide-victims/">Justin Trudeau Pays Tribute to Armenian Genocide Victims</a>
								</h3>
																<p class="penci-mega-date">April 22, 2017</p>
															</div>
						</div>
											<div class="penci-mega-post">
							<div class="penci-mega-thumbnail">
																<span class="mega-cat-name">
																			World																	</span>
																<a href="http://massispost.com/2017/04/eu-observers-claim-irregularities-possible-vote-tampering-turkish-referendum/" title="EU Observers Claim Irregularities, Possible Vote Tampering In Turkish Referendum">
																																																																													<img width="585" height="390" src="https://i1.wp.com/massispost.com/wp-content/uploads/2017/04/Protsts-Turkey.jpg?resize=585%2C390" class="attachment-penci-thumb size-penci-thumb wp-post-image" alt="" />								</a>
							</div>
							<div class="penci-mega-meta">
								<h3 class="post-mega-title">
									<a href="http://massispost.com/2017/04/eu-observers-claim-irregularities-possible-vote-tampering-turkish-referendum/">EU Observers Claim Irregularities, Possible Vote Tampering In Turkish Referendum</a>
								</h3>
																<p class="penci-mega-date">April 18, 2017</p>
															</div>
						</div>
											<div class="penci-mega-post">
							<div class="penci-mega-thumbnail">
																<span class="mega-cat-name">
																			World																	</span>
																<a href="http://massispost.com/2017/04/irans-defense-minister-warns-attempts-resolve-karabakh-conflict-force/" title="Iran’s Defense Minister Warns Against Attempts to Resolve Karabakh Conflict by Force">
																																																																													<img width="585" height="390" src="https://i2.wp.com/massispost.com/wp-content/uploads/2017/04/Iran-Defense-Minister.jpg?resize=585%2C390" class="attachment-penci-thumb size-penci-thumb wp-post-image" alt="" />								</a>
							</div>
							<div class="penci-mega-meta">
								<h3 class="post-mega-title">
									<a href="http://massispost.com/2017/04/irans-defense-minister-warns-attempts-resolve-karabakh-conflict-force/">Iran’s Defense Minister Warns Against Attempts to Resolve Karabakh Conflict by Force</a>
								</h3>
																<p class="penci-mega-date">April 17, 2017</p>
															</div>
						</div>
											<div class="penci-mega-post">
							<div class="penci-mega-thumbnail">
																<span class="mega-cat-name">
																			World																	</span>
																<a href="http://massispost.com/2017/04/bagrat-estukyan-turkeys-armenian-community-voted-no-constitutional-referendum/" title="Bagrat Estukyan: Turkey’s Armenian Community Voted “No” in Constitutional Referendum">
																																																																													<img width="585" height="390" src="https://i1.wp.com/massispost.com/wp-content/uploads/2017/04/referandum-Yes-No.jpg?resize=585%2C390" class="attachment-penci-thumb size-penci-thumb wp-post-image" alt="" />								</a>
							</div>
							<div class="penci-mega-meta">
								<h3 class="post-mega-title">
									<a href="http://massispost.com/2017/04/bagrat-estukyan-turkeys-armenian-community-voted-no-constitutional-referendum/">Bagrat Estukyan: Turkey’s Armenian Community Voted “No” in Constitutional Referendum</a>
								</h3>
																<p class="penci-mega-date">April 17, 2017</p>
															</div>
						</div>
									</div>
							</div>
		</div>

		</div></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent penci-mega-menu menu-item-3228"><a href="http://massispost.com/category/armenian-genocide/">Armenian Genocide</a>
<ul class="sub-menu">
	<li class="menu-item-0"><div class="penci-megamenu">		
		<div class="penci-content-megamenu">
			<div class="penci-mega-latest-posts col-mn-5 mega-row-1">
								<div class="penci-mega-row penci-mega-12 row-active">
											<div class="penci-mega-post">
							<div class="penci-mega-thumbnail">
																<span class="mega-cat-name">
																			Armenian Genocide																	</span>
																<a href="http://massispost.com/2017/04/armenian-council-america-message-delivered-natalie-sarafian-times-square-commemoration/" title="Armenian Council of America Message Delivered by Natalie Sarafian During Times Square Commemoration">
																																																																													<img width="585" height="390" src="https://i1.wp.com/massispost.com/wp-content/uploads/2017/04/Natalie-4-24-2017-NY-Times-Square..jpg?resize=585%2C390" class="attachment-penci-thumb size-penci-thumb wp-post-image" alt="" />								</a>
							</div>
							<div class="penci-mega-meta">
								<h3 class="post-mega-title">
									<a href="http://massispost.com/2017/04/armenian-council-america-message-delivered-natalie-sarafian-times-square-commemoration/">Armenian Council of America Message Delivered by Natalie Sarafian During Times Square Commemoration</a>
								</h3>
																<p class="penci-mega-date">April 24, 2017</p>
															</div>
						</div>
											<div class="penci-mega-post">
							<div class="penci-mega-thumbnail">
																<span class="mega-cat-name">
																			Armenian Genocide																	</span>
																<a href="http://massispost.com/2017/04/truth-justice-remembrance-prevail-times-square/" title="Truth, Justice &#038; Remembrance Prevail in Times Square">
																																																																						<i class="fa fa-picture-o"></i>
																												<img width="585" height="390" src="https://i2.wp.com/massispost.com/wp-content/uploads/2017/04/04232017_Lohr-Jones_102AGCTS_06.jpg?resize=585%2C390" class="attachment-penci-thumb size-penci-thumb wp-post-image" alt="" />								</a>
							</div>
							<div class="penci-mega-meta">
								<h3 class="post-mega-title">
									<a href="http://massispost.com/2017/04/truth-justice-remembrance-prevail-times-square/">Truth, Justice &#038; Remembrance Prevail in Times Square</a>
								</h3>
																<p class="penci-mega-date">April 24, 2017</p>
															</div>
						</div>
											<div class="penci-mega-post">
							<div class="penci-mega-thumbnail">
																<span class="mega-cat-name">
																			Armenian Genocide																	</span>
																<a href="http://massispost.com/2017/04/erdogan-sends-message-condolences-turkish-armenian-community/" title="Erdogan Sends Message of Condolences to the Turkish-Armenian Community">
																																																																													<img width="585" height="390" src="https://i1.wp.com/massispost.com/wp-content/uploads/2017/04/erdogan.jpg?resize=585%2C390" class="attachment-penci-thumb size-penci-thumb wp-post-image" alt="" />								</a>
							</div>
							<div class="penci-mega-meta">
								<h3 class="post-mega-title">
									<a href="http://massispost.com/2017/04/erdogan-sends-message-condolences-turkish-armenian-community/">Erdogan Sends Message of Condolences to the Turkish-Armenian Community</a>
								</h3>
																<p class="penci-mega-date">April 24, 2017</p>
															</div>
						</div>
											<div class="penci-mega-post">
							<div class="penci-mega-thumbnail">
																<span class="mega-cat-name">
																			Armenian Genocide																	</span>
																<a href="http://massispost.com/2017/04/president-trump-issues-statement-commemorating-meds-yeghern/" title="President Trump Issues Statement Commemorating  “Meds Yeghern”">
																																																																													<img width="585" height="390" src="https://i1.wp.com/massispost.com/wp-content/uploads/2016/11/Trump.jpg?resize=585%2C390" class="attachment-penci-thumb size-penci-thumb wp-post-image" alt="" />								</a>
							</div>
							<div class="penci-mega-meta">
								<h3 class="post-mega-title">
									<a href="http://massispost.com/2017/04/president-trump-issues-statement-commemorating-meds-yeghern/">President Trump Issues Statement Commemorating  “Meds Yeghern”</a>
								</h3>
																<p class="penci-mega-date">April 24, 2017</p>
															</div>
						</div>
											<div class="penci-mega-post">
							<div class="penci-mega-thumbnail">
																<span class="mega-cat-name">
																			Armenian Genocide																	</span>
																<a href="http://massispost.com/2017/04/lost-evidence-armenian-genocide-discovered-jerusalem-archive/" title="Lost Evidence of Armenian Genocide Discovered in Jerusalem Archive">
																																																																													<img width="585" height="390" src="https://i2.wp.com/massispost.com/wp-content/uploads/2017/04/Hunchakian_gallows-1.jpg?resize=585%2C390" class="attachment-penci-thumb size-penci-thumb wp-post-image" alt="" />								</a>
							</div>
							<div class="penci-mega-meta">
								<h3 class="post-mega-title">
									<a href="http://massispost.com/2017/04/lost-evidence-armenian-genocide-discovered-jerusalem-archive/">Lost Evidence of Armenian Genocide Discovered in Jerusalem Archive</a>
								</h3>
																<p class="penci-mega-date">April 23, 2017</p>
															</div>
						</div>
									</div>
							</div>
		</div>

		</div></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category penci-mega-menu menu-item-3223"><a href="http://massispost.com/category/commentary/">Commentary</a>
<ul class="sub-menu">
	<li class="menu-item-0"><div class="penci-megamenu">		
		<div class="penci-content-megamenu">
			<div class="penci-mega-latest-posts col-mn-5 mega-row-1">
								<div class="penci-mega-row penci-mega-9 row-active">
											<div class="penci-mega-post">
							<div class="penci-mega-thumbnail">
																<span class="mega-cat-name">
																			Commentary																	</span>
																<a href="http://massispost.com/2017/04/armenians-didnt-arrive-accident-promise-largely/" title="Armenians Didn’t Arrive Here by Accident. ‘The Promise’ is Largely Why">
																																																																													<img width="585" height="390" src="https://i2.wp.com/massispost.com/wp-content/uploads/2016/09/the-promise-trailer.jpg?resize=585%2C390" class="attachment-penci-thumb size-penci-thumb wp-post-image" alt="" />								</a>
							</div>
							<div class="penci-mega-meta">
								<h3 class="post-mega-title">
									<a href="http://massispost.com/2017/04/armenians-didnt-arrive-accident-promise-largely/">Armenians Didn’t Arrive Here by Accident. ‘The Promise’ is Largely Why</a>
								</h3>
																<p class="penci-mega-date">April 17, 2017</p>
															</div>
						</div>
											<div class="penci-mega-post">
							<div class="penci-mega-thumbnail">
																<span class="mega-cat-name">
																			Commentary																	</span>
																<a href="http://massispost.com/2017/04/zoryan-institute-reflects-regressive-trends-human-rights-genocide-awareness-month/" title="The Zoryan Institute Reflects on the Regressive Trends in Human Rights during Genocide Awareness Month">
																																																																													<img width="585" height="304" src="https://i2.wp.com/massispost.com/wp-content/uploads/2017/04/UnitedToEndGenocide.jpg?resize=585%2C304" class="attachment-penci-thumb size-penci-thumb wp-post-image" alt="" />								</a>
							</div>
							<div class="penci-mega-meta">
								<h3 class="post-mega-title">
									<a href="http://massispost.com/2017/04/zoryan-institute-reflects-regressive-trends-human-rights-genocide-awareness-month/">The Zoryan Institute Reflects on the Regressive Trends in Human Rights during Genocide Awareness Month</a>
								</h3>
																<p class="penci-mega-date">April 13, 2017</p>
															</div>
						</div>
											<div class="penci-mega-post">
							<div class="penci-mega-thumbnail">
																<span class="mega-cat-name">
																			Commentary																	</span>
																<a href="http://massispost.com/2017/03/pro-turkish-journalist-stephen-kinzers-assault-armenian-genocide-armenians/" title="Pro-Turkish Journalist Stephen Kinzer’s Assault on the Armenian Genocide and Armenians">
																																																																													<img width="585" height="390" src="https://i1.wp.com/massispost.com/wp-content/uploads/2017/03/Stephen-Kinzer.jpg?resize=585%2C390" class="attachment-penci-thumb size-penci-thumb wp-post-image" alt="" />								</a>
							</div>
							<div class="penci-mega-meta">
								<h3 class="post-mega-title">
									<a href="http://massispost.com/2017/03/pro-turkish-journalist-stephen-kinzers-assault-armenian-genocide-armenians/">Pro-Turkish Journalist Stephen Kinzer’s Assault on the Armenian Genocide and Armenians</a>
								</h3>
																<p class="penci-mega-date">March 29, 2017</p>
															</div>
						</div>
											<div class="penci-mega-post">
							<div class="penci-mega-thumbnail">
																<span class="mega-cat-name">
																			Commentary																	</span>
																<a href="http://massispost.com/2017/03/patriarchal-election-deja-vu-turkey-government-meddling-election-inevitable-not-decisive/" title="Patriarchal Election Déjà Vu in Turkey: Government Meddling in the Election is Inevitable, But Not Decisive">
																																																																													<img width="585" height="390" src="https://i1.wp.com/massispost.com/wp-content/uploads/2017/03/Armenian-Patriarchate-Istanbul.jpg?resize=585%2C390" class="attachment-penci-thumb size-penci-thumb wp-post-image" alt="" />								</a>
							</div>
							<div class="penci-mega-meta">
								<h3 class="post-mega-title">
									<a href="http://massispost.com/2017/03/patriarchal-election-deja-vu-turkey-government-meddling-election-inevitable-not-decisive/">Patriarchal Election Déjà Vu in Turkey: Government Meddling in the Election is Inevitable, But Not Decisive</a>
								</h3>
																<p class="penci-mega-date">March 27, 2017</p>
															</div>
						</div>
											<div class="penci-mega-post">
							<div class="penci-mega-thumbnail">
																<span class="mega-cat-name">
																			Commentary																	</span>
																<a href="http://massispost.com/2017/03/returning-greater-armenia-civilizational-path-armenians/" title="Returning to Greater Armenia: Civilizational Path of Armenians">
																																																																													<img width="585" height="390" src="https://i2.wp.com/massispost.com/wp-content/uploads/2017/03/1440949157_tigran-765x510.jpg?resize=585%2C390" class="attachment-penci-thumb size-penci-thumb wp-post-image" alt="" srcset="https://i2.wp.com/massispost.com/wp-content/uploads/2017/03/1440949157_tigran-765x510.jpg?resize=765%2C510 765w, https://i2.wp.com/massispost.com/wp-content/uploads/2017/03/1440949157_tigran-765x510.jpg?resize=300%2C200 300w, https://i2.wp.com/massispost.com/wp-content/uploads/2017/03/1440949157_tigran-765x510.jpg?resize=585%2C390 585w" sizes="(max-width: 585px) 100vw, 585px" />								</a>
							</div>
							<div class="penci-mega-meta">
								<h3 class="post-mega-title">
									<a href="http://massispost.com/2017/03/returning-greater-armenia-civilizational-path-armenians/">Returning to Greater Armenia: Civilizational Path of Armenians</a>
								</h3>
																<p class="penci-mega-date">March 12, 2017</p>
															</div>
						</div>
									</div>
							</div>
		</div>

		</div></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category penci-mega-menu menu-item-23223"><a href="http://massispost.com/category/culture/">Arts &#038; Culture</a>
<ul class="sub-menu">
	<li class="menu-item-0"><div class="penci-megamenu">		
		<div class="penci-content-megamenu">
			<div class="penci-mega-latest-posts col-mn-5 mega-row-1">
								<div class="penci-mega-row penci-mega-10 row-active">
											<div class="penci-mega-post">
							<div class="penci-mega-thumbnail">
																<span class="mega-cat-name">
																			Arts &amp; Culture																	</span>
																<a href="http://massispost.com/2017/04/winners-first-open-call-artist-armenia-art-foundation-announced/" title="Winners of the First Open Call for Artist of Armenia Art Foundation Announced">
																																																																													<img width="585" height="390" src="https://i1.wp.com/massispost.com/wp-content/uploads/2017/04/ArmenianArtsFoundation.jpg?resize=585%2C390" class="attachment-penci-thumb size-penci-thumb wp-post-image" alt="" />								</a>
							</div>
							<div class="penci-mega-meta">
								<h3 class="post-mega-title">
									<a href="http://massispost.com/2017/04/winners-first-open-call-artist-armenia-art-foundation-announced/">Winners of the First Open Call for Artist of Armenia Art Foundation Announced</a>
								</h3>
																<p class="penci-mega-date">April 19, 2017</p>
															</div>
						</div>
											<div class="penci-mega-post">
							<div class="penci-mega-thumbnail">
																<span class="mega-cat-name">
																			Arts &amp; Culture																	</span>
																<a href="http://massispost.com/2017/04/armenians-didnt-arrive-accident-promise-largely/" title="Armenians Didn’t Arrive Here by Accident. ‘The Promise’ is Largely Why">
																																																																													<img width="585" height="390" src="https://i2.wp.com/massispost.com/wp-content/uploads/2016/09/the-promise-trailer.jpg?resize=585%2C390" class="attachment-penci-thumb size-penci-thumb wp-post-image" alt="" />								</a>
							</div>
							<div class="penci-mega-meta">
								<h3 class="post-mega-title">
									<a href="http://massispost.com/2017/04/armenians-didnt-arrive-accident-promise-largely/">Armenians Didn’t Arrive Here by Accident. ‘The Promise’ is Largely Why</a>
								</h3>
																<p class="penci-mega-date">April 17, 2017</p>
															</div>
						</div>
											<div class="penci-mega-post">
							<div class="penci-mega-thumbnail">
																<span class="mega-cat-name">
																			Arts &amp; Culture																	</span>
																<a href="http://massispost.com/2017/04/adaa-antaeus-theatre-present-two-reading-events/" title="ADAA and Antaeus Theatre Present Two Reading Events">
																																																																													<img width="585" height="390" src="https://i2.wp.com/massispost.com/wp-content/uploads/2017/04/ADAA.jpg?resize=585%2C390" class="attachment-penci-thumb size-penci-thumb wp-post-image" alt="" />								</a>
							</div>
							<div class="penci-mega-meta">
								<h3 class="post-mega-title">
									<a href="http://massispost.com/2017/04/adaa-antaeus-theatre-present-two-reading-events/">ADAA and Antaeus Theatre Present Two Reading Events</a>
								</h3>
																<p class="penci-mega-date">April 17, 2017</p>
															</div>
						</div>
											<div class="penci-mega-post">
							<div class="penci-mega-thumbnail">
																<span class="mega-cat-name">
																			Arts &amp; Culture																	</span>
																<a href="http://massispost.com/2017/04/crows-desert-screening-april-23-warner-grand-theater-san-pedro/" title="&#8220;Crows Of The Desert&#8230;&#8221; Screening April 23 at Warner Grand Theater in San Pedro">
																																																																													<img width="585" height="390" src="https://i1.wp.com/massispost.com/wp-content/uploads/2017/04/crowsofthedesert.jpg?resize=585%2C390" class="attachment-penci-thumb size-penci-thumb wp-post-image" alt="" />								</a>
							</div>
							<div class="penci-mega-meta">
								<h3 class="post-mega-title">
									<a href="http://massispost.com/2017/04/crows-desert-screening-april-23-warner-grand-theater-san-pedro/">&#8220;Crows Of The Desert&#8230;&#8221; Screening April 23 at Warner Grand Theater in San Pedro</a>
								</h3>
																<p class="penci-mega-date">April 13, 2017</p>
															</div>
						</div>
											<div class="penci-mega-post">
							<div class="penci-mega-thumbnail">
																<span class="mega-cat-name">
																			Arts &amp; Culture																	</span>
																<a href="http://massispost.com/2017/04/master-oudist-richard-hagopian-present-melodic-rhythmic-considerations-oud-performance/" title="Master Oudist Richard Hagopian to Present “Melodic and Rhythmic Considerations in Oud Performance”">
																										</a>
							</div>
							<div class="penci-mega-meta">
								<h3 class="post-mega-title">
									<a href="http://massispost.com/2017/04/master-oudist-richard-hagopian-present-melodic-rhythmic-considerations-oud-performance/">Master Oudist Richard Hagopian to Present “Melodic and Rhythmic Considerations in Oud Performance”</a>
								</h3>
																<p class="penci-mega-date">April 13, 2017</p>
															</div>
						</div>
									</div>
							</div>
		</div>

		</div></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category penci-mega-menu menu-item-23232"><a href="http://massispost.com/category/sports/">Sports</a>
<ul class="sub-menu">
	<li class="menu-item-0"><div class="penci-megamenu">		
		<div class="penci-content-megamenu">
			<div class="penci-mega-latest-posts col-mn-5 mega-row-1">
								<div class="penci-mega-row penci-mega-186 row-active">
											<div class="penci-mega-post">
							<div class="penci-mega-thumbnail">
																<span class="mega-cat-name">
																			Sports																	</span>
																<a href="http://massispost.com/2017/04/arthur-abraham-beats-robin-krasniqi-unanimous-decision/" title="Arthur Abraham Beats Robin Krasniqi in Unanimous Decision">
																																																																													<img width="585" height="390" src="https://i1.wp.com/massispost.com/wp-content/uploads/2017/04/abraham-krasniqi-1.jpg?resize=585%2C390" class="attachment-penci-thumb size-penci-thumb wp-post-image" alt="" />								</a>
							</div>
							<div class="penci-mega-meta">
								<h3 class="post-mega-title">
									<a href="http://massispost.com/2017/04/arthur-abraham-beats-robin-krasniqi-unanimous-decision/">Arthur Abraham Beats Robin Krasniqi in Unanimous Decision</a>
								</h3>
																<p class="penci-mega-date">April 23, 2017</p>
															</div>
						</div>
											<div class="penci-mega-post">
							<div class="penci-mega-thumbnail">
																<span class="mega-cat-name">
																			Sports																	</span>
																<a href="http://massispost.com/2017/04/simon-martirosyan-wins-gold-european-weightlifting-championships/" title="Simon Martirosyan Wins Gold at European Weightlifting Championships">
																																																																													<img width="585" height="390" src="https://i1.wp.com/massispost.com/wp-content/uploads/2017/04/Simon-Martirosyan.jpg?resize=585%2C390" class="attachment-penci-thumb size-penci-thumb wp-post-image" alt="" srcset="https://i1.wp.com/massispost.com/wp-content/uploads/2017/04/Simon-Martirosyan.jpg?w=1024 1024w, https://i1.wp.com/massispost.com/wp-content/uploads/2017/04/Simon-Martirosyan.jpg?resize=300%2C200 300w, https://i1.wp.com/massispost.com/wp-content/uploads/2017/04/Simon-Martirosyan.jpg?resize=768%2C512 768w, https://i1.wp.com/massispost.com/wp-content/uploads/2017/04/Simon-Martirosyan.jpg?resize=585%2C390 585w" sizes="(max-width: 585px) 100vw, 585px" />								</a>
							</div>
							<div class="penci-mega-meta">
								<h3 class="post-mega-title">
									<a href="http://massispost.com/2017/04/simon-martirosyan-wins-gold-european-weightlifting-championships/">Simon Martirosyan Wins Gold at European Weightlifting Championships</a>
								</h3>
																<p class="penci-mega-date">April 10, 2017</p>
															</div>
						</div>
											<div class="penci-mega-post">
							<div class="penci-mega-thumbnail">
																<span class="mega-cat-name">
																			Sports																	</span>
																<a href="http://massispost.com/2017/03/armenia-beat-kazakhstan-2-0-world-cup-qualifier/" title="Armenia Beat Kazakhstan 2-0 in World Cup Qualifier">
																																																																													<img width="585" height="390" src="https://i2.wp.com/massispost.com/wp-content/uploads/2017/03/Armenia-Kazakhstan.jpg?resize=585%2C390" class="attachment-penci-thumb size-penci-thumb wp-post-image" alt="" />								</a>
							</div>
							<div class="penci-mega-meta">
								<h3 class="post-mega-title">
									<a href="http://massispost.com/2017/03/armenia-beat-kazakhstan-2-0-world-cup-qualifier/">Armenia Beat Kazakhstan 2-0 in World Cup Qualifier</a>
								</h3>
																<p class="penci-mega-date">March 26, 2017</p>
															</div>
						</div>
											<div class="penci-mega-post">
							<div class="penci-mega-thumbnail">
																<span class="mega-cat-name">
																			Sports																	</span>
																<a href="http://massispost.com/2017/03/henrikh-mkhitaryan-receives-armenias-footballer-year-award/" title="Henrikh Mkhitaryan Receives Armenia’s Footballer of the Year Award">
																																																																													<img width="585" height="390" src="https://i2.wp.com/massispost.com/wp-content/uploads/2017/03/mkhitaryan-1.jpg?resize=585%2C390" class="attachment-penci-thumb size-penci-thumb wp-post-image" alt="" />								</a>
							</div>
							<div class="penci-mega-meta">
								<h3 class="post-mega-title">
									<a href="http://massispost.com/2017/03/henrikh-mkhitaryan-receives-armenias-footballer-year-award/">Henrikh Mkhitaryan Receives Armenia’s Footballer of the Year Award</a>
								</h3>
																<p class="penci-mega-date">March 24, 2017</p>
															</div>
						</div>
											<div class="penci-mega-post">
							<div class="penci-mega-thumbnail">
																<span class="mega-cat-name">
																			Sports																	</span>
																<a href="http://massispost.com/2017/03/henrikh-mkhitaryan-wins-third-goal-month-manchester-united/" title="Henrikh Mkhitaryan Wins Third Goal of the Month for Manchester United">
																														<i class="fa fa-play"></i>
																																																																				<img width="585" height="390" src="https://i2.wp.com/massispost.com/wp-content/uploads/2017/03/mkhitaryan.jpg?resize=585%2C390" class="attachment-penci-thumb size-penci-thumb wp-post-image" alt="" />								</a>
							</div>
							<div class="penci-mega-meta">
								<h3 class="post-mega-title">
									<a href="http://massispost.com/2017/03/henrikh-mkhitaryan-wins-third-goal-month-manchester-united/">Henrikh Mkhitaryan Wins Third Goal of the Month for Manchester United</a>
								</h3>
																<p class="penci-mega-date">March 9, 2017</p>
															</div>
						</div>
									</div>
							</div>
		</div>

		</div></li>
</ul>
</li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-23225"><a href="http://massispost.com/am">Հայերէն</a></li>
</ul>
				
									<div id="top-search">
						<a class="search-click"><i class="fa fa-search"></i></a>
						<div class="show-search">
							<form role="search" method="get" id="searchform" action="http://massispost.com/">
    <div>
		<input type="text" class="search-input" placeholder="Type and hit enter..." name="s" id="s" />
	 </div>
</form>							<a class="search-click close-search"><i class="fa fa-close"></i></a>
						</div>
					</div>
				
							</div>
		</nav><!-- End Navigation -->
	</header>
<!-- end #header -->



			<div class="container penci-breadcrumb single-breadcrumb">
			<span><a class="crumb" href="http://massispost.com/">Home</a></span><i class="fa fa-angle-right"></i>
				<span>
					<a href="http://massispost.com/category/armenian/">Armenian</a>				</span><i class="fa fa-angle-right"></i>
			<span>Truth, Justice &#038; Remembrance Prevail in Times Square</span>
		</div>
	
	
	<div class="container container-single container-single-magazine penci_sidebar right-sidebar penci-enable-lightbox">
		<div id="main" class="penci-main-sticky-sidebar">
			<div class="theiaStickySidebar">
														<article id="post-27073" class="post-27073 post type-post status-publish format-gallery has-post-thumbnail hentry category-armenian category-armenian-genocide category-community category-featured category-news post_format-post-format-gallery">

	
	
	
		
					<div class="post-image">
				<div class="penci-slick-slider" data-auto-height="true">
					
																		<figure>
							<img src="https://i2.wp.com/massispost.com/wp-content/uploads/2017/04/04232017_Lohr-Jones_102AGCTS_06-1.jpg?resize=850%2C525" />
						</figure>

					
																		<figure>
							<img src="https://i0.wp.com/massispost.com/wp-content/uploads/2017/04/04232017_Lohr-Jones_102AGCTS_19.jpg?resize=850%2C567" />
						</figure>

					
																		<figure>
							<img src="https://i1.wp.com/massispost.com/wp-content/uploads/2017/04/04232017_Lohr-Jones_102AGCTS_18.jpg?resize=850%2C567" />
						</figure>

					
																		<figure>
							<img src="https://i2.wp.com/massispost.com/wp-content/uploads/2017/04/04232017_Lohr-Jones_102AGCTS_14.jpg?resize=850%2C680" />
						</figure>

					
																		<figure>
							<img src="https://i1.wp.com/massispost.com/wp-content/uploads/2017/04/04232017_Lohr-Jones_102AGCTS_07.jpg?resize=850%2C567" />
						</figure>

					
																		<figure>
							<img src="https://i2.wp.com/massispost.com/wp-content/uploads/2017/04/04232017_Lohr-Jones_102AGCTS_24.jpg?resize=850%2C680" />
						</figure>

					
																		<figure>
							<img src="https://i1.wp.com/massispost.com/wp-content/uploads/2017/04/04232017_Lohr-Jones_102AGCTS_36.jpg?resize=850%2C567" />
						</figure>

					
																		<figure>
							<img src="https://i0.wp.com/massispost.com/wp-content/uploads/2017/04/04232017_Lohr-Jones_102AGCTS_32.jpg?resize=850%2C567" />
						</figure>

					
																		<figure>
							<img src="https://i0.wp.com/massispost.com/wp-content/uploads/2017/04/IMG_5858.jpg?resize=850%2C567" />
						</figure>

					
																		<figure>
							<img src="https://i2.wp.com/massispost.com/wp-content/uploads/2017/04/IMG_3942.jpg?resize=850%2C569" />
						</figure>

					
																		<figure>
							<img src="https://i2.wp.com/massispost.com/wp-content/uploads/2017/04/04232017_Lohr-Jones_102AGCTS_39.jpg?resize=850%2C567" />
						</figure>

									</div>
			</div>
		
	
	
	
	
		<div class="header-standard header-classic single-header">
							<div class="penci-standard-cat"><span class="cat"><a class="penci-cat-name" href="http://massispost.com/category/armenian/" title="View all posts in Armenian" >Armenian</a><a class="penci-cat-name" href="http://massispost.com/category/armenian-genocide/" title="View all posts in Armenian Genocide" >Armenian Genocide</a><a class="penci-cat-name" href="http://massispost.com/category/community/" title="View all posts in Community" >Community</a><a class="penci-cat-name" href="http://massispost.com/category/featured/" title="View all posts in Featured" >Featured</a><a class="penci-cat-name" href="http://massispost.com/category/news/" title="View all posts in News" >News</a></span></div>
			
			<h1 class="post-title single-post-title">Truth, Justice &#038; Remembrance Prevail in Times Square</h1>

							<div class="post-box-meta-single">
																<span>April 24, 2017</span>
									</div>
					</div>

		
	
	<div class="post-entry">
		<div class="inner-post-entry">
			<p><strong>By Taleen Babayan</strong></p>
<p>The vow to <em>Keep the Promise</em> was in full effect on Sunday, April 23 as an impressive number gathered in Times Square to remember the 1.5 million martyrs and pay homage to their legacy, proving that the Armenian Genocide commemorations have only gained momentum since the centennial.</p>
<p>The relevant and inspiring program, organized by the Knights and Daughters of Vartan since 1985, once again attracted thousands of supporters who waved the vibrant tricolor flags of Armenia and Artzakh in the heart of New York City as the past was remembered and a renewed effort was made to strengthen the Armenian Diaspora and the homeland.</p>
<p>Steadfast supporters of the Armenian Genocide were once again in attendance to speak, particularly committed elected officials, including Congressman Frank Pallone (D-N.J.), who acknowledged the accomplishments of the Armenian Diaspora in championing genocide recognition around the world.</p>
<p>“Recognition will happen if all of you continue to march, write letters and take action,” said Pallone, founder of the Congressional Caucus of Armenian Issues, who recently introduced a new resolution for the U.S. Congress to recognize the genocide.</p>
<p>Pallone remarked that conflict in Armenia and Artzakh is ongoing, recognizing the war there last year and warned that although the genocide was over 100 years ago, violence is still being used against the Armenian people.</p>
<p>“Continue your efforts,” urged Pallone. “You being here today helps with genocide recognition and we as a people must speak out against genocide wherever it occurs.”</p>
<p>A fellow member of the Congressional Caucus on Armenian issues, Congresswoman Carolyn Maloney (D-NY) promised to “confront a stubborn resistance.”</p>
<p>She said all nations have a responsibility to recognize the systemic extermination of the Armenians and that until the resolution is passed to recognize the Armenian Genocide in the U.S., “we will not stop.”</p>
<p>Appearing every year without fail, Senator Chuck Schumer (D-N.Y.), who is the current Senate Minority Leader, pledged to “stand with all of you in acknowledging the Armenian Genocide and nothing less.”</p>
<p>He praised the energy and collective spirit of Armenians a century after the massacres and hailed the production of the major motion picture, <em>The Promise</em> that “finally shines a light on this story and puts it in the mainstream for all to see.”</p>
<p>Honoring the memory of his late friend Sam Azadian, founder of the Armenian Genocide Commemoration in Times Square, Schumer said he attends the commemoration every year “because I believe it is our duty to speak out for the innocent victims of the Armenian Genocide.”</p>
<p>“The Armenian Genocide was the first Holocaust of the 20<sup>th</sup> century but not the last,” said Schumer. “These events are a stain on humanity and I stand with all of you today to remember the pain of the past.”</p>
<p>Scholar David Phillips, who worked towards reconciliation with Armenia and Turkey as former chair of the Turkish-Armenian Reconciliation Commission, said he always believed that “hard problems can be solved through hard dialogue.”</p>
<p>“But dialogue is impossible if one side wants to humiliate the other,” said Phillips, noting the efforts of Armenia’s President Serge Sarkisian towards reconciliation, while Turkey’s then Prime Minister Recep Erdogan reneged on their discussions.</p>
<p>“It takes two to talk,” said Phillips, who is currently the Director of the Peace-building and Rights Program at Columbia University’s Institute for the Study of Human Rights. “But Erdogan is not reconciliatory,”</p>
<p>He called for Washington to investigate Erdogan for war crimes “to lay the groundwork for accountability.”</p>
<p>“Your work and presence here today is so important,” said Phillips. “For the Armenians today in Nagorno Karabakh, for the Yazidis in Iraq and for all who suffer from crimes against humanity.”</p>
<p>Urging the next generation to take genocide recognition into their own hands, celebrity attorney Mark Geragos told the thousands of young people at the commemoration to “go outside the political process to create a movement to never forget.”</p>
<p>“If you as the next generation don’t keep the promise, we are doomed to repeat it.”</p>
<p>Geragos remarked that Turkey spends millions of dollars to “cover up and perpetuate a lie” and the following generations need to do their part to continue the fight for justice and remembrance.</p>
<p>Knights of Vartan Grand Commander Steven Kradjian and Daughters of Vartan Grand Matron Sona Manuelian recognized and honored Olympic wrestler Migran Arutyunyan and MMA champion Albert Ghazaryan, along with their coach Hayk Ghukasyan with special Knights of Vartan medals for their accomplishments in sports.</p>
<p>Dr. Rachel Goshgarian, Professor of History at Lafayette College and Armen McOmber Esq., New Jersey attorney, ably served as MCs for the program.</p>
<p>Remarks by sponsoring organizations were made by Steven Mesrobian, Armenian National Committee of America, Talin Yacoubian, Armenian Assembly of America, Natalie Gabrielian, Armenian General Benevolent Union, Shahe Sanentz, ADL-Ramgavars, Souren Israelyan, Esq., Armenian Bar Association, Natalie Sarafian, Armenian Council of America, Shant Mardirossian, Near East Foundation and Rev. Haig Kherlopian, Armenian Missionary Association of America and Armenian Evangelical Union of North America.</p>
<p>Archbishop Oshagan Choloyan, Prelate of the Eastern Prelacy of the Armenian Apostolic Church of America, gave the invocation and Very Rev. Fr. Vazken Karayan, pastor of Holy Cross Armenian Church, representing Archbishop Barsamian, Primate of the Diocese of the Armenian Church of America (Eastern), offered the benediction. Other clergy in attendance included Bishop Anoushavan Tanielian, Vicar General of the Eastern Prelacy of the Armenian Apostolic Church of America.</p>
<p>The winners of this year’s Knights of Vartan Essay Contest were announced at the program: Raffi Salbashian, 1st place, Stephan Havatian, 2nd place, and Samantha Khorozian, 3rd place.</p>
<p>The Hovnanian Armenian Day School students sang the national anthems of the United States and Armenia, as well as “God Bless America.”</p>
<p>The Armenian Radio Hour of New Jersey, led by director Vartan Abdo streamed the event live in video format worldwide, reaching more than 50,000 people, with the assistance of his dedicated volunteer staff.</p>
<p>The 102<sup>nd</sup> Armenian Genocide Commemoration in Times Square was organized by the Mid-Atlantic chapters of the Knights and Daughters of Vartan. Co-sponsors included the Armenian General Benevolent Union, the Armenian Assembly of America, the Armenian National Committee of America, the ADL-Ramgavars, and the Armenian Council of America. Participating organizations included the Diocese of the Armenian Church of America (Eastern), Prelacy of the Armenian Church, Armenian Missionary Association of America, Armenian Presbyterian Church, the Armenian Evangelical Church, the Armenian Catholic Eparchy for U.S. and Canada and numerous Armenian youth organizations, including the Armenian Church Youth Organization of America, the Armenian Network of America, the Armenian Youth Federation, Homenetmen Scouts, Hamazkayin Cultural Association, Tekeyan Cultural Association, Noyan Tapan of Brooklyn,  Armenian Students Association, Akh’tamar Dance Ensemble NJ, NY Armenian Old Age Home, AGBU Young Professionals, Armenian Youth Talent Association, tri-state Armenian college and university clubs, including the Cornell Armenian Student Organization, Princeton Armenian Society and Yale Armenian Network.<br />
<a href="https://i0.wp.com/massispost.com/wp-content/uploads/2017/04/IMG_5858.jpg" data-rel="penci-gallery-image-content" ><img class="aligncenter size-full wp-image-27086" src="https://i0.wp.com/massispost.com/wp-content/uploads/2017/04/IMG_5858.jpg?resize=850%2C567" alt="" srcset="https://i0.wp.com/massispost.com/wp-content/uploads/2017/04/IMG_5858.jpg?w=850 850w, https://i0.wp.com/massispost.com/wp-content/uploads/2017/04/IMG_5858.jpg?resize=300%2C200 300w, https://i0.wp.com/massispost.com/wp-content/uploads/2017/04/IMG_5858.jpg?resize=768%2C512 768w, https://i0.wp.com/massispost.com/wp-content/uploads/2017/04/IMG_5858.jpg?resize=585%2C390 585w" sizes="(max-width: 850px) 100vw, 850px" data-recalc-dims="1" /></a> <a href="https://i2.wp.com/massispost.com/wp-content/uploads/2017/04/IMG_3942.jpg" data-rel="penci-gallery-image-content" ><img class="aligncenter size-full wp-image-27085" src="https://i2.wp.com/massispost.com/wp-content/uploads/2017/04/IMG_3942.jpg?resize=850%2C569" alt="" srcset="https://i2.wp.com/massispost.com/wp-content/uploads/2017/04/IMG_3942.jpg?w=850 850w, https://i2.wp.com/massispost.com/wp-content/uploads/2017/04/IMG_3942.jpg?resize=300%2C201 300w, https://i2.wp.com/massispost.com/wp-content/uploads/2017/04/IMG_3942.jpg?resize=768%2C514 768w, https://i2.wp.com/massispost.com/wp-content/uploads/2017/04/IMG_3942.jpg?resize=585%2C392 585w" sizes="(max-width: 850px) 100vw, 850px" data-recalc-dims="1" /></a> <a href="https://i2.wp.com/massispost.com/wp-content/uploads/2017/04/04232017_Lohr-Jones_102AGCTS_39.jpg" data-rel="penci-gallery-image-content" ><img class="aligncenter size-full wp-image-27084" src="https://i2.wp.com/massispost.com/wp-content/uploads/2017/04/04232017_Lohr-Jones_102AGCTS_39.jpg?resize=850%2C567" alt="" srcset="https://i2.wp.com/massispost.com/wp-content/uploads/2017/04/04232017_Lohr-Jones_102AGCTS_39.jpg?w=850 850w, https://i2.wp.com/massispost.com/wp-content/uploads/2017/04/04232017_Lohr-Jones_102AGCTS_39.jpg?resize=300%2C200 300w, https://i2.wp.com/massispost.com/wp-content/uploads/2017/04/04232017_Lohr-Jones_102AGCTS_39.jpg?resize=768%2C512 768w, https://i2.wp.com/massispost.com/wp-content/uploads/2017/04/04232017_Lohr-Jones_102AGCTS_39.jpg?resize=585%2C390 585w" sizes="(max-width: 850px) 100vw, 850px" data-recalc-dims="1" /></a> <a href="https://i1.wp.com/massispost.com/wp-content/uploads/2017/04/04232017_Lohr-Jones_102AGCTS_36.jpg" data-rel="penci-gallery-image-content" ><img class="aligncenter size-full wp-image-27083" src="https://i1.wp.com/massispost.com/wp-content/uploads/2017/04/04232017_Lohr-Jones_102AGCTS_36.jpg?resize=850%2C567" alt="" srcset="https://i1.wp.com/massispost.com/wp-content/uploads/2017/04/04232017_Lohr-Jones_102AGCTS_36.jpg?w=850 850w, https://i1.wp.com/massispost.com/wp-content/uploads/2017/04/04232017_Lohr-Jones_102AGCTS_36.jpg?resize=300%2C200 300w, https://i1.wp.com/massispost.com/wp-content/uploads/2017/04/04232017_Lohr-Jones_102AGCTS_36.jpg?resize=768%2C512 768w, https://i1.wp.com/massispost.com/wp-content/uploads/2017/04/04232017_Lohr-Jones_102AGCTS_36.jpg?resize=585%2C390 585w" sizes="(max-width: 850px) 100vw, 850px" data-recalc-dims="1" /></a> <a href="https://i0.wp.com/massispost.com/wp-content/uploads/2017/04/04232017_Lohr-Jones_102AGCTS_32.jpg" data-rel="penci-gallery-image-content" ><img class="aligncenter size-full wp-image-27082" src="https://i0.wp.com/massispost.com/wp-content/uploads/2017/04/04232017_Lohr-Jones_102AGCTS_32.jpg?resize=850%2C567" alt="" srcset="https://i0.wp.com/massispost.com/wp-content/uploads/2017/04/04232017_Lohr-Jones_102AGCTS_32.jpg?w=850 850w, https://i0.wp.com/massispost.com/wp-content/uploads/2017/04/04232017_Lohr-Jones_102AGCTS_32.jpg?resize=300%2C200 300w, https://i0.wp.com/massispost.com/wp-content/uploads/2017/04/04232017_Lohr-Jones_102AGCTS_32.jpg?resize=768%2C512 768w, https://i0.wp.com/massispost.com/wp-content/uploads/2017/04/04232017_Lohr-Jones_102AGCTS_32.jpg?resize=585%2C390 585w" sizes="(max-width: 850px) 100vw, 850px" data-recalc-dims="1" /></a> <a href="https://i2.wp.com/massispost.com/wp-content/uploads/2017/04/04232017_Lohr-Jones_102AGCTS_24.jpg" data-rel="penci-gallery-image-content" ><img class="aligncenter size-full wp-image-27081" src="https://i2.wp.com/massispost.com/wp-content/uploads/2017/04/04232017_Lohr-Jones_102AGCTS_24.jpg?resize=850%2C680" alt="" srcset="https://i2.wp.com/massispost.com/wp-content/uploads/2017/04/04232017_Lohr-Jones_102AGCTS_24.jpg?w=850 850w, https://i2.wp.com/massispost.com/wp-content/uploads/2017/04/04232017_Lohr-Jones_102AGCTS_24.jpg?resize=300%2C240 300w, https://i2.wp.com/massispost.com/wp-content/uploads/2017/04/04232017_Lohr-Jones_102AGCTS_24.jpg?resize=768%2C614 768w, https://i2.wp.com/massispost.com/wp-content/uploads/2017/04/04232017_Lohr-Jones_102AGCTS_24.jpg?resize=585%2C468 585w" sizes="(max-width: 850px) 100vw, 850px" data-recalc-dims="1" /></a> <a href="https://i0.wp.com/massispost.com/wp-content/uploads/2017/04/04232017_Lohr-Jones_102AGCTS_19.jpg" data-rel="penci-gallery-image-content" ><img class="aligncenter size-full wp-image-27080" src="https://i0.wp.com/massispost.com/wp-content/uploads/2017/04/04232017_Lohr-Jones_102AGCTS_19.jpg?resize=850%2C567" alt="" srcset="https://i0.wp.com/massispost.com/wp-content/uploads/2017/04/04232017_Lohr-Jones_102AGCTS_19.jpg?w=850 850w, https://i0.wp.com/massispost.com/wp-content/uploads/2017/04/04232017_Lohr-Jones_102AGCTS_19.jpg?resize=300%2C200 300w, https://i0.wp.com/massispost.com/wp-content/uploads/2017/04/04232017_Lohr-Jones_102AGCTS_19.jpg?resize=768%2C512 768w, https://i0.wp.com/massispost.com/wp-content/uploads/2017/04/04232017_Lohr-Jones_102AGCTS_19.jpg?resize=585%2C390 585w" sizes="(max-width: 850px) 100vw, 850px" data-recalc-dims="1" /></a> <a href="https://i1.wp.com/massispost.com/wp-content/uploads/2017/04/04232017_Lohr-Jones_102AGCTS_18.jpg" data-rel="penci-gallery-image-content" ><img class="aligncenter size-full wp-image-27079" src="https://i1.wp.com/massispost.com/wp-content/uploads/2017/04/04232017_Lohr-Jones_102AGCTS_18.jpg?resize=850%2C567" alt="" srcset="https://i1.wp.com/massispost.com/wp-content/uploads/2017/04/04232017_Lohr-Jones_102AGCTS_18.jpg?w=850 850w, https://i1.wp.com/massispost.com/wp-content/uploads/2017/04/04232017_Lohr-Jones_102AGCTS_18.jpg?resize=300%2C200 300w, https://i1.wp.com/massispost.com/wp-content/uploads/2017/04/04232017_Lohr-Jones_102AGCTS_18.jpg?resize=768%2C512 768w, https://i1.wp.com/massispost.com/wp-content/uploads/2017/04/04232017_Lohr-Jones_102AGCTS_18.jpg?resize=585%2C390 585w" sizes="(max-width: 850px) 100vw, 850px" data-recalc-dims="1" /></a> <a href="https://i2.wp.com/massispost.com/wp-content/uploads/2017/04/04232017_Lohr-Jones_102AGCTS_14.jpg" data-rel="penci-gallery-image-content" ><img class="aligncenter size-full wp-image-27078" src="https://i2.wp.com/massispost.com/wp-content/uploads/2017/04/04232017_Lohr-Jones_102AGCTS_14.jpg?resize=850%2C680" alt="" srcset="https://i2.wp.com/massispost.com/wp-content/uploads/2017/04/04232017_Lohr-Jones_102AGCTS_14.jpg?w=850 850w, https://i2.wp.com/massispost.com/wp-content/uploads/2017/04/04232017_Lohr-Jones_102AGCTS_14.jpg?resize=300%2C240 300w, https://i2.wp.com/massispost.com/wp-content/uploads/2017/04/04232017_Lohr-Jones_102AGCTS_14.jpg?resize=768%2C614 768w, https://i2.wp.com/massispost.com/wp-content/uploads/2017/04/04232017_Lohr-Jones_102AGCTS_14.jpg?resize=585%2C468 585w" sizes="(max-width: 850px) 100vw, 850px" data-recalc-dims="1" /></a> <a href="https://i1.wp.com/massispost.com/wp-content/uploads/2017/04/04232017_Lohr-Jones_102AGCTS_07.jpg" data-rel="penci-gallery-image-content" ><img class="aligncenter size-full wp-image-27077" src="https://i1.wp.com/massispost.com/wp-content/uploads/2017/04/04232017_Lohr-Jones_102AGCTS_07.jpg?resize=850%2C567" alt="" srcset="https://i1.wp.com/massispost.com/wp-content/uploads/2017/04/04232017_Lohr-Jones_102AGCTS_07.jpg?w=850 850w, https://i1.wp.com/massispost.com/wp-content/uploads/2017/04/04232017_Lohr-Jones_102AGCTS_07.jpg?resize=300%2C200 300w, https://i1.wp.com/massispost.com/wp-content/uploads/2017/04/04232017_Lohr-Jones_102AGCTS_07.jpg?resize=768%2C512 768w, https://i1.wp.com/massispost.com/wp-content/uploads/2017/04/04232017_Lohr-Jones_102AGCTS_07.jpg?resize=585%2C390 585w" sizes="(max-width: 850px) 100vw, 850px" data-recalc-dims="1" /></a></p>
<p>Photo Credits: Albin Lohr-Jones &amp; Anoush Gulian</p>
<span class="cp-load-after-post"></span><div class="hatom-extra" style="display:none !important;visibility:hidden;"><span class="entry-title">Truth, Justice &#038; Remembrance Prevail in Times Square</span> was last modified: <span class="updated"> April 24th, 2017</span> by <span class="author vcard"><span class="fn">MassisPost</span></span></div>								</div>
	</div>

	
			<div class="tags-share-box center-box">

							<span class="single-comment-o"><i class="fa fa-comment-o"></i>0 comment</span>
			
							<div class="post-share">
					<span class="count-number-like">0</span><a class="penci-post-like single-like-button" data-post_id="27073" title="Like" data-like="Like" data-unlike="Unlike"><i class="fa fa-heart-o"></i></a>					<div class="list-posts-share">
												<a target="_blank" href="https://www.facebook.com/sharer/sharer.php?u=http://massispost.com/2017/04/truth-justice-remembrance-prevail-times-square/"><i class="fa fa-facebook"></i><span class="dt-share">Facebook</span></a>
						<a target="_blank" href="https://twitter.com/home?status=Check%20out%20this%20article:%20Truth,%20Justice%20&#038;%20Remembrance%20Prevail%20in%20Times%20Square%20-%20http://massispost.com/2017/04/truth-justice-remembrance-prevail-times-square/"><i class="fa fa-twitter"></i><span class="dt-share">Twitter</span></a>
						<a target="_blank" href="https://plus.google.com/share?url=http://massispost.com/2017/04/truth-justice-remembrance-prevail-times-square/"><i class="fa fa-google-plus"></i><span class="dt-share">Google +</span></a>
						<a data-pin-do="none" target="_blank" href="https://pinterest.com/pin/create/button/?url=http://massispost.com/2017/04/truth-justice-remembrance-prevail-times-square/&#038;media=http://massispost.com/wp-content/uploads/2017/04/04232017_Lohr-Jones_102AGCTS_06.jpg&#038;description=Truth,%20Justice%20&#038;%20Remembrance%20Prevail%20in%20Times%20Square"><i class="fa fa-pinterest"></i><span class="dt-share">Pinterest</span></a>
					</div>
				</div>
					</div>
	
			<div class="post-author">
	<div class="author-img">
		<img alt='' src='http://0.gravatar.com/avatar/670508df3ed5048abc6774a98a687f9a?s=100&#038;d=mm&#038;r=g' srcset='http://0.gravatar.com/avatar/670508df3ed5048abc6774a98a687f9a?s=200&amp;d=mm&amp;r=g 2x' class='avatar avatar-100 photo' height='100' width='100' />	</div>
	<div class="author-content">
		<h5><a href="http://massispost.com/author/admin/" title="Posts by MassisPost" rel="author">MassisPost</a></h5>
		<p></p>
													</div>
</div>	
			<div class="post-pagination">
				<div class="prev-post">
						<div class="prev-post-inner">
				<div class="prev-post-title">
					<span>previous post</span>
				</div>
				<a href="http://massispost.com/2017/04/2017-aurora-prize-finalists-announced/">
					<div class="pagi-text">
						<h5 class="prev-title">2017 Aurora Prize Finalists Announced</h5>
					</div>
				</a>
			</div>
		</div>
	
			<div class="next-post">
						<div class="next-post-inner">
				<div class="prev-post-title next-post-title">
					<span>next post</span>
				</div>
				<a href="http://massispost.com/2017/04/armenian-council-america-message-delivered-natalie-sarafian-times-square-commemoration/">
					<div class="pagi-text">
						<h5 class="next-title">Armenian Council of America Message Delivered by Natalie Sarafian During Times Square Commemoration</h5>
					</div>
				</a>
			</div>
		</div>
	</div>	
					<div class="post-related">
		<div class="post-title-box"><h4 class="post-box-title">You may also like</h4></div>
		<div class="penci-carousel penci-related-carousel" data-auto="false" data-dots="true" data-arrows="false">
						<div class="item-related">
											<a class="related-thumb" href="http://massispost.com/2017/04/crows-desert-screening-april-23-warner-grand-theater-san-pedro/">
														<img width="585" height="390" src="https://i1.wp.com/massispost.com/wp-content/uploads/2017/04/crowsofthedesert.jpg?resize=585%2C390" class="attachment-penci-thumb size-penci-thumb wp-post-image" alt="" />						</a>
										<h3><a href="http://massispost.com/2017/04/crows-desert-screening-april-23-warner-grand-theater-san-pedro/">&#8220;Crows Of The Desert&#8230;&#8221; Screening April 23 at Warner Grand Theater in San Pedro</a></h3>
										<span class="date">April 13, 2017</span>
									</div>
						<div class="item-related">
											<a class="related-thumb" href="http://massispost.com/2016/05/armenian-parliament-withholds-debate-on-karabakh-recognition-bill/">
														<img width="585" height="390" src="https://i0.wp.com/massispost.com/wp-content/uploads/2016/05/armenia-parliament.jpg?resize=585%2C390" class="attachment-penci-thumb size-penci-thumb wp-post-image" alt="" srcset="https://i0.wp.com/massispost.com/wp-content/uploads/2016/05/armenia-parliament.jpg?w=696 696w, https://i0.wp.com/massispost.com/wp-content/uploads/2016/05/armenia-parliament.jpg?resize=300%2C200 300w, https://i0.wp.com/massispost.com/wp-content/uploads/2016/05/armenia-parliament.jpg?resize=539%2C360 539w, https://i0.wp.com/massispost.com/wp-content/uploads/2016/05/armenia-parliament.jpg?resize=350%2C234 350w, https://i0.wp.com/massispost.com/wp-content/uploads/2016/05/armenia-parliament.jpg?resize=254%2C170 254w, https://i0.wp.com/massispost.com/wp-content/uploads/2016/05/armenia-parliament.jpg?resize=125%2C84 125w" sizes="(max-width: 585px) 100vw, 585px" />						</a>
										<h3><a href="http://massispost.com/2016/05/armenian-parliament-withholds-debate-on-karabakh-recognition-bill/">Armenian Parliament Withholds Debate On Karabakh Recognition Bill</a></h3>
										<span class="date">May 16, 2016</span>
									</div>
						<div class="item-related">
											<a class="related-thumb" href="http://massispost.com/2016/06/armount-tv-first-247-armenian-language-tv-channel-in-las-vegas/">
														<img width="585" height="390" src="https://i2.wp.com/massispost.com/wp-content/uploads/2016/06/a2.jpg?resize=585%2C390" class="attachment-penci-thumb size-penci-thumb wp-post-image" alt="" srcset="https://i2.wp.com/massispost.com/wp-content/uploads/2016/06/a2.jpg?w=738 738w, https://i2.wp.com/massispost.com/wp-content/uploads/2016/06/a2.jpg?resize=300%2C200 300w, https://i2.wp.com/massispost.com/wp-content/uploads/2016/06/a2.jpg?resize=730%2C487 730w, https://i2.wp.com/massispost.com/wp-content/uploads/2016/06/a2.jpg?resize=539%2C359 539w, https://i2.wp.com/massispost.com/wp-content/uploads/2016/06/a2.jpg?resize=350%2C233 350w, https://i2.wp.com/massispost.com/wp-content/uploads/2016/06/a2.jpg?resize=254%2C169 254w, https://i2.wp.com/massispost.com/wp-content/uploads/2016/06/a2.jpg?resize=125%2C83 125w" sizes="(max-width: 585px) 100vw, 585px" />						</a>
										<h3><a href="http://massispost.com/2016/06/armount-tv-first-247-armenian-language-tv-channel-in-las-vegas/">ARMOUNT TV &#8211; First 24/7 Armenian Language TV Channel in Las Vegas</a></h3>
										<span class="date">June 9, 2016</span>
									</div>
						<div class="item-related">
											<a class="related-thumb" href="http://massispost.com/2017/04/author-dawn-mackeen-speaks-armenian-genocide-newport-beach-city-council/">
														<img width="585" height="390" src="https://i0.wp.com/massispost.com/wp-content/uploads/2017/04/newportbeach-city.jpg?resize=585%2C390" class="attachment-penci-thumb size-penci-thumb wp-post-image" alt="" />						</a>
										<h3><a href="http://massispost.com/2017/04/author-dawn-mackeen-speaks-armenian-genocide-newport-beach-city-council/">Author Dawn MacKeen Speaks On Armenian Genocide at Newport Beach City Council</a></h3>
										<span class="date">April 12, 2017</span>
									</div>
						<div class="item-related">
											<a class="related-thumb" href="http://massispost.com/2016/08/osce-foreign-ministers-meeting-in-potsdam-to-address-the-karabakh-issue/">
														<img width="585" height="390" src="https://i2.wp.com/massispost.com/wp-content/uploads/2016/08/Steinmeier-1.jpg?resize=585%2C390" class="attachment-penci-thumb size-penci-thumb wp-post-image" alt="" />						</a>
										<h3><a href="http://massispost.com/2016/08/osce-foreign-ministers-meeting-in-potsdam-to-address-the-karabakh-issue/">OSCE Foreign Ministers’ Meeting in Potsdam to Address the Karabakh Issue</a></h3>
										<span class="date">August 31, 2016</span>
									</div>
						<div class="item-related">
											<a class="related-thumb" href="http://massispost.com/2013/11/s-d-hunchakian-party-meeting-with-artsakh-president-bako-sahakyan/">
														<img width="585" height="390" src="https://i0.wp.com/massispost.com/wp-content/uploads/2013/11/sdhp-sahakian2.jpg?resize=585%2C390" class="attachment-penci-thumb size-penci-thumb wp-post-image" alt="" srcset="https://i0.wp.com/massispost.com/wp-content/uploads/2013/11/sdhp-sahakian2.jpg?zoom=2&amp;resize=585%2C390 1170w, https://i0.wp.com/massispost.com/wp-content/uploads/2013/11/sdhp-sahakian2.jpg?zoom=3&amp;resize=585%2C390 1755w" sizes="(max-width: 585px) 100vw, 585px" />						</a>
										<h3><a href="http://massispost.com/2013/11/s-d-hunchakian-party-meeting-with-artsakh-president-bako-sahakyan/">S.D. Hunchakian Party Meeting with  Artsakh President Bako Sahakyan</a></h3>
										<span class="date">November 27, 2013</span>
									</div>
						<div class="item-related">
											<a class="related-thumb" href="http://massispost.com/2017/02/armenia-slams-belarus-bloggers-extradition/">
														<img width="585" height="390" src="https://i1.wp.com/massispost.com/wp-content/uploads/2017/02/lapshin_baku.jpg?resize=585%2C390" class="attachment-penci-thumb size-penci-thumb wp-post-image" alt="" srcset="https://i1.wp.com/massispost.com/wp-content/uploads/2017/02/lapshin_baku.jpg?w=800 800w, https://i1.wp.com/massispost.com/wp-content/uploads/2017/02/lapshin_baku.jpg?resize=300%2C200 300w, https://i1.wp.com/massispost.com/wp-content/uploads/2017/02/lapshin_baku.jpg?resize=768%2C512 768w, https://i1.wp.com/massispost.com/wp-content/uploads/2017/02/lapshin_baku.jpg?resize=585%2C390 585w" sizes="(max-width: 585px) 100vw, 585px" />						</a>
										<h3><a href="http://massispost.com/2017/02/armenia-slams-belarus-bloggers-extradition/">Armenia Slams Belarus for Blogger’s Extradition</a></h3>
										<span class="date">February 8, 2017</span>
									</div>
						<div class="item-related">
											<a class="related-thumb" href="http://massispost.com/2014/03/community-forum-with-the-three-traditional-armenian-political-parties/">
														<img width="520" height="206" src="https://i2.wp.com/massispost.com/wp-content/uploads/2014/03/OIA_Event.png?resize=520%2C206" class="attachment-penci-thumb size-penci-thumb wp-post-image" alt="" srcset="https://i2.wp.com/massispost.com/wp-content/uploads/2014/03/OIA_Event.png?w=520 520w, https://i2.wp.com/massispost.com/wp-content/uploads/2014/03/OIA_Event.png?resize=300%2C118 300w" sizes="(max-width: 520px) 100vw, 520px" />						</a>
										<h3><a href="http://massispost.com/2014/03/community-forum-with-the-three-traditional-armenian-political-parties/">Community Forum With The Three Traditional Armenian Political Parties</a></h3>
										<span class="date">March 17, 2014</span>
									</div>
						<div class="item-related">
											<a class="related-thumb" href="http://massispost.com/2013/12/rep-adam-schiff-statement-on-death-of-armenian-soldier/">
														<img width="500" height="333" src="https://i0.wp.com/massispost.com/wp-content/uploads/2013/12/AdamSchiff.jpg?resize=500%2C333" class="attachment-penci-thumb size-penci-thumb wp-post-image" alt="" srcset="https://i0.wp.com/massispost.com/wp-content/uploads/2013/12/AdamSchiff.jpg?w=500 500w, https://i0.wp.com/massispost.com/wp-content/uploads/2013/12/AdamSchiff.jpg?resize=300%2C199 300w" sizes="(max-width: 500px) 100vw, 500px" />						</a>
										<h3><a href="http://massispost.com/2013/12/rep-adam-schiff-statement-on-death-of-armenian-soldier/">Rep. Adam Schiff Statement on Death of Armenian Soldier</a></h3>
										<span class="date">December 17, 2013</span>
									</div>
						<div class="item-related">
											<a class="related-thumb" href="http://massispost.com/2010/10/nkr-president-meets-minsk-group-co-chairs/">
														<img width="338" height="225" src="https://i0.wp.com/massispost.com/wp-content/uploads/2010/10/bakosahakyan.jpg?resize=338%2C225" class="attachment-penci-thumb size-penci-thumb wp-post-image" alt="" srcset="https://i0.wp.com/massispost.com/wp-content/uploads/2010/10/bakosahakyan.jpg?w=338 338w, https://i0.wp.com/massispost.com/wp-content/uploads/2010/10/bakosahakyan.jpg?resize=300%2C199 300w" sizes="(max-width: 338px) 100vw, 338px" />						</a>
										<h3><a href="http://massispost.com/2010/10/nkr-president-meets-minsk-group-co-chairs/">NKR President Meets Minsk Group Co-Chairs</a></h3>
										<span class="date">October 7, 2010</span>
									</div>
		</div></div>	
			<div class="post-comments no-comment-yet" id="comments">
	<div id='comments_pagination'></div>
		<div id="respond" class="comment-respond">
			<h3 id="reply-title" class="comment-reply-title">Leave a Reply <small><a rel="nofollow" id="cancel-comment-reply-link" href="/2017/04/truth-justice-remembrance-prevail-times-square/#respond" style="display:none;">Cancel reply</a></small></h3>
			<form id="commentform" class="comment-form">
				<iframe src="https://jetpack.wordpress.com/jetpack-comment/?blogid=47534632&#038;postid=27073&#038;comment_registration=0&#038;require_name_email=1&#038;stc_enabled=0&#038;stb_enabled=0&#038;show_avatars=1&#038;avatar_default=mystery&#038;greeting=Leave+a+Reply&#038;greeting_reply=Leave+a+Reply+to+%25s&#038;color_scheme=transparent&#038;lang=en_US&#038;jetpack_version=4.4&#038;sig=6ce5ad9881ea62ed2c1dce6cf42f300c02400a65#parent=http%3A%2F%2Fmassispost.com%2F2017%2F04%2Ftruth-justice-remembrance-prevail-times-square%2F" allowtransparency="true" style="width:100%; height: 430px;border:0;" frameBorder="0" scrolling="no" name="jetpack_remote_comment" id="jetpack_remote_comment"></iframe>
			</form>
		</div>

		
		<input type="hidden" name="comment_parent" id="comment_parent" value="" />

		</div> <!-- end comments div -->
	
</article>							</div>
		</div>
					
<div id="sidebar" class="penci-sticky-sidebar">
	<div class="theiaStickySidebar">
		<aside id="search-4" class="widget widget_search"><form role="search" method="get" id="searchform" action="http://massispost.com/">
    <div>
		<input type="text" class="search-input" placeholder="Type and hit enter..." name="s" id="s" />
	 </div>
</form></aside><aside id="text-24" class="widget widget_text"><h4 class="widget-title penci-border-arrow"><span class="inner-arrow">Massis Weekly</span></h4>			<div class="textwidget"><a href="http://massisweekly.com/current.html" target=blank><img src="http://massisweekly.com/images/pg1.jpg"></a></div>
		</aside><aside id="penci_facebook_widget-3" class="widget penci_facebook_widget"><h4 class="widget-title penci-border-arrow"><span class="inner-arrow">Like Us on Facebook</span></h4>			<div class="fb-page" data-href="http://www.facebook.com/massispost" data-height="290" data-small-header="false" data-adapt-container-width="true" data-hide-cover="false" data-show-facepile="true" data-show-posts="true"><div class="fb-xfbml-parse-ignore"><blockquote cite="http://www.facebook.com/massispost"><a href="http://www.facebook.com/massispost">Facebook</a></blockquote></div></div>
		</aside><aside id="text-28" class="widget widget_text">			<div class="textwidget"><script>
  (function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
  (i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
  m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
  })(window,document,'script','https://www.google-analytics.com/analytics.js','ga');

  ga('create', 'UA-30283758-1', 'auto');
  ga('send', 'pageview');

</script></div>
		</aside>	</div>
</div>		
<!-- END CONTAINER -->
</div>
<div class="clear-footer"></div>

<div id="penci-end-sidebar-sticky"></div>


<footer id="footer-section">
	<div class="container">
							<div class="footer-logo-copyright footer-not-logo">
				
									<div class="footer-menu-wrap">
					<ul id="menu-secondary" class="footer-menu"><li id="menu-item-7974" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-7974"><a href="http://massispost.com/about/">About</a></li>
<li id="menu-item-7972" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-7972"><a href="http://massispost.com/staff-2/">Staff</a></li>
<li id="menu-item-7973" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-7973"><a href="http://massispost.com/contact/">Contact</a></li>
<li id="menu-item-8003" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-8003"><a target="_blank" href="https://itunes.apple.com/us/app/armenian-news-by-massispost/id796065906?mt=8">iPhone</a></li>
<li id="menu-item-8004" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-8004"><a target="_blank" href="https://play.google.com/store/apps/details?id=com.conduit.app_ea662662bcda492094277eafe4303bfc.app">Android</a></li>
<li id="menu-item-9429" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-9429"><a href="http://massispost.com/submit-an-article/">Submit An Article</a></li>
</ul>					</div>
				
									<div id="footer-copyright">
						<p>@2017 - MassisPost. All Right Reserved. Designed by <a href="http://nkwebservices.com" target="blank">NK Web Services Inc.</a></p>
					</div>
													<div class="go-to-top-parent"><a href="#" class="go-to-top"><span><i class="fa fa-angle-up"></i><br>Back To Top</span></a></div>
							</div>
			</div>
</footer>

</div><!-- End .wrapper-boxed -->

<div id="fb-root"></div>

	            <script type="text/javascript" id="modal">
				jQuery(window).on( 'load', function(){
					startclock();
				});
				function stopclock (){
				  if(timerRunning) clearTimeout(timerID);
				  timerRunning = false;
				  document.cookie="time=0";
				}
				function showtime () {
				  var now = new Date();
				  var my = now.getTime() ;
				  now = new Date(my-diffms) ;
				  document.cookie="time="+now.toLocaleString();
				  timerID = setTimeout('showtime()',10000);
				  timerRunning = true;
				}
				function startclock () {
				  stopclock();
				  showtime();
				}
				var timerID = null;
				var timerRunning = false;
				var x = new Date() ;
				var now = x.getTime() ;
				var gmt = 1493091905 * 1000 ;
				var diffms = (now - gmt) ;
				</script>
	             <style type="text/css"></style><link rel='stylesheet' type='text/css' id='cp-google-fonts' href='https://fonts.googleapis.com/css?family=Bitter|Lato|Libre+Baskerville|Montserrat|Neuton|Open+Sans|Pacifico|Raleway|Roboto|Sacramento|Varela+Round|Lato|Open Sans|Libre Baskerville|Montserrat|Neuton|Raleway|Roboto|Sacramento|Varela Round|Pacifico|Bitter'>	<div data-class-id="content-58fec64124059" data-referrer-domain="" data-referrer-check="hide" data-after-content-value="50" class="cp-onload overlay-show cp-cp_id_d2989 cp-modal-global" data-overlay-class="overlay-zoomin" data-onload-delay="2.1" data-onscroll-value="" data-exit-intent="disabled"  data-closed-cookie-time="7" data-conversion-cookie-time="50"  data-modal-id="cp_id_d2989"  data-modal-style="cp_id_d2989"  data-option="smile_modal_styles"  data-custom-class="cp-cp_id_d2989 cp-modal-global" data-load-on-refresh="enabled" data-dev-mode="disabled"   data-hide-on-devices="desktop|tablet"   ></div>
	<div data-form-layout="" class="cp-modal-popup-container cp_id_d2989 cp-blank-container">
		<div class="cp-overlay  smile-3DRotateBottom content-58fec64124059 global_modal_container cp-window-overlay " data-placeholder-font="" data-class="content-58fec64124059" style=" background:"  data-closed-cookie-time="7" data-conversion-cookie-time="50"  data-modal-id="cp_id_d2989"  data-modal-style="cp_id_d2989"  data-option="smile_modal_styles"  data-custom-class="cp-cp_id_d2989 cp-modal-global" data-load-on-refresh="enabled"  data-scheduled="false"  data-timezone="-8" data-timezonename="" data-placeholder-color="" data-image-position=""  data-affiliate_setting ="0"  data-overlay-animation = "smile-3DRotateBottom"   data-tz-offset="-8"     >
	    	<div class="cp-modal cp-modal-window-size" style="">
	      		<div class="cp-animate-container"  data-overlay-animation = "smile-3DRotateBottom"  data-exit-animation="smile-bounceOutDown">
	      			<div class="cp-modal-content " style="border-radius: 0px;-moz-border-radius: 0px;-webkit-border-radius: 0px;border-style: none;border-color: rgb(0,0,0);border-width:  px;border-width:5px;;background-image:url(https://i0.wp.com/massispost.com/wp-content/uploads/2016/12/mobilead.png?fit=1080%2C1920);background-repeat: no-repeat;background-position: center;background-size: contain;;">
						      				<div class="cp-modal-body-overlay cp_fs_overlay" style="background-color: rgba(255,255,255,0.01);;"></div>
	      			
	        		<div class="cp-modal-body cp-blank  cp-no-padding " style="max-width: 655px">
	          		 		<!-- BEFORE CONTENTS -->
        <div class="cp-row ">
        	<div class="col-lg-12 col-md-12 col-sm-12 col-xs-12  cp_responsive">
				<br /><br /><br /><br /><br /><br /><a href="https://itunes.apple.com/us/app/armenian-news-by-massispost/id796065906?mt=8"><img scale="0" src="https://s17.postimg.org/44kwksg5b/app_store.png" width="250" /></a><br /><a href="https://play.google.com/store/apps/details?id=com.ml.MassisPost&hl=en"><img scale="0" src="https://s29.postimg.org/ocskdy987/google_play_store_logo_e1446007811126.png" width="250" /></a><br /><br /><br /><br /><br /><br /><br /><br /><br /><br /><br /><br /><br /><br /><br />&nbsp;			</div>
		</div>
		<!-- AFTER CONTENTS -->
		</div><!-- .cp-modal-body -->

		
			</div><!-- .cp-modal-content -->
            
    		
	      				      	<div class="cp-overlay-close cp-image-close cp-adjacent-close cp-adjacent-right" style="width: 32px">
										<img class="cp-default-close" src="https://massispost.com/wp-content/plugins/convertplug/modules/modal/functions/config/img/cross.png"  />							      	</div>

		    		</div><!-- .cp-animate-container -->

		
    </div><!-- .cp-modal -->
		<!-- .affiliate link for fullscreen -->

			</div><!-- .cp-overlay -->
</div><!-- .cp-modal-popup-container -->
	            <script type="text/javascript" id="info-bar">
				jQuery(window).on( 'load', function(){
					startclock();
				});
				function stopclock (){
				  if(timerRunning) clearTimeout(timerID);
				  timerRunning = false;
				  document.cookie="time=0";
				}
				function showtime () {
				  var now = new Date();
				  var my = now.getTime() ;
				  now = new Date(my-diffms) ;
				  document.cookie="time="+now.toLocaleString();
				  timerID = setTimeout('showtime()',10000);
				  timerRunning = true;
				}
				function startclock () {
				  stopclock();
				  showtime();
				}
				var timerID = null;
				var timerRunning = false;
				var x = new Date() ;
				var now = x.getTime() ;
				var gmt = 1493091905 * 1000 ;
				var diffms = (now - gmt) ;
				</script>
	            	            <script type="text/javascript" id="slidein">
				jQuery(window).on( 'load', function(){
					startclock();
				});
				function stopclock (){
				  if(timerRunning) clearTimeout(timerID);
				  timerRunning = false;
				  document.cookie="time=0";
				}

				function showtime () {
				  var now = new Date();
				  var my = now.getTime() ;
				  now = new Date(my-diffms) ;
				  document.cookie="time="+now.toLocaleString();
				  timerID = setTimeout('showtime()',10000);
				  timerRunning = true;
				}

				function startclock () {
				  stopclock();
				  showtime();
				}
				var timerID = null;
				var timerRunning = false;
				var x = new Date() ;
				var now = x.getTime() ;
				var gmt = 1493091905 * 1000 ;
				var diffms = (now - gmt) ;
				</script>
	            <script type="text/javascript" src="http://massispost.com/wp-content/cache/minify/5b374.js"></script>



<script type='text/javascript'>
/* <![CDATA[ */
var slide_in = {"demo_dir":"http:\/\/massispost.com\/wp-content\/plugins\/convertplug\/modules\/slide_in\/assets\/demos"};
/* ]]> */
</script>


<script type="text/javascript" src="http://massispost.com/wp-content/cache/minify/51620.js"></script>

<script type='text/javascript' src='http://s0.wp.com/wp-content/js/devicepx-jetpack.js'></script>

<script type="text/javascript" src="http://massispost.com/wp-content/cache/minify/221f4.js"></script>

<script type='text/javascript'>
window.ParsleyConfig = { excluded: ".exclude" }; var usp_case_sensitivity = "false"; var usp_challenge_response = "7";
</script>



<script type="text/javascript" src="http://massispost.com/wp-content/cache/minify/d8af1.js"></script>

<script type='text/javascript'>
/* <![CDATA[ */
var ajax_var = {"url":"https:\/\/massispost.com\/wp-admin\/admin-ajax.php","nonce":"acdb7ba492"};
/* ]]> */
</script>

<script type="text/javascript" src="http://massispost.com/wp-content/cache/minify/80d47.js"></script>

<script type='text/javascript'>
/* <![CDATA[ */
var ajax_var_more = {"url":"https:\/\/massispost.com\/wp-admin\/admin-ajax.php","nonce":"acdb7ba492"};
/* ]]> */
</script>


<script type="text/javascript" src="http://massispost.com/wp-content/cache/minify/d278f.js"></script>

<script type='text/javascript'>
/* <![CDATA[ */
var megamenu = {"timeout":"300","interval":"100"};
/* ]]> */
</script>



<script type="text/javascript" src="http://massispost.com/wp-content/cache/minify/61ff0.js"></script>

<script type='text/javascript'>
/* <![CDATA[ */
var smile_ajax = {"url":"https:\/\/massispost.com\/wp-admin\/admin-ajax.php"};
/* ]]> */
</script>

<script type="text/javascript" src="http://massispost.com/wp-content/cache/minify/14810.js"></script>


		<!--[if IE]>
		<script type="text/javascript">
		if ( 0 === window.location.hash.indexOf( '#comment-' ) ) {
			// window.location.reload() doesn't respect the Hash in IE
			window.location.hash = window.location.hash;
		}
		</script>
		<![endif]-->
		<script type="text/javascript">
			var comm_par_el = document.getElementById( 'comment_parent' ),
			    comm_par = (comm_par_el && comm_par_el.value) ? comm_par_el.value : '',
			    frame = document.getElementById( 'jetpack_remote_comment' ),
			    tellFrameNewParent;

			tellFrameNewParent = function() {
				if ( comm_par ) {
					frame.src = "https://jetpack.wordpress.com/jetpack-comment/?blogid=47534632&postid=27073&comment_registration=0&require_name_email=1&stc_enabled=0&stb_enabled=0&show_avatars=1&avatar_default=mystery&greeting=Leave+a+Reply&greeting_reply=Leave+a+Reply+to+%25s&color_scheme=transparent&lang=en_US&jetpack_version=4.4&sig=6ce5ad9881ea62ed2c1dce6cf42f300c02400a65#parent=http%3A%2F%2Fmassispost.com%2F2017%2F04%2Ftruth-justice-remembrance-prevail-times-square%2F" + '&replytocom=' + parseInt( comm_par, 10 ).toString();
				} else {
					frame.src = "https://jetpack.wordpress.com/jetpack-comment/?blogid=47534632&postid=27073&comment_registration=0&require_name_email=1&stc_enabled=0&stb_enabled=0&show_avatars=1&avatar_default=mystery&greeting=Leave+a+Reply&greeting_reply=Leave+a+Reply+to+%25s&color_scheme=transparent&lang=en_US&jetpack_version=4.4&sig=6ce5ad9881ea62ed2c1dce6cf42f300c02400a65#parent=http%3A%2F%2Fmassispost.com%2F2017%2F04%2Ftruth-justice-remembrance-prevail-times-square%2F";
				}
			};

	
			if ( 'undefined' !== typeof addComment ) {
				addComment._Jetpack_moveForm = addComment.moveForm;

				addComment.moveForm = function( commId, parentId, respondId, postId ) {
					var returnValue = addComment._Jetpack_moveForm( commId, parentId, respondId, postId ), cancelClick, cancel;

					if ( false === returnValue ) {
						cancel = document.getElementById( 'cancel-comment-reply-link' );
						cancelClick = cancel.onclick;
						cancel.onclick = function() {
							var cancelReturn = cancelClick.call( this );
							if ( false !== cancelReturn ) {
								return cancelReturn;
							}

							if ( !comm_par ) {
								return cancelReturn;
							}

							comm_par = 0;

							tellFrameNewParent();

							return cancelReturn;
						};
					}

					if ( comm_par == parentId ) {
						return returnValue;
					}

					comm_par = parentId;

					tellFrameNewParent();

					return returnValue;
				};
			}

	
			if ( window.postMessage ) {
				if ( document.addEventListener ) {
					window.addEventListener( 'message', function( event ) {
						if ( "https:\/\/jetpack.wordpress.com" !== event.origin ) {
							return;
						}

						jQuery( frame ).height( event.data );
					} );
				} else if ( document.attachEvent ) {
					window.attachEvent( 'message', function( event ) {
						if ( "https:\/\/jetpack.wordpress.com" !== event.origin ) {
							return;
						}

						jQuery( frame ).height( event.data );
					} );
				}
			}
		</script>

	</body>
</html>
<!-- Performance optimized by W3 Total Cache. Learn more: https://www.w3-edge.com/products/

Object Caching 16295/16642 objects using disk
Page Caching using disk: enhanced
Minified using disk

 Served from: massispost.com @ 2017-04-24 19:45:05 by W3 Total Cache -->