<!DOCTYPE html>
<html lang="en-US" xmlns:fb="https://www.facebook.com/2008/fbml" xmlns:addthis="https://www.addthis.com/help/api-spec"  prefix="og: http://ogp.me/ns#">
<head>


	<meta property="fb:pages" content="116412075092856" />
	<meta charset="UTF-8">
	<meta http-equiv="X-UA-Compatible" content="IE=edge">
	<meta name="viewport" content="width=device-width, initial-scale=1">
	<title>PM Pashinian Satisfied With ‘Productive’ Talks With President Putin - Armenian News By MassisPost</title>
	<link rel="profile" href="http://gmpg.org/xfn/11" />
		<link rel="alternate" type="application/rss+xml" title="Armenian News By MassisPost RSS Feed" href="https://massispost.com/feed/" />
	<link rel="alternate" type="application/atom+xml" title="Armenian News By MassisPost Atom Feed" href="https://massispost.com/feed/atom/" />
	<link rel="pingback" href="https://massispost.com/xmlrpc.php" />
	<!--[if lt IE 9]>
	<script src="https://cdn2.massispost.com/wp-content/themes/soledad/js/html5.js"></script>
	<style type="text/css">
		.featured-carousel .item { opacity: 1; }
	</style>
	<![endif]-->
	
<!-- This site is optimized with the Yoast SEO plugin v7.3 - https://yoast.com/wordpress/plugins/seo/ -->
<link rel="canonical" href="https://massispost.com/2018/05/pm-pashinian-satisfied-with-productive-talks-with-president-putin/" />
<meta property="og:locale" content="en_US" />
<meta property="og:type" content="article" />
<meta property="og:title" content="PM Pashinian Satisfied With ‘Productive’ Talks With President Putin - Armenian News By MassisPost" />
<meta property="og:description" content="YEREVAN (RFE/RL) &#8212; Armenian Prime Minister Nikol Pashinian on Tuesday described as “very productive” his first meeting with Russian President Vladimir Putin&hellip;" />
<meta property="og:url" content="https://massispost.com/2018/05/pm-pashinian-satisfied-with-productive-talks-with-president-putin/" />
<meta property="og:site_name" content="Armenian News By MassisPost" />
<meta property="article:section" content="Armenia" />
<meta property="article:published_time" content="2018-05-15T07:08:25+00:00" />
<meta property="og:image" content="https://cdn5.massispost.com/wp-content/uploads/2018/05/pashinyan-putin-2.jpg" />
<meta property="og:image:secure_url" content="https://cdn5.massispost.com/wp-content/uploads/2018/05/pashinyan-putin-2.jpg" />
<meta property="og:image:width" content="850" />
<meta property="og:image:height" content="566" />
<meta name="twitter:card" content="summary" />
<meta name="twitter:description" content="YEREVAN (RFE/RL) &#8212; Armenian Prime Minister Nikol Pashinian on Tuesday described as “very productive” his first meeting with Russian President Vladimir Putin&hellip;" />
<meta name="twitter:title" content="PM Pashinian Satisfied With ‘Productive’ Talks With President Putin - Armenian News By MassisPost" />
<meta name="twitter:image" content="https://i1.wp.com/massispost.com/wp-content/uploads/2018/05/pashinyan-putin-2.jpg?fit=850%2C566&#038;ssl=1" />
<!-- / Yoast SEO plugin. -->

<link rel="amphtml" href="https://massispost.com/2018/05/pm-pashinian-satisfied-with-productive-talks-with-president-putin/amp/" /><link rel='dns-prefetch' href='//s7.addthis.com' />
<link rel='dns-prefetch' href='//s0.wp.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="Armenian News By MassisPost &raquo; Feed" href="https://massispost.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="Armenian News By MassisPost &raquo; Comments Feed" href="https://massispost.com/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="Armenian News By MassisPost &raquo; PM Pashinian Satisfied With ‘Productive’ Talks With President Putin Comments Feed" href="https://massispost.com/2018/05/pm-pashinian-satisfied-with-productive-talks-with-president-putin/feed/" />
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.4\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.4\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/massispost.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=4.9.5"}};
			!function(a,b,c){function d(a,b){var c=String.fromCharCode;l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,a),0,0);var d=k.toDataURL();l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,b),0,0);var e=k.toDataURL();return d===e}function e(a){var b;if(!l||!l.fillText)return!1;switch(l.textBaseline="top",l.font="600 32px Arial",a){case"flag":return!(b=d([55356,56826,55356,56819],[55356,56826,8203,55356,56819]))&&(b=d([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]),!b);case"emoji":return b=d([55357,56692,8205,9792,65039],[55357,56692,8203,9792,65039]),!b}return!1}function f(a){var c=b.createElement("script");c.src=a,c.defer=c.type="text/javascript",b.getElementsByTagName("head")[0].appendChild(c)}var g,h,i,j,k=b.createElement("canvas"),l=k.getContext&&k.getContext("2d");for(j=Array("flag","emoji"),c.supports={everything:!0,everythingExceptFlag:!0},i=0;i<j.length;i++)c.supports[j[i]]=e(j[i]),c.supports.everything=c.supports.everything&&c.supports[j[i]],"flag"!==j[i]&&(c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&c.supports[j[i]]);c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&!c.supports.flag,c.DOMReady=!1,c.readyCallback=function(){c.DOMReady=!0},c.supports.everything||(h=function(){c.readyCallback()},b.addEventListener?(b.addEventListener("DOMContentLoaded",h,!1),a.addEventListener("load",h,!1)):(a.attachEvent("onload",h),b.attachEvent("onreadystatechange",function(){"complete"===b.readyState&&c.readyCallback()})),g=c.source||{},g.concatemoji?f(g.concatemoji):g.wpemoji&&g.twemoji&&(f(g.twemoji),f(g.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
<link rel='stylesheet' id='menu-icons-extra-css'  href='https://cdn5.massispost.com/wp-content/plugins/menu-icons/css/extra.min.css?ver=0.11.0' type='text/css' media='all' />
<link rel='stylesheet' id='contact-form-7-css'  href='https://cdn5.massispost.com/wp-content/plugins/contact-form-7/includes/css/styles.css?ver=4.9.1' type='text/css' media='all' />
<link rel='stylesheet' id='dashicons-css'  href='https://cdn5.massispost.com/wp-includes/css/dashicons.min.css?ver=4.9.5' type='text/css' media='all' />
<link rel='stylesheet' id='penci_style-css'  href='https://cdn5.massispost.com/wp-content/themes/soledad/style.css?ver=2.6.1' type='text/css' media='all' />
<link rel='stylesheet' id='open-sans-css'  href='https://fonts.googleapis.com/css?family=Open+Sans%3A300italic%2C400italic%2C600italic%2C300%2C400%2C600&#038;subset=latin%2Clatin-ext&#038;ver=4.9.5' type='text/css' media='all' />
<link rel='stylesheet' id='addthis_all_pages-css'  href='https://cdn5.massispost.com/wp-content/plugins/addthis/frontend/build/addthis_wordpress_public.min.css?ver=4.9.5' type='text/css' media='all' />
<link rel='stylesheet' id='jetpack_css-css'  href='https://cdn5.massispost.com/wp-content/plugins/jetpack/css/jetpack.css?ver=6.0' type='text/css' media='all' />
<script type='text/javascript' src='https://cdn2.massispost.com/wp-includes/js/jquery/jquery.js?ver=1.12.4'></script>
<script type='text/javascript' src='https://cdn2.massispost.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=1.4.1'></script>
<script type='text/javascript' src='https://cdn2.massispost.com/wp-content/plugins/jetpack/_inc/build/postmessage.min.js?ver=6.0'></script>
<script type='text/javascript' src='https://cdn2.massispost.com/wp-content/plugins/jetpack/_inc/build/jquery.jetpack-resize.min.js?ver=6.0'></script>
<link rel='https://api.w.org/' href='https://massispost.com/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://massispost.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://cdn5.massispost.com/wp-includes/wlwmanifest.xml" /> 
<meta name="generator" content="WordPress 4.9.5" />
<link rel='shortlink' href='https://massispost.com/?p=31553' />
<link rel="alternate" type="application/json+oembed" href="https://massispost.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fmassispost.com%2F2018%2F05%2Fpm-pashinian-satisfied-with-productive-talks-with-president-putin%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://massispost.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fmassispost.com%2F2018%2F05%2Fpm-pashinian-satisfied-with-productive-talks-with-president-putin%2F&#038;format=xml" />
<meta name="apple-itunes-app" content="app-id=796065906"><script type="text/javascript">
(function(url){
	if(/(?:Chrome\/26\.0\.1410\.63 Safari\/537\.31|WordfenceTestMonBot)/.test(navigator.userAgent)){ return; }
	var addEvent = function(evt, handler) {
		if (window.addEventListener) {
			document.addEventListener(evt, handler, false);
		} else if (window.attachEvent) {
			document.attachEvent('on' + evt, handler);
		}
	};
	var removeEvent = function(evt, handler) {
		if (window.removeEventListener) {
			document.removeEventListener(evt, handler, false);
		} else if (window.detachEvent) {
			document.detachEvent('on' + evt, handler);
		}
	};
	var evts = 'contextmenu dblclick drag dragend dragenter dragleave dragover dragstart drop keydown keypress keyup mousedown mousemove mouseout mouseover mouseup mousewheel scroll'.split(' ');
	var logHuman = function() {
		var wfscr = document.createElement('script');
		wfscr.type = 'text/javascript';
		wfscr.async = true;
		wfscr.src = url + '&r=' + Math.random();
		(document.getElementsByTagName('head')[0]||document.getElementsByTagName('body')[0]).appendChild(wfscr);
		for (var i = 0; i < evts.length; i++) {
			removeEvent(evts[i], logHuman);
		}
	};
	for (var i = 0; i < evts.length; i++) {
		addEvent(evts[i], logHuman);
	}
})('//massispost.com/?wordfence_lh=1&hid=F001D7EC5F5CAE890EBEC7A81BD3208B');
</script>
<link rel='dns-prefetch' href='//jetpack.wordpress.com'/>
<link rel='dns-prefetch' href='//s0.wp.com'/>
<link rel='dns-prefetch' href='//s1.wp.com'/>
<link rel='dns-prefetch' href='//s2.wp.com'/>
<link rel='dns-prefetch' href='//public-api.wordpress.com'/>
<link rel='dns-prefetch' href='//0.gravatar.com'/>
<link rel='dns-prefetch' href='//1.gravatar.com'/>
<link rel='dns-prefetch' href='//2.gravatar.com'/>
<link rel='dns-prefetch' href='//widgets.wp.com'/>
<link rel='dns-prefetch' href='//i0.wp.com'/>
<link rel='dns-prefetch' href='//i1.wp.com'/>
<link rel='dns-prefetch' href='//i2.wp.com'/>
    <style type="text/css">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</style>
          <meta name="onesignal" content="wordpress-plugin"/>
          <link rel="manifest"
            href="https://cdn2.massispost.com/wp-content/plugins/onesignal-free-web-push-notifications/sdk_files/manifest.json.php?gcm_sender_id="/>
          <script src="https://cdn.onesignal.com/sdks/OneSignalSDK.js" async></script>    <script>

      window.OneSignal = window.OneSignal || [];

      OneSignal.push( function() {
        OneSignal.SERVICE_WORKER_UPDATER_PATH = "OneSignalSDKUpdaterWorker.js.php";
        OneSignal.SERVICE_WORKER_PATH = "OneSignalSDKWorker.js.php";
        OneSignal.SERVICE_WORKER_PARAM = { scope: '/' };

        OneSignal.setDefaultNotificationUrl("https://massispost.com");
        var oneSignal_options = {};
        window._oneSignalInitOptions = oneSignal_options;

        oneSignal_options['wordpress'] = true;
oneSignal_options['appId'] = '5c5f1dd8-fcc4-426e-8d4b-be176dae85b2';
oneSignal_options['autoRegister'] = true;
oneSignal_options['httpPermissionRequest'] = { };
oneSignal_options['httpPermissionRequest']['enable'] = true;
oneSignal_options['welcomeNotification'] = { };
oneSignal_options['welcomeNotification']['title'] = "";
oneSignal_options['welcomeNotification']['message'] = "";
oneSignal_options['path'] = "https://massispost.com/wp-content/plugins/onesignal-free-web-push-notifications/sdk_files/";
oneSignal_options['safari_web_id'] = "web.onesignal.auto.11a76d30-e2a9-4f46-9be9-382fbd4a01f1";
oneSignal_options['promptOptions'] = { };
oneSignal_options['notifyButton'] = { };
oneSignal_options['notifyButton']['enable'] = true;
oneSignal_options['notifyButton']['position'] = 'bottom-right';
oneSignal_options['notifyButton']['theme'] = 'default';
oneSignal_options['notifyButton']['size'] = 'large';
oneSignal_options['notifyButton']['prenotify'] = true;
oneSignal_options['notifyButton']['showCredit'] = true;
oneSignal_options['notifyButton']['text'] = {};
              OneSignal.init(window._oneSignalInitOptions);
                    });

      function documentInitOneSignal() {
        var oneSignal_elements = document.getElementsByClassName("OneSignal-prompt");

        var oneSignalLinkClickHandler = function(event) { OneSignal.push(['registerForPushNotifications']); event.preventDefault(); };        for(var i = 0; i < oneSignal_elements.length; i++)
          oneSignal_elements[i].addEventListener('click', oneSignalLinkClickHandler, false);
      }

      if (document.readyState === 'complete') {
           documentInitOneSignal();
      }
      else {
           window.addEventListener("load", function(event){
               documentInitOneSignal();
          });
      }
    </script>


<!-- BEGIN GADWP v5.3.2 Universal Analytics - https://deconf.com/google-analytics-dashboard-wordpress/ -->
<script>
(function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
	(i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
	m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
})(window,document,'script','https://www.google-analytics.com/analytics.js','ga');
  ga('create', 'UA-30283758-1', 'auto');
  ga('send', 'pageview');
</script>
<!-- END GADWP Universal Analytics -->
<style type="text/css">/** Mega Menu CSS: fs **/</style>
<!-- Global site tag (gtag.js) - Google Analytics -->
<script async src="https://www.googletagmanager.com/gtag/js?id=UA-30283758-1"></script>
<script>
  window.dataLayer = window.dataLayer || [];
  function gtag(){dataLayer.push(arguments);}
  gtag('js', new Date());

  gtag('config', 'UA-30283758-1');
</script>
<!-- Go to www.addthis.com/dashboard to customize your tools --> <script type="text/javascript" src="//s7.addthis.com/js/300/addthis_widget.js#pubid=ra-5556226714325ad2"></script>

</head>

<body class="post-template-default single single-post postid-31553 single-format-standard penci-body-boxed">
<a id="close-sidebar-nav" class="header-3"><i class="fa fa-close"></i></a>

<nav id="sidebar-nav" class="header-3">

			<div id="sidebar-nav-logo">
							<a href="https://massispost.com/"><img src="https://cdn5.massispost.com/wp-content/uploads/2017/06/massismainnewB.jpg" alt="Armenian News By MassisPost" /></a>
					</div>
	
	
	<ul id="menu-massispost" class="menu"><li id="menu-item-23224" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-23224"><a href="https://massispost.com">Home</a></li>
<li id="menu-item-3216" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent penci-mega-menu menu-item-3216"><a href="https://massispost.com/category/news/">News</a>
<ul class="sub-menu">
	<li id="menu-item-0" class="menu-item-0"><div class="penci-megamenu">		
		<div class="penci-content-megamenu">
			<div class="penci-mega-latest-posts col-mn-5 mega-row-1">
								<div class="penci-mega-row penci-mega-3 row-active">
											<div class="penci-mega-post">
							<div class="penci-mega-thumbnail">
																<span class="mega-cat-name">
																			News																	</span>
																<a href="https://massispost.com/2018/05/pm-pashinian-satisfied-with-productive-talks-with-president-putin/" title="PM Pashinian Satisfied With ‘Productive’ Talks With President Putin">
																		<img width="585" height="390" src="https://i1.wp.com/massispost.com/wp-content/uploads/2018/05/pashinyan-putin-2.jpg?resize=585%2C390&amp;ssl=1" class="attachment-penci-thumb size-penci-thumb wp-post-image" alt="" srcset="https://i1.wp.com/massispost.com/wp-content/uploads/2018/05/pashinyan-putin-2.jpg?w=850&amp;ssl=1 850w, https://i1.wp.com/massispost.com/wp-content/uploads/2018/05/pashinyan-putin-2.jpg?resize=300%2C200&amp;ssl=1 300w, https://i1.wp.com/massispost.com/wp-content/uploads/2018/05/pashinyan-putin-2.jpg?resize=768%2C511&amp;ssl=1 768w, https://i1.wp.com/massispost.com/wp-content/uploads/2018/05/pashinyan-putin-2.jpg?resize=585%2C390&amp;ssl=1 585w" sizes="(max-width: 585px) 100vw, 585px" />								</a>
							</div>
							<div class="penci-mega-meta">
								<h3 class="post-mega-title">
									<a href="https://massispost.com/2018/05/pm-pashinian-satisfied-with-productive-talks-with-president-putin/">PM Pashinian Satisfied With ‘Productive’ Talks With President Putin</a>
								</h3>
																<p class="penci-mega-date">May 15, 2018</p>
															</div>
						</div>
											<div class="penci-mega-post">
							<div class="penci-mega-thumbnail">
																<span class="mega-cat-name">
																			News																	</span>
																<a href="https://massispost.com/2018/05/new-armenian-government-formed/" title="New Armenian Government Formed">
																		<img width="585" height="390" src="https://i0.wp.com/massispost.com/wp-content/uploads/2018/05/new-cabinet.jpg?resize=585%2C390&amp;ssl=1" class="attachment-penci-thumb size-penci-thumb wp-post-image" alt="" />								</a>
							</div>
							<div class="penci-mega-meta">
								<h3 class="post-mega-title">
									<a href="https://massispost.com/2018/05/new-armenian-government-formed/">New Armenian Government Formed</a>
								</h3>
																<p class="penci-mega-date">May 13, 2018</p>
															</div>
						</div>
											<div class="penci-mega-post">
							<div class="penci-mega-thumbnail">
																<span class="mega-cat-name">
																			News																	</span>
																<a href="https://massispost.com/2018/05/pashinian-invites-renowned-economist-daron-acemoglu-to-restore-armenias-economy/" title="Pashinian Invites Renowned  Economist Daron Acemoglu to Restore Armenia’s Economy">
																		<img width="585" height="390" src="https://i1.wp.com/massispost.com/wp-content/uploads/2018/05/daron-acemoglu.jpg?resize=585%2C390&amp;ssl=1" class="attachment-penci-thumb size-penci-thumb wp-post-image" alt="" srcset="https://i1.wp.com/massispost.com/wp-content/uploads/2018/05/daron-acemoglu.jpg?resize=585%2C390&amp;ssl=1 585w, https://i1.wp.com/massispost.com/wp-content/uploads/2018/05/daron-acemoglu.jpg?resize=840%2C559&amp;ssl=1 840w" sizes="(max-width: 585px) 100vw, 585px" />								</a>
							</div>
							<div class="penci-mega-meta">
								<h3 class="post-mega-title">
									<a href="https://massispost.com/2018/05/pashinian-invites-renowned-economist-daron-acemoglu-to-restore-armenias-economy/">Pashinian Invites Renowned  Economist Daron Acemoglu to Restore Armenia’s Economy</a>
								</h3>
																<p class="penci-mega-date">May 13, 2018</p>
															</div>
						</div>
											<div class="penci-mega-post">
							<div class="penci-mega-thumbnail">
																<span class="mega-cat-name">
																			News																	</span>
																<a href="https://massispost.com/2018/05/release-of-political-prisoners-in-armenia-has-started-and-should-continue/" title="Release of Political Prisoners in Armenia Has Started and Should Continue">
																		<img width="585" height="390" src="https://i0.wp.com/massispost.com/wp-content/uploads/2018/05/Political-Prisoners.jpeg?resize=585%2C390&amp;ssl=1" class="attachment-penci-thumb size-penci-thumb wp-post-image" alt="" />								</a>
							</div>
							<div class="penci-mega-meta">
								<h3 class="post-mega-title">
									<a href="https://massispost.com/2018/05/release-of-political-prisoners-in-armenia-has-started-and-should-continue/">Release of Political Prisoners in Armenia Has Started and Should Continue</a>
								</h3>
																<p class="penci-mega-date">May 13, 2018</p>
															</div>
						</div>
											<div class="penci-mega-post">
							<div class="penci-mega-thumbnail">
																<span class="mega-cat-name">
																			News																	</span>
																<a href="https://massispost.com/2018/05/azerbaijan-threatens-armenia-with-large-scale-military-operations/" title="Azerbaijan Threatens Armenia with &#8216;Large-Scale Military Operations&#8217;">
																		<img width="585" height="390" src="https://i2.wp.com/massispost.com/wp-content/uploads/2018/05/Zakir-Hasanov.jpg?resize=585%2C390&amp;ssl=1" class="attachment-penci-thumb size-penci-thumb wp-post-image" alt="" />								</a>
							</div>
							<div class="penci-mega-meta">
								<h3 class="post-mega-title">
									<a href="https://massispost.com/2018/05/azerbaijan-threatens-armenia-with-large-scale-military-operations/">Azerbaijan Threatens Armenia with &#8216;Large-Scale Military Operations&#8217;</a>
								</h3>
																<p class="penci-mega-date">May 13, 2018</p>
															</div>
						</div>
									</div>
							</div>
		</div>

		</div></li>
</ul>
</li>
<li id="menu-item-3217" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent penci-mega-menu menu-item-3217"><a href="https://massispost.com/category/armenia/">Armenia</a>
<ul class="sub-menu">
	<li class="menu-item-0"><div class="penci-megamenu">				<div class="penci-mega-child-categories">
							<a class="mega-cat-child cat-active" href="https://massispost.com/category/armenia/" data-id="penci-mega-5">All</a>
							<a class="mega-cat-child" href="https://massispost.com/category/armenia/artsakh/" data-id="penci-mega-8">Artsakh</a>
					</div>
		
		<div class="penci-content-megamenu">
			<div class="penci-mega-latest-posts col-mn-4 mega-row-1">
								<div class="penci-mega-row penci-mega-5 row-active">
											<div class="penci-mega-post">
							<div class="penci-mega-thumbnail">
																<span class="mega-cat-name">
																			Armenia																	</span>
																<a href="https://massispost.com/2018/05/pm-pashinian-satisfied-with-productive-talks-with-president-putin/" title="PM Pashinian Satisfied With ‘Productive’ Talks With President Putin">
																		<img width="585" height="390" src="https://i1.wp.com/massispost.com/wp-content/uploads/2018/05/pashinyan-putin-2.jpg?resize=585%2C390&amp;ssl=1" class="attachment-penci-thumb size-penci-thumb wp-post-image" alt="" srcset="https://i1.wp.com/massispost.com/wp-content/uploads/2018/05/pashinyan-putin-2.jpg?w=850&amp;ssl=1 850w, https://i1.wp.com/massispost.com/wp-content/uploads/2018/05/pashinyan-putin-2.jpg?resize=300%2C200&amp;ssl=1 300w, https://i1.wp.com/massispost.com/wp-content/uploads/2018/05/pashinyan-putin-2.jpg?resize=768%2C511&amp;ssl=1 768w, https://i1.wp.com/massispost.com/wp-content/uploads/2018/05/pashinyan-putin-2.jpg?resize=585%2C390&amp;ssl=1 585w" sizes="(max-width: 585px) 100vw, 585px" />								</a>
							</div>
							<div class="penci-mega-meta">
								<h3 class="post-mega-title">
									<a href="https://massispost.com/2018/05/pm-pashinian-satisfied-with-productive-talks-with-president-putin/">PM Pashinian Satisfied With ‘Productive’ Talks With President Putin</a>
								</h3>
																<p class="penci-mega-date">May 15, 2018</p>
															</div>
						</div>
											<div class="penci-mega-post">
							<div class="penci-mega-thumbnail">
																<span class="mega-cat-name">
																			Armenia																	</span>
																<a href="https://massispost.com/2018/05/new-armenian-government-formed/" title="New Armenian Government Formed">
																		<img width="585" height="390" src="https://i0.wp.com/massispost.com/wp-content/uploads/2018/05/new-cabinet.jpg?resize=585%2C390&amp;ssl=1" class="attachment-penci-thumb size-penci-thumb wp-post-image" alt="" />								</a>
							</div>
							<div class="penci-mega-meta">
								<h3 class="post-mega-title">
									<a href="https://massispost.com/2018/05/new-armenian-government-formed/">New Armenian Government Formed</a>
								</h3>
																<p class="penci-mega-date">May 13, 2018</p>
															</div>
						</div>
											<div class="penci-mega-post">
							<div class="penci-mega-thumbnail">
																<span class="mega-cat-name">
																			Armenia																	</span>
																<a href="https://massispost.com/2018/05/pashinian-invites-renowned-economist-daron-acemoglu-to-restore-armenias-economy/" title="Pashinian Invites Renowned  Economist Daron Acemoglu to Restore Armenia’s Economy">
																		<img width="585" height="390" src="https://i1.wp.com/massispost.com/wp-content/uploads/2018/05/daron-acemoglu.jpg?resize=585%2C390&amp;ssl=1" class="attachment-penci-thumb size-penci-thumb wp-post-image" alt="" srcset="https://i1.wp.com/massispost.com/wp-content/uploads/2018/05/daron-acemoglu.jpg?resize=585%2C390&amp;ssl=1 585w, https://i1.wp.com/massispost.com/wp-content/uploads/2018/05/daron-acemoglu.jpg?resize=840%2C559&amp;ssl=1 840w" sizes="(max-width: 585px) 100vw, 585px" />								</a>
							</div>
							<div class="penci-mega-meta">
								<h3 class="post-mega-title">
									<a href="https://massispost.com/2018/05/pashinian-invites-renowned-economist-daron-acemoglu-to-restore-armenias-economy/">Pashinian Invites Renowned  Economist Daron Acemoglu to Restore Armenia’s Economy</a>
								</h3>
																<p class="penci-mega-date">May 13, 2018</p>
															</div>
						</div>
											<div class="penci-mega-post">
							<div class="penci-mega-thumbnail">
																<span class="mega-cat-name">
																			Armenia																	</span>
																<a href="https://massispost.com/2018/05/release-of-political-prisoners-in-armenia-has-started-and-should-continue/" title="Release of Political Prisoners in Armenia Has Started and Should Continue">
																		<img width="585" height="390" src="https://i0.wp.com/massispost.com/wp-content/uploads/2018/05/Political-Prisoners.jpeg?resize=585%2C390&amp;ssl=1" class="attachment-penci-thumb size-penci-thumb wp-post-image" alt="" />								</a>
							</div>
							<div class="penci-mega-meta">
								<h3 class="post-mega-title">
									<a href="https://massispost.com/2018/05/release-of-political-prisoners-in-armenia-has-started-and-should-continue/">Release of Political Prisoners in Armenia Has Started and Should Continue</a>
								</h3>
																<p class="penci-mega-date">May 13, 2018</p>
															</div>
						</div>
									</div>
								<div class="penci-mega-row penci-mega-8">
											<div class="penci-mega-post">
							<div class="penci-mega-thumbnail">
																<span class="mega-cat-name">
																			Artsakh																	</span>
																<a href="https://massispost.com/2018/05/azerbaijan-threatens-armenia-with-large-scale-military-operations/" title="Azerbaijan Threatens Armenia with &#8216;Large-Scale Military Operations&#8217;">
																		<img width="585" height="390" src="https://i2.wp.com/massispost.com/wp-content/uploads/2018/05/Zakir-Hasanov.jpg?resize=585%2C390&amp;ssl=1" class="attachment-penci-thumb size-penci-thumb wp-post-image" alt="" />								</a>
							</div>
							<div class="penci-mega-meta">
								<h3 class="post-mega-title">
									<a href="https://massispost.com/2018/05/azerbaijan-threatens-armenia-with-large-scale-military-operations/">Azerbaijan Threatens Armenia with &#8216;Large-Scale Military Operations&#8217;</a>
								</h3>
																<p class="penci-mega-date">May 13, 2018</p>
															</div>
						</div>
											<div class="penci-mega-post">
							<div class="penci-mega-thumbnail">
																<span class="mega-cat-name">
																			Artsakh																	</span>
																<a href="https://massispost.com/2018/05/prime-minister-nikol-pashinian-visits-artsakh-photos/" title="Prime Minister Nikol Pashinian Visits Artsakh (Photos)">
																		<img width="585" height="390" src="https://i0.wp.com/massispost.com/wp-content/uploads/2018/05/Artsakh-5.jpg?resize=585%2C390&amp;ssl=1" class="attachment-penci-thumb size-penci-thumb wp-post-image" alt="" srcset="https://i0.wp.com/massispost.com/wp-content/uploads/2018/05/Artsakh-5.jpg?w=1670&amp;ssl=1 1670w, https://i0.wp.com/massispost.com/wp-content/uploads/2018/05/Artsakh-5.jpg?resize=300%2C200&amp;ssl=1 300w, https://i0.wp.com/massispost.com/wp-content/uploads/2018/05/Artsakh-5.jpg?resize=768%2C512&amp;ssl=1 768w, https://i0.wp.com/massispost.com/wp-content/uploads/2018/05/Artsakh-5.jpg?resize=1024%2C682&amp;ssl=1 1024w, https://i0.wp.com/massispost.com/wp-content/uploads/2018/05/Artsakh-5.jpg?resize=1170%2C780&amp;ssl=1 1170w, https://i0.wp.com/massispost.com/wp-content/uploads/2018/05/Artsakh-5.jpg?resize=585%2C390&amp;ssl=1 585w" sizes="(max-width: 585px) 100vw, 585px" />								</a>
							</div>
							<div class="penci-mega-meta">
								<h3 class="post-mega-title">
									<a href="https://massispost.com/2018/05/prime-minister-nikol-pashinian-visits-artsakh-photos/">Prime Minister Nikol Pashinian Visits Artsakh (Photos)</a>
								</h3>
																<p class="penci-mega-date">May 9, 2018</p>
															</div>
						</div>
											<div class="penci-mega-post">
							<div class="penci-mega-thumbnail">
																<span class="mega-cat-name">
																			Artsakh																	</span>
																<a href="https://massispost.com/2018/03/members-congress-pay-tribute-halo-trust-employees-killed-landmine-accident-artsakh/" title="Members of Congress Pay Tribute to HALO Trust Employees Killed in Landmine Accident in Artsakh">
																		<img width="585" height="390" src="https://i2.wp.com/massispost.com/wp-content/uploads/2018/03/HALO-Landmines.jpg?resize=585%2C390&amp;ssl=1" class="attachment-penci-thumb size-penci-thumb wp-post-image" alt="" srcset="https://i2.wp.com/massispost.com/wp-content/uploads/2018/03/HALO-Landmines.jpg?resize=300%2C201&amp;ssl=1 300w, https://i2.wp.com/massispost.com/wp-content/uploads/2018/03/HALO-Landmines.jpg?resize=585%2C390&amp;ssl=1 585w" sizes="(max-width: 585px) 100vw, 585px" />								</a>
							</div>
							<div class="penci-mega-meta">
								<h3 class="post-mega-title">
									<a href="https://massispost.com/2018/03/members-congress-pay-tribute-halo-trust-employees-killed-landmine-accident-artsakh/">Members of Congress Pay Tribute to HALO Trust Employees Killed in Landmine Accident in Artsakh</a>
								</h3>
																<p class="penci-mega-date">March 30, 2018</p>
															</div>
						</div>
											<div class="penci-mega-post">
							<div class="penci-mega-thumbnail">
																<span class="mega-cat-name">
																			Artsakh																	</span>
																<a href="https://massispost.com/2018/03/three-armenians-killed-karabakh-landmine-blast/" title="Three Armenians Killed in Karabakh Landmine Blast">
																		<img width="585" height="390" src="https://i0.wp.com/massispost.com/wp-content/uploads/2018/03/halo-karabakh.jpg?resize=585%2C390&amp;ssl=1" class="attachment-penci-thumb size-penci-thumb wp-post-image" alt="" />								</a>
							</div>
							<div class="penci-mega-meta">
								<h3 class="post-mega-title">
									<a href="https://massispost.com/2018/03/three-armenians-killed-karabakh-landmine-blast/">Three Armenians Killed in Karabakh Landmine Blast</a>
								</h3>
																<p class="penci-mega-date">March 29, 2018</p>
															</div>
						</div>
									</div>
							</div>
		</div>

		</div></li>
</ul>
</li>
<li id="menu-item-3220" class="menu-item menu-item-type-taxonomy menu-item-object-category penci-mega-menu menu-item-3220"><a href="https://massispost.com/category/community/">Community</a>
<ul class="sub-menu">
	<li class="menu-item-0"><div class="penci-megamenu">		
		<div class="penci-content-megamenu">
			<div class="penci-mega-latest-posts col-mn-5 mega-row-1">
								<div class="penci-mega-row penci-mega-6 row-active">
											<div class="penci-mega-post">
							<div class="penci-mega-thumbnail">
																<span class="mega-cat-name">
																			Community																	</span>
																<a href="https://massispost.com/2018/05/groundbreaking-ceremony-of-new-armenian-church-campus-in-san-diego/" title="Groundbreaking Ceremony of New Armenian Church Campus in San Diego">
																		<img width="585" height="390" src="https://i0.wp.com/massispost.com/wp-content/uploads/2018/05/sandiego-1.jpeg?resize=585%2C390&amp;ssl=1" class="attachment-penci-thumb size-penci-thumb wp-post-image" alt="" srcset="https://i0.wp.com/massispost.com/wp-content/uploads/2018/05/sandiego-1.jpeg?w=850&amp;ssl=1 850w, https://i0.wp.com/massispost.com/wp-content/uploads/2018/05/sandiego-1.jpeg?resize=300%2C200&amp;ssl=1 300w, https://i0.wp.com/massispost.com/wp-content/uploads/2018/05/sandiego-1.jpeg?resize=768%2C513&amp;ssl=1 768w, https://i0.wp.com/massispost.com/wp-content/uploads/2018/05/sandiego-1.jpeg?resize=585%2C391&amp;ssl=1 585w" sizes="(max-width: 585px) 100vw, 585px" />								</a>
							</div>
							<div class="penci-mega-meta">
								<h3 class="post-mega-title">
									<a href="https://massispost.com/2018/05/groundbreaking-ceremony-of-new-armenian-church-campus-in-san-diego/">Groundbreaking Ceremony of New Armenian Church Campus in San Diego</a>
								</h3>
																<p class="penci-mega-date">May 13, 2018</p>
															</div>
						</div>
											<div class="penci-mega-post">
							<div class="penci-mega-thumbnail">
																<span class="mega-cat-name">
																			Community																	</span>
																<a href="https://massispost.com/2018/05/world-premiere-of-100-aprils-at-rogue-machine/" title="World Premiere of &#8220;100 Aprils&#8221; at Rogue Machine">
																		<img width="585" height="390" src="https://i0.wp.com/massispost.com/wp-content/uploads/2018/05/100-APRILS.jpg?resize=585%2C390&amp;ssl=1" class="attachment-penci-thumb size-penci-thumb wp-post-image" alt="" />								</a>
							</div>
							<div class="penci-mega-meta">
								<h3 class="post-mega-title">
									<a href="https://massispost.com/2018/05/world-premiere-of-100-aprils-at-rogue-machine/">World Premiere of &#8220;100 Aprils&#8221; at Rogue Machine</a>
								</h3>
																<p class="penci-mega-date">May 13, 2018</p>
															</div>
						</div>
											<div class="penci-mega-post">
							<div class="penci-mega-thumbnail">
																<span class="mega-cat-name">
																			Community																	</span>
																<a href="https://massispost.com/2018/05/ararat-eskijian-museum-presents-an-illustrated-talk-by-dr-gabis-harboyan/" title="Ararat-Eskijian Museum Presents an Illustrated  Talk by Dr. Gabis Harboyan">
																		<img width="585" height="390" src="https://i1.wp.com/massispost.com/wp-content/uploads/2018/05/May-17th-talk-by-Garbis-Harboyan.jpg?resize=585%2C390&amp;ssl=1" class="attachment-penci-thumb size-penci-thumb wp-post-image" alt="" />								</a>
							</div>
							<div class="penci-mega-meta">
								<h3 class="post-mega-title">
									<a href="https://massispost.com/2018/05/ararat-eskijian-museum-presents-an-illustrated-talk-by-dr-gabis-harboyan/">Ararat-Eskijian Museum Presents an Illustrated  Talk by Dr. Gabis Harboyan</a>
								</h3>
																<p class="penci-mega-date">May 10, 2018</p>
															</div>
						</div>
											<div class="penci-mega-post">
							<div class="penci-mega-thumbnail">
																<span class="mega-cat-name">
																			Community																	</span>
																<a href="https://massispost.com/2018/05/armenian-studies-program-30th-annual-banquet/" title="Armenian Studies Program 30th Annual Banquet">
																		<img width="585" height="390" src="https://i2.wp.com/massispost.com/wp-content/uploads/2018/05/1-ASP-Banquet.jpg?resize=585%2C390&amp;ssl=1" class="attachment-penci-thumb size-penci-thumb wp-post-image" alt="" />								</a>
							</div>
							<div class="penci-mega-meta">
								<h3 class="post-mega-title">
									<a href="https://massispost.com/2018/05/armenian-studies-program-30th-annual-banquet/">Armenian Studies Program 30th Annual Banquet</a>
								</h3>
																<p class="penci-mega-date">May 10, 2018</p>
															</div>
						</div>
											<div class="penci-mega-post">
							<div class="penci-mega-thumbnail">
																<span class="mega-cat-name">
																			Community																	</span>
																<a href="https://massispost.com/2018/05/the-mysterious-theater-robert-elibekians-reflections-on-theatrical-art/" title="The Mysterious Theater: Robert Elibekian’s Reflections on Theatrical Art">
																		<img width="585" height="390" src="https://i1.wp.com/massispost.com/wp-content/uploads/2018/05/Robert-Elibekian-dencer-35.5x24.5-cm-14x9.5-inches.jpg?resize=585%2C390&amp;ssl=1" class="attachment-penci-thumb size-penci-thumb wp-post-image" alt="" srcset="https://i1.wp.com/massispost.com/wp-content/uploads/2018/05/Robert-Elibekian-dencer-35.5x24.5-cm-14x9.5-inches.jpg?w=800&amp;ssl=1 800w, https://i1.wp.com/massispost.com/wp-content/uploads/2018/05/Robert-Elibekian-dencer-35.5x24.5-cm-14x9.5-inches.jpg?resize=300%2C200&amp;ssl=1 300w, https://i1.wp.com/massispost.com/wp-content/uploads/2018/05/Robert-Elibekian-dencer-35.5x24.5-cm-14x9.5-inches.jpg?resize=768%2C511&amp;ssl=1 768w, https://i1.wp.com/massispost.com/wp-content/uploads/2018/05/Robert-Elibekian-dencer-35.5x24.5-cm-14x9.5-inches.jpg?resize=585%2C389&amp;ssl=1 585w" sizes="(max-width: 585px) 100vw, 585px" />								</a>
							</div>
							<div class="penci-mega-meta">
								<h3 class="post-mega-title">
									<a href="https://massispost.com/2018/05/the-mysterious-theater-robert-elibekians-reflections-on-theatrical-art/">The Mysterious Theater: Robert Elibekian’s Reflections on Theatrical Art</a>
								</h3>
																<p class="penci-mega-date">May 10, 2018</p>
															</div>
						</div>
									</div>
							</div>
		</div>

		</div></li>
</ul>
</li>
<li id="menu-item-3218" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent penci-mega-menu menu-item-3218"><a href="https://massispost.com/category/world/">World</a>
<ul class="sub-menu">
	<li class="menu-item-0"><div class="penci-megamenu">		
		<div class="penci-content-megamenu">
			<div class="penci-mega-latest-posts col-mn-5 mega-row-1">
								<div class="penci-mega-row penci-mega-4 row-active">
											<div class="penci-mega-post">
							<div class="penci-mega-thumbnail">
																<span class="mega-cat-name">
																			World																	</span>
																<a href="https://massispost.com/2018/05/pm-pashinian-satisfied-with-productive-talks-with-president-putin/" title="PM Pashinian Satisfied With ‘Productive’ Talks With President Putin">
																		<img width="585" height="390" src="https://i1.wp.com/massispost.com/wp-content/uploads/2018/05/pashinyan-putin-2.jpg?resize=585%2C390&amp;ssl=1" class="attachment-penci-thumb size-penci-thumb wp-post-image" alt="" srcset="https://i1.wp.com/massispost.com/wp-content/uploads/2018/05/pashinyan-putin-2.jpg?w=850&amp;ssl=1 850w, https://i1.wp.com/massispost.com/wp-content/uploads/2018/05/pashinyan-putin-2.jpg?resize=300%2C200&amp;ssl=1 300w, https://i1.wp.com/massispost.com/wp-content/uploads/2018/05/pashinyan-putin-2.jpg?resize=768%2C511&amp;ssl=1 768w, https://i1.wp.com/massispost.com/wp-content/uploads/2018/05/pashinyan-putin-2.jpg?resize=585%2C390&amp;ssl=1 585w" sizes="(max-width: 585px) 100vw, 585px" />								</a>
							</div>
							<div class="penci-mega-meta">
								<h3 class="post-mega-title">
									<a href="https://massispost.com/2018/05/pm-pashinian-satisfied-with-productive-talks-with-president-putin/">PM Pashinian Satisfied With ‘Productive’ Talks With President Putin</a>
								</h3>
																<p class="penci-mega-date">May 15, 2018</p>
															</div>
						</div>
											<div class="penci-mega-post">
							<div class="penci-mega-thumbnail">
																<span class="mega-cat-name">
																			World																	</span>
																<a href="https://massispost.com/2018/05/turkey-willing-to-normalize-relations-with-armenia-but-with-preconditions/" title="Turkey Willing to Normalize Relations with Armenia but with Preconditions">
																		<img width="585" height="390" src="https://i0.wp.com/massispost.com/wp-content/uploads/2018/05/yildrim.jpg?resize=585%2C390&amp;ssl=1" class="attachment-penci-thumb size-penci-thumb wp-post-image" alt="" />								</a>
							</div>
							<div class="penci-mega-meta">
								<h3 class="post-mega-title">
									<a href="https://massispost.com/2018/05/turkey-willing-to-normalize-relations-with-armenia-but-with-preconditions/">Turkey Willing to Normalize Relations with Armenia but with Preconditions</a>
								</h3>
																<p class="penci-mega-date">May 13, 2018</p>
															</div>
						</div>
											<div class="penci-mega-post">
							<div class="penci-mega-thumbnail">
																<span class="mega-cat-name">
																			World																	</span>
																<a href="https://massispost.com/2018/05/armenian-pm-russian-president-agree-to-strengthen-bilateral-ties/" title="Armenian PM, Russian President Agree to Strengthen Bilateral Ties">
																		<img width="585" height="390" src="https://i2.wp.com/massispost.com/wp-content/uploads/2018/05/Putin-Pashinyan.png?resize=585%2C390&amp;ssl=1" class="attachment-penci-thumb size-penci-thumb wp-post-image" alt="" />								</a>
							</div>
							<div class="penci-mega-meta">
								<h3 class="post-mega-title">
									<a href="https://massispost.com/2018/05/armenian-pm-russian-president-agree-to-strengthen-bilateral-ties/">Armenian PM, Russian President Agree to Strengthen Bilateral Ties</a>
								</h3>
																<p class="penci-mega-date">May 8, 2018</p>
															</div>
						</div>
											<div class="penci-mega-post">
							<div class="penci-mega-thumbnail">
																<span class="mega-cat-name">
																			World																	</span>
																<a href="https://massispost.com/2018/04/statement-by-president-trump-on-armenian-remembrance-day-2018/" title="Statement by President Trump on Armenian Remembrance Day 2018">
																		<img width="585" height="390" src="https://i2.wp.com/massispost.com/wp-content/uploads/2018/04/The-white-house.jpg?resize=585%2C390&amp;ssl=1" class="attachment-penci-thumb size-penci-thumb wp-post-image" alt="" />								</a>
							</div>
							<div class="penci-mega-meta">
								<h3 class="post-mega-title">
									<a href="https://massispost.com/2018/04/statement-by-president-trump-on-armenian-remembrance-day-2018/">Statement by President Trump on Armenian Remembrance Day 2018</a>
								</h3>
																<p class="penci-mega-date">April 24, 2018</p>
															</div>
						</div>
											<div class="penci-mega-post">
							<div class="penci-mega-thumbnail">
																<span class="mega-cat-name">
																			World																	</span>
																<a href="https://massispost.com/2018/04/emmanuel-macron-france-stands-by-armenia-to-commemorate-genocide-anniversary/" title="Emmanuel Macron &#8211; France Stands by Armenia to Commemorate Genocide Anniversary">
																		<img width="585" height="390" src="https://i0.wp.com/massispost.com/wp-content/uploads/2018/04/Emmanuel-Macron.jpg?resize=585%2C390&amp;ssl=1" class="attachment-penci-thumb size-penci-thumb wp-post-image" alt="" srcset="https://i0.wp.com/massispost.com/wp-content/uploads/2018/04/Emmanuel-Macron.jpg?w=800&amp;ssl=1 800w, https://i0.wp.com/massispost.com/wp-content/uploads/2018/04/Emmanuel-Macron.jpg?resize=300%2C200&amp;ssl=1 300w, https://i0.wp.com/massispost.com/wp-content/uploads/2018/04/Emmanuel-Macron.jpg?resize=768%2C512&amp;ssl=1 768w, https://i0.wp.com/massispost.com/wp-content/uploads/2018/04/Emmanuel-Macron.jpg?resize=585%2C390&amp;ssl=1 585w" sizes="(max-width: 585px) 100vw, 585px" />								</a>
							</div>
							<div class="penci-mega-meta">
								<h3 class="post-mega-title">
									<a href="https://massispost.com/2018/04/emmanuel-macron-france-stands-by-armenia-to-commemorate-genocide-anniversary/">Emmanuel Macron &#8211; France Stands by Armenia to Commemorate Genocide Anniversary</a>
								</h3>
																<p class="penci-mega-date">April 24, 2018</p>
															</div>
						</div>
									</div>
							</div>
		</div>

		</div></li>
</ul>
</li>
<li id="menu-item-3228" class="menu-item menu-item-type-taxonomy menu-item-object-category penci-mega-menu menu-item-3228"><a href="https://massispost.com/category/armenian-genocide/">Armenian Genocide</a>
<ul class="sub-menu">
	<li class="menu-item-0"><div class="penci-megamenu">		
		<div class="penci-content-megamenu">
			<div class="penci-mega-latest-posts col-mn-5 mega-row-1">
								<div class="penci-mega-row penci-mega-12 row-active">
											<div class="penci-mega-post">
							<div class="penci-mega-thumbnail">
																<span class="mega-cat-name">
																			Armenian Genocide																	</span>
																<a href="https://massispost.com/2018/05/commemorative-evening-for-the-armenian-genocide-at-the-hebrew-university-of-jerusalem/" title="Commemorative Evening for the Armenian Genocide at   The Hebrew University of Jerusalem">
																		<img width="585" height="390" src="https://i0.wp.com/massispost.com/wp-content/uploads/2018/05/hebrew-university-1.jpeg?resize=585%2C390&amp;ssl=1" class="attachment-penci-thumb size-penci-thumb wp-post-image" alt="" />								</a>
							</div>
							<div class="penci-mega-meta">
								<h3 class="post-mega-title">
									<a href="https://massispost.com/2018/05/commemorative-evening-for-the-armenian-genocide-at-the-hebrew-university-of-jerusalem/">Commemorative Evening for the Armenian Genocide at   The Hebrew University of Jerusalem</a>
								</h3>
																<p class="penci-mega-date">May 3, 2018</p>
															</div>
						</div>
											<div class="penci-mega-post">
							<div class="penci-mega-thumbnail">
																<span class="mega-cat-name">
																			Armenian Genocide																	</span>
																<a href="https://massispost.com/2018/04/times-square-armenian-genocide-commemoration/" title="Times Square Armenian Genocide Commemoration">
																		<img width="585" height="390" src="https://i1.wp.com/massispost.com/wp-content/uploads/2018/04/ny-Crowd.jpg?resize=585%2C390&amp;ssl=1" class="attachment-penci-thumb size-penci-thumb wp-post-image" alt="" srcset="https://i1.wp.com/massispost.com/wp-content/uploads/2018/04/ny-Crowd.jpg?w=850&amp;ssl=1 850w, https://i1.wp.com/massispost.com/wp-content/uploads/2018/04/ny-Crowd.jpg?resize=300%2C200&amp;ssl=1 300w, https://i1.wp.com/massispost.com/wp-content/uploads/2018/04/ny-Crowd.jpg?resize=768%2C512&amp;ssl=1 768w, https://i1.wp.com/massispost.com/wp-content/uploads/2018/04/ny-Crowd.jpg?resize=585%2C390&amp;ssl=1 585w" sizes="(max-width: 585px) 100vw, 585px" />								</a>
							</div>
							<div class="penci-mega-meta">
								<h3 class="post-mega-title">
									<a href="https://massispost.com/2018/04/times-square-armenian-genocide-commemoration/">Times Square Armenian Genocide Commemoration</a>
								</h3>
																<p class="penci-mega-date">April 27, 2018</p>
															</div>
						</div>
											<div class="penci-mega-post">
							<div class="penci-mega-thumbnail">
																<span class="mega-cat-name">
																			Armenian Genocide																	</span>
																<a href="https://massispost.com/2018/04/statement-by-president-trump-on-armenian-remembrance-day-2018/" title="Statement by President Trump on Armenian Remembrance Day 2018">
																		<img width="585" height="390" src="https://i2.wp.com/massispost.com/wp-content/uploads/2018/04/The-white-house.jpg?resize=585%2C390&amp;ssl=1" class="attachment-penci-thumb size-penci-thumb wp-post-image" alt="" />								</a>
							</div>
							<div class="penci-mega-meta">
								<h3 class="post-mega-title">
									<a href="https://massispost.com/2018/04/statement-by-president-trump-on-armenian-remembrance-day-2018/">Statement by President Trump on Armenian Remembrance Day 2018</a>
								</h3>
																<p class="penci-mega-date">April 24, 2018</p>
															</div>
						</div>
											<div class="penci-mega-post">
							<div class="penci-mega-thumbnail">
																<span class="mega-cat-name">
																			Armenian Genocide																	</span>
																<a href="https://massispost.com/2018/04/emmanuel-macron-france-stands-by-armenia-to-commemorate-genocide-anniversary/" title="Emmanuel Macron &#8211; France Stands by Armenia to Commemorate Genocide Anniversary">
																		<img width="585" height="390" src="https://i0.wp.com/massispost.com/wp-content/uploads/2018/04/Emmanuel-Macron.jpg?resize=585%2C390&amp;ssl=1" class="attachment-penci-thumb size-penci-thumb wp-post-image" alt="" srcset="https://i0.wp.com/massispost.com/wp-content/uploads/2018/04/Emmanuel-Macron.jpg?w=800&amp;ssl=1 800w, https://i0.wp.com/massispost.com/wp-content/uploads/2018/04/Emmanuel-Macron.jpg?resize=300%2C200&amp;ssl=1 300w, https://i0.wp.com/massispost.com/wp-content/uploads/2018/04/Emmanuel-Macron.jpg?resize=768%2C512&amp;ssl=1 768w, https://i0.wp.com/massispost.com/wp-content/uploads/2018/04/Emmanuel-Macron.jpg?resize=585%2C390&amp;ssl=1 585w" sizes="(max-width: 585px) 100vw, 585px" />								</a>
							</div>
							<div class="penci-mega-meta">
								<h3 class="post-mega-title">
									<a href="https://massispost.com/2018/04/emmanuel-macron-france-stands-by-armenia-to-commemorate-genocide-anniversary/">Emmanuel Macron &#8211; France Stands by Armenia to Commemorate Genocide Anniversary</a>
								</h3>
																<p class="penci-mega-date">April 24, 2018</p>
															</div>
						</div>
											<div class="penci-mega-post">
							<div class="penci-mega-thumbnail">
																<span class="mega-cat-name">
																			Armenian Genocide																	</span>
																<a href="https://massispost.com/2018/04/erdogan-turkey-shares-the-historical-pain-of-our-armenian-citizens/" title="Erdogan &#8211; &#8220;Turkey Shares the Historical Pain of Our Armenian Citizens”">
																		<img width="585" height="390" src="https://i1.wp.com/massispost.com/wp-content/uploads/2017/03/erdogan.jpg?resize=585%2C390&amp;ssl=1" class="attachment-penci-thumb size-penci-thumb wp-post-image" alt="" />								</a>
							</div>
							<div class="penci-mega-meta">
								<h3 class="post-mega-title">
									<a href="https://massispost.com/2018/04/erdogan-turkey-shares-the-historical-pain-of-our-armenian-citizens/">Erdogan &#8211; &#8220;Turkey Shares the Historical Pain of Our Armenian Citizens”</a>
								</h3>
																<p class="penci-mega-date">April 24, 2018</p>
															</div>
						</div>
									</div>
							</div>
		</div>

		</div></li>
</ul>
</li>
<li id="menu-item-3223" class="menu-item menu-item-type-taxonomy menu-item-object-category penci-mega-menu menu-item-3223"><a href="https://massispost.com/category/commentary/">Commentary</a>
<ul class="sub-menu">
	<li class="menu-item-0"><div class="penci-megamenu">		
		<div class="penci-content-megamenu">
			<div class="penci-mega-latest-posts col-mn-5 mega-row-1">
								<div class="penci-mega-row penci-mega-9 row-active">
											<div class="penci-mega-post">
							<div class="penci-mega-thumbnail">
																<span class="mega-cat-name">
																			Commentary																	</span>
																<a href="https://massispost.com/2018/04/armenias-democratic-triumph-the-atlantic/" title="Armenia&#8217;s Democratic Triumph &#8211; The Atlantic">
																		<img width="585" height="390" src="https://i0.wp.com/massispost.com/wp-content/uploads/2018/04/pashinyan-24-1.jpg?resize=585%2C390&amp;ssl=1" class="attachment-penci-thumb size-penci-thumb wp-post-image" alt="" srcset="https://i0.wp.com/massispost.com/wp-content/uploads/2018/04/pashinyan-24-1.jpg?resize=300%2C201&amp;ssl=1 300w, https://i0.wp.com/massispost.com/wp-content/uploads/2018/04/pashinyan-24-1.jpg?resize=585%2C390&amp;ssl=1 585w" sizes="(max-width: 585px) 100vw, 585px" />								</a>
							</div>
							<div class="penci-mega-meta">
								<h3 class="post-mega-title">
									<a href="https://massispost.com/2018/04/armenias-democratic-triumph-the-atlantic/">Armenia&#8217;s Democratic Triumph &#8211; The Atlantic</a>
								</h3>
																<p class="penci-mega-date">April 24, 2018</p>
															</div>
						</div>
											<div class="penci-mega-post">
							<div class="penci-mega-thumbnail">
																<span class="mega-cat-name">
																			Commentary																	</span>
																<a href="https://massispost.com/2018/04/genocide-and-independence-the-100-year-journey-of-a-nation/" title="Genocide and Independence: The 100-Year Journey of a Nation">
																		<img width="585" height="390" src="https://i0.wp.com/massispost.com/wp-content/uploads/2018/04/armenians-1.png?resize=585%2C390&amp;ssl=1" class="attachment-penci-thumb size-penci-thumb wp-post-image" alt="" />								</a>
							</div>
							<div class="penci-mega-meta">
								<h3 class="post-mega-title">
									<a href="https://massispost.com/2018/04/genocide-and-independence-the-100-year-journey-of-a-nation/">Genocide and Independence: The 100-Year Journey of a Nation</a>
								</h3>
																<p class="penci-mega-date">April 22, 2018</p>
															</div>
						</div>
											<div class="penci-mega-post">
							<div class="penci-mega-thumbnail">
																<span class="mega-cat-name">
																			Commentary																	</span>
																<a href="https://massispost.com/2018/04/aca-calls-for-immediate-release-of-peaceful-demonstrators/" title="ACA Calls For Immediate Release of Peaceful Demonstrators">
																		<img width="585" height="390" src="https://i0.wp.com/massispost.com/wp-content/uploads/2016/08/aca.jpg?resize=585%2C390&amp;ssl=1" class="attachment-penci-thumb size-penci-thumb wp-post-image" alt="" />								</a>
							</div>
							<div class="penci-mega-meta">
								<h3 class="post-mega-title">
									<a href="https://massispost.com/2018/04/aca-calls-for-immediate-release-of-peaceful-demonstrators/">ACA Calls For Immediate Release of Peaceful Demonstrators</a>
								</h3>
																<p class="penci-mega-date">April 22, 2018</p>
															</div>
						</div>
											<div class="penci-mega-post">
							<div class="penci-mega-thumbnail">
																<span class="mega-cat-name">
																			Commentary																	</span>
																<a href="https://massispost.com/2018/04/arsinee-khanjian-open-letter-serzh-sarkisian/" title="Arsinee Khanjian: Open letter to Serzh Sarkisian">
																		<img width="585" height="390" src="https://i2.wp.com/massispost.com/wp-content/uploads/2018/04/arsinee-khanjian.jpg?resize=585%2C390&amp;ssl=1" class="attachment-penci-thumb size-penci-thumb wp-post-image" alt="" srcset="https://i2.wp.com/massispost.com/wp-content/uploads/2018/04/arsinee-khanjian.jpg?resize=585%2C390&amp;ssl=1 585w, https://i2.wp.com/massispost.com/wp-content/uploads/2018/04/arsinee-khanjian.jpg?zoom=2&amp;resize=585%2C390&amp;ssl=1 1170w" sizes="(max-width: 585px) 100vw, 585px" />								</a>
							</div>
							<div class="penci-mega-meta">
								<h3 class="post-mega-title">
									<a href="https://massispost.com/2018/04/arsinee-khanjian-open-letter-serzh-sarkisian/">Arsinee Khanjian: Open letter to Serzh Sarkisian</a>
								</h3>
																<p class="penci-mega-date">April 17, 2018</p>
															</div>
						</div>
											<div class="penci-mega-post">
							<div class="penci-mega-thumbnail">
																<span class="mega-cat-name">
																			Commentary																	</span>
																<a href="https://massispost.com/2018/04/the-march-for-our-lives/" title="The March for Our Lives">
																		<img width="585" height="390" src="https://i0.wp.com/massispost.com/wp-content/uploads/2018/04/forourlives.jpg?resize=585%2C390&amp;ssl=1" class="attachment-penci-thumb size-penci-thumb wp-post-image" alt="" />								</a>
							</div>
							<div class="penci-mega-meta">
								<h3 class="post-mega-title">
									<a href="https://massispost.com/2018/04/the-march-for-our-lives/">The March for Our Lives</a>
								</h3>
																<p class="penci-mega-date">April 1, 2018</p>
															</div>
						</div>
									</div>
							</div>
		</div>

		</div></li>
</ul>
</li>
<li id="menu-item-23223" class="menu-item menu-item-type-taxonomy menu-item-object-category penci-mega-menu menu-item-23223"><a href="https://massispost.com/category/culture/">Arts &#038; Culture</a>
<ul class="sub-menu">
	<li class="menu-item-0"><div class="penci-megamenu">		
		<div class="penci-content-megamenu">
			<div class="penci-mega-latest-posts col-mn-5 mega-row-1">
								<div class="penci-mega-row penci-mega-10 row-active">
											<div class="penci-mega-post">
							<div class="penci-mega-thumbnail">
																<span class="mega-cat-name">
																			Arts &amp; Culture																	</span>
																<a href="https://massispost.com/2018/05/world-premiere-of-100-aprils-at-rogue-machine/" title="World Premiere of &#8220;100 Aprils&#8221; at Rogue Machine">
																		<img width="585" height="390" src="https://i0.wp.com/massispost.com/wp-content/uploads/2018/05/100-APRILS.jpg?resize=585%2C390&amp;ssl=1" class="attachment-penci-thumb size-penci-thumb wp-post-image" alt="" />								</a>
							</div>
							<div class="penci-mega-meta">
								<h3 class="post-mega-title">
									<a href="https://massispost.com/2018/05/world-premiere-of-100-aprils-at-rogue-machine/">World Premiere of &#8220;100 Aprils&#8221; at Rogue Machine</a>
								</h3>
																<p class="penci-mega-date">May 13, 2018</p>
															</div>
						</div>
											<div class="penci-mega-post">
							<div class="penci-mega-thumbnail">
																<span class="mega-cat-name">
																			Arts &amp; Culture																	</span>
																<a href="https://massispost.com/2018/05/the-mysterious-theater-robert-elibekians-reflections-on-theatrical-art/" title="The Mysterious Theater: Robert Elibekian’s Reflections on Theatrical Art">
																		<img width="585" height="390" src="https://i1.wp.com/massispost.com/wp-content/uploads/2018/05/Robert-Elibekian-dencer-35.5x24.5-cm-14x9.5-inches.jpg?resize=585%2C390&amp;ssl=1" class="attachment-penci-thumb size-penci-thumb wp-post-image" alt="" srcset="https://i1.wp.com/massispost.com/wp-content/uploads/2018/05/Robert-Elibekian-dencer-35.5x24.5-cm-14x9.5-inches.jpg?w=800&amp;ssl=1 800w, https://i1.wp.com/massispost.com/wp-content/uploads/2018/05/Robert-Elibekian-dencer-35.5x24.5-cm-14x9.5-inches.jpg?resize=300%2C200&amp;ssl=1 300w, https://i1.wp.com/massispost.com/wp-content/uploads/2018/05/Robert-Elibekian-dencer-35.5x24.5-cm-14x9.5-inches.jpg?resize=768%2C511&amp;ssl=1 768w, https://i1.wp.com/massispost.com/wp-content/uploads/2018/05/Robert-Elibekian-dencer-35.5x24.5-cm-14x9.5-inches.jpg?resize=585%2C389&amp;ssl=1 585w" sizes="(max-width: 585px) 100vw, 585px" />								</a>
							</div>
							<div class="penci-mega-meta">
								<h3 class="post-mega-title">
									<a href="https://massispost.com/2018/05/the-mysterious-theater-robert-elibekians-reflections-on-theatrical-art/">The Mysterious Theater: Robert Elibekian’s Reflections on Theatrical Art</a>
								</h3>
																<p class="penci-mega-date">May 10, 2018</p>
															</div>
						</div>
											<div class="penci-mega-post">
							<div class="penci-mega-thumbnail">
																<span class="mega-cat-name">
																			Arts &amp; Culture																	</span>
																<a href="https://massispost.com/2018/04/avedis-baghsarian-exhibit-pioneering-art-design-benefit-armenias-students/" title="Avedis Baghsarian to Exhibit His Pioneering Art and Design to Benefit Armenia’s Students">
																		<img width="585" height="390" src="https://i0.wp.com/massispost.com/wp-content/uploads/2018/04/baghdasarian-1.jpg?resize=585%2C390&amp;ssl=1" class="attachment-penci-thumb size-penci-thumb wp-post-image" alt="" />								</a>
							</div>
							<div class="penci-mega-meta">
								<h3 class="post-mega-title">
									<a href="https://massispost.com/2018/04/avedis-baghsarian-exhibit-pioneering-art-design-benefit-armenias-students/">Avedis Baghsarian to Exhibit His Pioneering Art and Design to Benefit Armenia’s Students</a>
								</h3>
																<p class="penci-mega-date">April 14, 2018</p>
															</div>
						</div>
											<div class="penci-mega-post">
							<div class="penci-mega-thumbnail">
																<span class="mega-cat-name">
																			Arts &amp; Culture																	</span>
																<a href="https://massispost.com/2018/04/side-home-fresno-state/" title="“The Other Side of Home” at Fresno State">
																		<img width="585" height="390" src="https://i1.wp.com/massispost.com/wp-content/uploads/2018/04/The-Other-Side-of-Home.jpg?resize=585%2C390&amp;ssl=1" class="attachment-penci-thumb size-penci-thumb wp-post-image" alt="" srcset="https://i1.wp.com/massispost.com/wp-content/uploads/2018/04/The-Other-Side-of-Home.jpg?resize=585%2C390&amp;ssl=1 585w, https://i1.wp.com/massispost.com/wp-content/uploads/2018/04/The-Other-Side-of-Home.jpg?zoom=2&amp;resize=585%2C390&amp;ssl=1 1170w" sizes="(max-width: 585px) 100vw, 585px" />								</a>
							</div>
							<div class="penci-mega-meta">
								<h3 class="post-mega-title">
									<a href="https://massispost.com/2018/04/side-home-fresno-state/">“The Other Side of Home” at Fresno State</a>
								</h3>
																<p class="penci-mega-date">April 13, 2018</p>
															</div>
						</div>
											<div class="penci-mega-post">
							<div class="penci-mega-thumbnail">
																<span class="mega-cat-name">
																			Arts &amp; Culture																	</span>
																<a href="https://massispost.com/2018/04/aca-screens-intent-destroy-sold-crowd/" title="ACA Screens “Intent to Destroy” To Sold Out Crowd">
																		<img width="585" height="390" src="https://i1.wp.com/massispost.com/wp-content/uploads/2018/04/intent-to-destroy.jpg?resize=585%2C390&amp;ssl=1" class="attachment-penci-thumb size-penci-thumb wp-post-image" alt="" />								</a>
							</div>
							<div class="penci-mega-meta">
								<h3 class="post-mega-title">
									<a href="https://massispost.com/2018/04/aca-screens-intent-destroy-sold-crowd/">ACA Screens “Intent to Destroy” To Sold Out Crowd</a>
								</h3>
																<p class="penci-mega-date">April 9, 2018</p>
															</div>
						</div>
									</div>
							</div>
		</div>

		</div></li>
</ul>
</li>
<li id="menu-item-23232" class="menu-item menu-item-type-taxonomy menu-item-object-category penci-mega-menu menu-item-23232"><a href="https://massispost.com/category/sports/">Sports</a>
<ul class="sub-menu">
	<li class="menu-item-0"><div class="penci-megamenu">		
		<div class="penci-content-megamenu">
			<div class="penci-mega-latest-posts col-mn-5 mega-row-1">
								<div class="penci-mega-row penci-mega-186 row-active">
											<div class="penci-mega-post">
							<div class="penci-mega-thumbnail">
																<span class="mega-cat-name">
																			Sports																	</span>
																<a href="https://massispost.com/2018/03/arsen-goulamirian-wins-wba-light-heavyweight-world-champion-title/" title="Arsen Goulamirian Wins WBA Light Heavyweight World Champion Title">
																		<img width="585" height="390" src="https://i2.wp.com/massispost.com/wp-content/uploads/2018/03/arsen-goulamirian.jpg?resize=585%2C390&amp;ssl=1" class="attachment-penci-thumb size-penci-thumb wp-post-image" alt="" />								</a>
							</div>
							<div class="penci-mega-meta">
								<h3 class="post-mega-title">
									<a href="https://massispost.com/2018/03/arsen-goulamirian-wins-wba-light-heavyweight-world-champion-title/">Arsen Goulamirian Wins WBA Light Heavyweight World Champion Title</a>
								</h3>
																<p class="penci-mega-date">March 26, 2018</p>
															</div>
						</div>
											<div class="penci-mega-post">
							<div class="penci-mega-thumbnail">
																<span class="mega-cat-name">
																			Sports																	</span>
																<a href="https://massispost.com/2018/03/yura-movsisyan-joins-swedish-club-djurgarden/" title="Yura Movsisyan Joins Swedish Club Djurgården">
																		<img width="585" height="390" src="https://i2.wp.com/massispost.com/wp-content/uploads/2018/03/Movsisyan-Djurgården.jpg?resize=585%2C390&amp;ssl=1" class="attachment-penci-thumb size-penci-thumb wp-post-image" alt="" />								</a>
							</div>
							<div class="penci-mega-meta">
								<h3 class="post-mega-title">
									<a href="https://massispost.com/2018/03/yura-movsisyan-joins-swedish-club-djurgarden/">Yura Movsisyan Joins Swedish Club Djurgården</a>
								</h3>
																<p class="penci-mega-date">March 26, 2018</p>
															</div>
						</div>
											<div class="penci-mega-post">
							<div class="penci-mega-thumbnail">
																<span class="mega-cat-name">
																			Sports																	</span>
																<a href="https://massispost.com/2018/02/armenia-beats-albania-84-65-eurobasket-2021-pre-qualifiers/" title="Armenia Beats Albania 84-65 in EuroBasket 2021 Pre-Qualifiers">
																		<img width="585" height="390" src="https://i2.wp.com/massispost.com/wp-content/uploads/2018/02/armenia-2.jpg?resize=585%2C390&amp;ssl=1" class="attachment-penci-thumb size-penci-thumb wp-post-image" alt="" srcset="https://i2.wp.com/massispost.com/wp-content/uploads/2018/02/armenia-2.jpg?w=850&amp;ssl=1 850w, https://i2.wp.com/massispost.com/wp-content/uploads/2018/02/armenia-2.jpg?resize=300%2C200&amp;ssl=1 300w, https://i2.wp.com/massispost.com/wp-content/uploads/2018/02/armenia-2.jpg?resize=768%2C512&amp;ssl=1 768w, https://i2.wp.com/massispost.com/wp-content/uploads/2018/02/armenia-2.jpg?resize=585%2C390&amp;ssl=1 585w" sizes="(max-width: 585px) 100vw, 585px" />								</a>
							</div>
							<div class="penci-mega-meta">
								<h3 class="post-mega-title">
									<a href="https://massispost.com/2018/02/armenia-beats-albania-84-65-eurobasket-2021-pre-qualifiers/">Armenia Beats Albania 84-65 in EuroBasket 2021 Pre-Qualifiers</a>
								</h3>
																<p class="penci-mega-date">February 26, 2018</p>
															</div>
						</div>
											<div class="penci-mega-post">
							<div class="penci-mega-thumbnail">
																<span class="mega-cat-name">
																			Sports																	</span>
																<a href="https://massispost.com/2018/02/mkhitaryan-three-assists-first-start-arsenal/" title="Mkhitaryan Has Three Assists in First Start for Arsenal">
																		<img width="585" height="390" src="https://i0.wp.com/massispost.com/wp-content/uploads/2018/02/mkhitaryan.jpg?resize=585%2C390&amp;ssl=1" class="attachment-penci-thumb size-penci-thumb wp-post-image" alt="" srcset="https://i0.wp.com/massispost.com/wp-content/uploads/2018/02/mkhitaryan.jpg?w=800&amp;ssl=1 800w, https://i0.wp.com/massispost.com/wp-content/uploads/2018/02/mkhitaryan.jpg?resize=300%2C200&amp;ssl=1 300w, https://i0.wp.com/massispost.com/wp-content/uploads/2018/02/mkhitaryan.jpg?resize=768%2C512&amp;ssl=1 768w, https://i0.wp.com/massispost.com/wp-content/uploads/2018/02/mkhitaryan.jpg?resize=585%2C390&amp;ssl=1 585w" sizes="(max-width: 585px) 100vw, 585px" />								</a>
							</div>
							<div class="penci-mega-meta">
								<h3 class="post-mega-title">
									<a href="https://massispost.com/2018/02/mkhitaryan-three-assists-first-start-arsenal/">Mkhitaryan Has Three Assists in First Start for Arsenal</a>
								</h3>
																<p class="penci-mega-date">February 3, 2018</p>
															</div>
						</div>
											<div class="penci-mega-post">
							<div class="penci-mega-thumbnail">
																<span class="mega-cat-name">
																			Sports																	</span>
																<a href="https://massispost.com/2018/01/uefa-nations-league-armenia-play-macedonia-lichtenstein-gibraltar/" title="UEFA Nations League: Armenia to Play Macedonia, Lichtenstein and Gibraltar">
																		<img width="585" height="390" src="https://i1.wp.com/massispost.com/wp-content/uploads/2018/01/uefa-d.jpg?resize=585%2C390&amp;ssl=1" class="attachment-penci-thumb size-penci-thumb wp-post-image" alt="" />								</a>
							</div>
							<div class="penci-mega-meta">
								<h3 class="post-mega-title">
									<a href="https://massispost.com/2018/01/uefa-nations-league-armenia-play-macedonia-lichtenstein-gibraltar/">UEFA Nations League: Armenia to Play Macedonia, Lichtenstein and Gibraltar</a>
								</h3>
																<p class="penci-mega-date">January 24, 2018</p>
															</div>
						</div>
									</div>
							</div>
		</div>

		</div></li>
</ul>
</li>
<li id="menu-item-23225" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-23225"><a href="https://massispost.com/am"><span class="visuallyhidden">Հայերէն</span><img src="https://cdn5.massispost.com/wp-content/uploads/2016/07/Flag_of_Armenia.svg-1.png" class="_mi _svg" aria-hidden="true" style="width:3em;" /></a></li>
</ul></nav>

<!-- .wrapper-boxed -->
<div class="wrapper-boxed header-style-header-3 enable-boxed">

<!-- Top Bar -->
	<div class="penci-top-bar">
	<div class="container">
		<div class="penci-headline">
										<span class="headline-title">Top Posts</span>
										<div class="penci-topbar-social">
					<div class="inner-header-social">
			<a href="https://www.facebook.com/MassisPost/?fref=ts" target="_blank"><i class="fa fa-facebook"></i></a>
				<a href="https://twitter.com/massispost" target="_blank"><i class="fa fa-twitter"></i></a>
				<a href="https://plus.google.com/103247076034057621040/" target="_blank"><i class="fa fa-google-plus"></i></a>
										<a href="https://www.youtube.com/user/MassisPost" target="_blank"><i class="fa fa-youtube-play"></i></a>
				<a href="info@massispost.com"><i class="fa fa-envelope-o"></i></a>
								<a href="http://massispost.com/feed" target="_blank"><i class="fa fa-rss"></i></a>
	</div>				</div>
											<div class="penci-headline-posts" data-auto="true" data-autotime="3000" data-speed="300" data-direction="vertical">
													<div>
								<a class="penci-topbar-post-title" href="https://massispost.com/2018/05/pm-pashinian-satisfied-with-productive-talks-with-president-putin/">PM Pashinian Satisfied With ‘Productive’ Talks With President...</a>
							</div>
													<div>
								<a class="penci-topbar-post-title" href="https://massispost.com/2018/05/new-armenian-government-formed/">New Armenian Government Formed</a>
							</div>
													<div>
								<a class="penci-topbar-post-title" href="https://massispost.com/2018/05/pashinian-invites-renowned-economist-daron-acemoglu-to-restore-armenias-economy/">Pashinian Invites Renowned Economist Daron Acemoglu to Restore...</a>
							</div>
													<div>
								<a class="penci-topbar-post-title" href="https://massispost.com/2018/05/azerbaijan-threatens-armenia-with-large-scale-military-operations/">Azerbaijan Threatens Armenia with &#8216;Large-Scale Military Operations&#8217;</a>
							</div>
													<div>
								<a class="penci-topbar-post-title" href="https://massispost.com/2018/05/turkey-willing-to-normalize-relations-with-armenia-but-with-preconditions/">Turkey Willing to Normalize Relations with Armenia but...</a>
							</div>
													<div>
								<a class="penci-topbar-post-title" href="https://massispost.com/2018/05/armenias-police-chief-and-head-of-national-security-service-sacked-by-pm-pashinian/">Armenia&#8217;s Police Chief and Head of National Security...</a>
							</div>
													<div>
								<a class="penci-topbar-post-title" href="https://massispost.com/2018/05/sdhp-central-committee-congratulates-prime-minister-nikol-pashinyan/">SDHP Central Committee Congratulates Prime Minister Nikol Pashinyan</a>
							</div>
													<div>
								<a class="penci-topbar-post-title" href="https://massispost.com/2018/05/prime-minister-nikol-pashinian-visits-artsakh-photos/">Prime Minister Nikol Pashinian Visits Artsakh (Photos)</a>
							</div>
													<div>
								<a class="penci-topbar-post-title" href="https://massispost.com/2018/05/former-california-governor-george-deukmejian-dead-at-89/">Former California Governor George Deukmejian Dead at 89</a>
							</div>
													<div>
								<a class="penci-topbar-post-title" href="https://massispost.com/2018/05/armenian-pm-russian-president-agree-to-strengthen-bilateral-ties/">Armenian PM, Russian President Agree to Strengthen Bilateral...</a>
							</div>
											</div>
									</div>
	</div>
</div>

<header id="header" class="header-header-3 has-bottom-line"><!-- #header -->
		<div class="inner-header">
		<div class="container align-left-logo">

			<div id="logo">
															<h2>
							<a href="https://massispost.com/"><img src="https://cdn5.massispost.com/wp-content/uploads/2017/06/massismainnewB.jpg" alt="Armenian News By MassisPost" /></a>
						</h2>
												</div>

			
			
					</div>
	</div>
	
			<!-- Navigation -->
		<nav id="navigation" class="header-layout-bottom header-3">
			<div class="container">
				<div class="button-menu-mobile header-3"><i class="fa fa-bars"></i></div>
								<ul id="menu-massispost-1" class="menu"><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-23224"><a href="https://massispost.com">Home</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent penci-mega-menu menu-item-3216"><a href="https://massispost.com/category/news/">News</a>
<ul class="sub-menu">
	<li class="menu-item-0"><div class="penci-megamenu">		
		<div class="penci-content-megamenu">
			<div class="penci-mega-latest-posts col-mn-5 mega-row-1">
								<div class="penci-mega-row penci-mega-3 row-active">
											<div class="penci-mega-post">
							<div class="penci-mega-thumbnail">
																<span class="mega-cat-name">
																			News																	</span>
																<a href="https://massispost.com/2018/05/pm-pashinian-satisfied-with-productive-talks-with-president-putin/" title="PM Pashinian Satisfied With ‘Productive’ Talks With President Putin">
																		<img width="585" height="390" src="https://i1.wp.com/massispost.com/wp-content/uploads/2018/05/pashinyan-putin-2.jpg?resize=585%2C390&amp;ssl=1" class="attachment-penci-thumb size-penci-thumb wp-post-image" alt="" srcset="https://i1.wp.com/massispost.com/wp-content/uploads/2018/05/pashinyan-putin-2.jpg?w=850&amp;ssl=1 850w, https://i1.wp.com/massispost.com/wp-content/uploads/2018/05/pashinyan-putin-2.jpg?resize=300%2C200&amp;ssl=1 300w, https://i1.wp.com/massispost.com/wp-content/uploads/2018/05/pashinyan-putin-2.jpg?resize=768%2C511&amp;ssl=1 768w, https://i1.wp.com/massispost.com/wp-content/uploads/2018/05/pashinyan-putin-2.jpg?resize=585%2C390&amp;ssl=1 585w" sizes="(max-width: 585px) 100vw, 585px" />								</a>
							</div>
							<div class="penci-mega-meta">
								<h3 class="post-mega-title">
									<a href="https://massispost.com/2018/05/pm-pashinian-satisfied-with-productive-talks-with-president-putin/">PM Pashinian Satisfied With ‘Productive’ Talks With President Putin</a>
								</h3>
																<p class="penci-mega-date">May 15, 2018</p>
															</div>
						</div>
											<div class="penci-mega-post">
							<div class="penci-mega-thumbnail">
																<span class="mega-cat-name">
																			News																	</span>
																<a href="https://massispost.com/2018/05/new-armenian-government-formed/" title="New Armenian Government Formed">
																		<img width="585" height="390" src="https://i0.wp.com/massispost.com/wp-content/uploads/2018/05/new-cabinet.jpg?resize=585%2C390&amp;ssl=1" class="attachment-penci-thumb size-penci-thumb wp-post-image" alt="" />								</a>
							</div>
							<div class="penci-mega-meta">
								<h3 class="post-mega-title">
									<a href="https://massispost.com/2018/05/new-armenian-government-formed/">New Armenian Government Formed</a>
								</h3>
																<p class="penci-mega-date">May 13, 2018</p>
															</div>
						</div>
											<div class="penci-mega-post">
							<div class="penci-mega-thumbnail">
																<span class="mega-cat-name">
																			News																	</span>
																<a href="https://massispost.com/2018/05/pashinian-invites-renowned-economist-daron-acemoglu-to-restore-armenias-economy/" title="Pashinian Invites Renowned  Economist Daron Acemoglu to Restore Armenia’s Economy">
																		<img width="585" height="390" src="https://i1.wp.com/massispost.com/wp-content/uploads/2018/05/daron-acemoglu.jpg?resize=585%2C390&amp;ssl=1" class="attachment-penci-thumb size-penci-thumb wp-post-image" alt="" srcset="https://i1.wp.com/massispost.com/wp-content/uploads/2018/05/daron-acemoglu.jpg?resize=585%2C390&amp;ssl=1 585w, https://i1.wp.com/massispost.com/wp-content/uploads/2018/05/daron-acemoglu.jpg?resize=840%2C559&amp;ssl=1 840w" sizes="(max-width: 585px) 100vw, 585px" />								</a>
							</div>
							<div class="penci-mega-meta">
								<h3 class="post-mega-title">
									<a href="https://massispost.com/2018/05/pashinian-invites-renowned-economist-daron-acemoglu-to-restore-armenias-economy/">Pashinian Invites Renowned  Economist Daron Acemoglu to Restore Armenia’s Economy</a>
								</h3>
																<p class="penci-mega-date">May 13, 2018</p>
															</div>
						</div>
											<div class="penci-mega-post">
							<div class="penci-mega-thumbnail">
																<span class="mega-cat-name">
																			News																	</span>
																<a href="https://massispost.com/2018/05/release-of-political-prisoners-in-armenia-has-started-and-should-continue/" title="Release of Political Prisoners in Armenia Has Started and Should Continue">
																		<img width="585" height="390" src="https://i0.wp.com/massispost.com/wp-content/uploads/2018/05/Political-Prisoners.jpeg?resize=585%2C390&amp;ssl=1" class="attachment-penci-thumb size-penci-thumb wp-post-image" alt="" />								</a>
							</div>
							<div class="penci-mega-meta">
								<h3 class="post-mega-title">
									<a href="https://massispost.com/2018/05/release-of-political-prisoners-in-armenia-has-started-and-should-continue/">Release of Political Prisoners in Armenia Has Started and Should Continue</a>
								</h3>
																<p class="penci-mega-date">May 13, 2018</p>
															</div>
						</div>
											<div class="penci-mega-post">
							<div class="penci-mega-thumbnail">
																<span class="mega-cat-name">
																			News																	</span>
																<a href="https://massispost.com/2018/05/azerbaijan-threatens-armenia-with-large-scale-military-operations/" title="Azerbaijan Threatens Armenia with &#8216;Large-Scale Military Operations&#8217;">
																		<img width="585" height="390" src="https://i2.wp.com/massispost.com/wp-content/uploads/2018/05/Zakir-Hasanov.jpg?resize=585%2C390&amp;ssl=1" class="attachment-penci-thumb size-penci-thumb wp-post-image" alt="" />								</a>
							</div>
							<div class="penci-mega-meta">
								<h3 class="post-mega-title">
									<a href="https://massispost.com/2018/05/azerbaijan-threatens-armenia-with-large-scale-military-operations/">Azerbaijan Threatens Armenia with &#8216;Large-Scale Military Operations&#8217;</a>
								</h3>
																<p class="penci-mega-date">May 13, 2018</p>
															</div>
						</div>
									</div>
							</div>
		</div>

		</div></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent penci-mega-menu menu-item-3217"><a href="https://massispost.com/category/armenia/">Armenia</a>
<ul class="sub-menu">
	<li class="menu-item-0"><div class="penci-megamenu">				<div class="penci-mega-child-categories">
							<a class="mega-cat-child cat-active" href="https://massispost.com/category/armenia/" data-id="penci-mega-5">All</a>
							<a class="mega-cat-child" href="https://massispost.com/category/armenia/artsakh/" data-id="penci-mega-8">Artsakh</a>
					</div>
		
		<div class="penci-content-megamenu">
			<div class="penci-mega-latest-posts col-mn-4 mega-row-1">
								<div class="penci-mega-row penci-mega-5 row-active">
											<div class="penci-mega-post">
							<div class="penci-mega-thumbnail">
																<span class="mega-cat-name">
																			Armenia																	</span>
																<a href="https://massispost.com/2018/05/pm-pashinian-satisfied-with-productive-talks-with-president-putin/" title="PM Pashinian Satisfied With ‘Productive’ Talks With President Putin">
																		<img width="585" height="390" src="https://i1.wp.com/massispost.com/wp-content/uploads/2018/05/pashinyan-putin-2.jpg?resize=585%2C390&amp;ssl=1" class="attachment-penci-thumb size-penci-thumb wp-post-image" alt="" srcset="https://i1.wp.com/massispost.com/wp-content/uploads/2018/05/pashinyan-putin-2.jpg?w=850&amp;ssl=1 850w, https://i1.wp.com/massispost.com/wp-content/uploads/2018/05/pashinyan-putin-2.jpg?resize=300%2C200&amp;ssl=1 300w, https://i1.wp.com/massispost.com/wp-content/uploads/2018/05/pashinyan-putin-2.jpg?resize=768%2C511&amp;ssl=1 768w, https://i1.wp.com/massispost.com/wp-content/uploads/2018/05/pashinyan-putin-2.jpg?resize=585%2C390&amp;ssl=1 585w" sizes="(max-width: 585px) 100vw, 585px" />								</a>
							</div>
							<div class="penci-mega-meta">
								<h3 class="post-mega-title">
									<a href="https://massispost.com/2018/05/pm-pashinian-satisfied-with-productive-talks-with-president-putin/">PM Pashinian Satisfied With ‘Productive’ Talks With President Putin</a>
								</h3>
																<p class="penci-mega-date">May 15, 2018</p>
															</div>
						</div>
											<div class="penci-mega-post">
							<div class="penci-mega-thumbnail">
																<span class="mega-cat-name">
																			Armenia																	</span>
																<a href="https://massispost.com/2018/05/new-armenian-government-formed/" title="New Armenian Government Formed">
																		<img width="585" height="390" src="https://i0.wp.com/massispost.com/wp-content/uploads/2018/05/new-cabinet.jpg?resize=585%2C390&amp;ssl=1" class="attachment-penci-thumb size-penci-thumb wp-post-image" alt="" />								</a>
							</div>
							<div class="penci-mega-meta">
								<h3 class="post-mega-title">
									<a href="https://massispost.com/2018/05/new-armenian-government-formed/">New Armenian Government Formed</a>
								</h3>
																<p class="penci-mega-date">May 13, 2018</p>
															</div>
						</div>
											<div class="penci-mega-post">
							<div class="penci-mega-thumbnail">
																<span class="mega-cat-name">
																			Armenia																	</span>
																<a href="https://massispost.com/2018/05/pashinian-invites-renowned-economist-daron-acemoglu-to-restore-armenias-economy/" title="Pashinian Invites Renowned  Economist Daron Acemoglu to Restore Armenia’s Economy">
																		<img width="585" height="390" src="https://i1.wp.com/massispost.com/wp-content/uploads/2018/05/daron-acemoglu.jpg?resize=585%2C390&amp;ssl=1" class="attachment-penci-thumb size-penci-thumb wp-post-image" alt="" srcset="https://i1.wp.com/massispost.com/wp-content/uploads/2018/05/daron-acemoglu.jpg?resize=585%2C390&amp;ssl=1 585w, https://i1.wp.com/massispost.com/wp-content/uploads/2018/05/daron-acemoglu.jpg?resize=840%2C559&amp;ssl=1 840w" sizes="(max-width: 585px) 100vw, 585px" />								</a>
							</div>
							<div class="penci-mega-meta">
								<h3 class="post-mega-title">
									<a href="https://massispost.com/2018/05/pashinian-invites-renowned-economist-daron-acemoglu-to-restore-armenias-economy/">Pashinian Invites Renowned  Economist Daron Acemoglu to Restore Armenia’s Economy</a>
								</h3>
																<p class="penci-mega-date">May 13, 2018</p>
															</div>
						</div>
											<div class="penci-mega-post">
							<div class="penci-mega-thumbnail">
																<span class="mega-cat-name">
																			Armenia																	</span>
																<a href="https://massispost.com/2018/05/release-of-political-prisoners-in-armenia-has-started-and-should-continue/" title="Release of Political Prisoners in Armenia Has Started and Should Continue">
																		<img width="585" height="390" src="https://i0.wp.com/massispost.com/wp-content/uploads/2018/05/Political-Prisoners.jpeg?resize=585%2C390&amp;ssl=1" class="attachment-penci-thumb size-penci-thumb wp-post-image" alt="" />								</a>
							</div>
							<div class="penci-mega-meta">
								<h3 class="post-mega-title">
									<a href="https://massispost.com/2018/05/release-of-political-prisoners-in-armenia-has-started-and-should-continue/">Release of Political Prisoners in Armenia Has Started and Should Continue</a>
								</h3>
																<p class="penci-mega-date">May 13, 2018</p>
															</div>
						</div>
									</div>
								<div class="penci-mega-row penci-mega-8">
											<div class="penci-mega-post">
							<div class="penci-mega-thumbnail">
																<span class="mega-cat-name">
																			Artsakh																	</span>
																<a href="https://massispost.com/2018/05/azerbaijan-threatens-armenia-with-large-scale-military-operations/" title="Azerbaijan Threatens Armenia with &#8216;Large-Scale Military Operations&#8217;">
																		<img width="585" height="390" src="https://i2.wp.com/massispost.com/wp-content/uploads/2018/05/Zakir-Hasanov.jpg?resize=585%2C390&amp;ssl=1" class="attachment-penci-thumb size-penci-thumb wp-post-image" alt="" />								</a>
							</div>
							<div class="penci-mega-meta">
								<h3 class="post-mega-title">
									<a href="https://massispost.com/2018/05/azerbaijan-threatens-armenia-with-large-scale-military-operations/">Azerbaijan Threatens Armenia with &#8216;Large-Scale Military Operations&#8217;</a>
								</h3>
																<p class="penci-mega-date">May 13, 2018</p>
															</div>
						</div>
											<div class="penci-mega-post">
							<div class="penci-mega-thumbnail">
																<span class="mega-cat-name">
																			Artsakh																	</span>
																<a href="https://massispost.com/2018/05/prime-minister-nikol-pashinian-visits-artsakh-photos/" title="Prime Minister Nikol Pashinian Visits Artsakh (Photos)">
																		<img width="585" height="390" src="https://i0.wp.com/massispost.com/wp-content/uploads/2018/05/Artsakh-5.jpg?resize=585%2C390&amp;ssl=1" class="attachment-penci-thumb size-penci-thumb wp-post-image" alt="" srcset="https://i0.wp.com/massispost.com/wp-content/uploads/2018/05/Artsakh-5.jpg?w=1670&amp;ssl=1 1670w, https://i0.wp.com/massispost.com/wp-content/uploads/2018/05/Artsakh-5.jpg?resize=300%2C200&amp;ssl=1 300w, https://i0.wp.com/massispost.com/wp-content/uploads/2018/05/Artsakh-5.jpg?resize=768%2C512&amp;ssl=1 768w, https://i0.wp.com/massispost.com/wp-content/uploads/2018/05/Artsakh-5.jpg?resize=1024%2C682&amp;ssl=1 1024w, https://i0.wp.com/massispost.com/wp-content/uploads/2018/05/Artsakh-5.jpg?resize=1170%2C780&amp;ssl=1 1170w, https://i0.wp.com/massispost.com/wp-content/uploads/2018/05/Artsakh-5.jpg?resize=585%2C390&amp;ssl=1 585w" sizes="(max-width: 585px) 100vw, 585px" />								</a>
							</div>
							<div class="penci-mega-meta">
								<h3 class="post-mega-title">
									<a href="https://massispost.com/2018/05/prime-minister-nikol-pashinian-visits-artsakh-photos/">Prime Minister Nikol Pashinian Visits Artsakh (Photos)</a>
								</h3>
																<p class="penci-mega-date">May 9, 2018</p>
															</div>
						</div>
											<div class="penci-mega-post">
							<div class="penci-mega-thumbnail">
																<span class="mega-cat-name">
																			Artsakh																	</span>
																<a href="https://massispost.com/2018/03/members-congress-pay-tribute-halo-trust-employees-killed-landmine-accident-artsakh/" title="Members of Congress Pay Tribute to HALO Trust Employees Killed in Landmine Accident in Artsakh">
																		<img width="585" height="390" src="https://i2.wp.com/massispost.com/wp-content/uploads/2018/03/HALO-Landmines.jpg?resize=585%2C390&amp;ssl=1" class="attachment-penci-thumb size-penci-thumb wp-post-image" alt="" srcset="https://i2.wp.com/massispost.com/wp-content/uploads/2018/03/HALO-Landmines.jpg?resize=300%2C201&amp;ssl=1 300w, https://i2.wp.com/massispost.com/wp-content/uploads/2018/03/HALO-Landmines.jpg?resize=585%2C390&amp;ssl=1 585w" sizes="(max-width: 585px) 100vw, 585px" />								</a>
							</div>
							<div class="penci-mega-meta">
								<h3 class="post-mega-title">
									<a href="https://massispost.com/2018/03/members-congress-pay-tribute-halo-trust-employees-killed-landmine-accident-artsakh/">Members of Congress Pay Tribute to HALO Trust Employees Killed in Landmine Accident in Artsakh</a>
								</h3>
																<p class="penci-mega-date">March 30, 2018</p>
															</div>
						</div>
											<div class="penci-mega-post">
							<div class="penci-mega-thumbnail">
																<span class="mega-cat-name">
																			Artsakh																	</span>
																<a href="https://massispost.com/2018/03/three-armenians-killed-karabakh-landmine-blast/" title="Three Armenians Killed in Karabakh Landmine Blast">
																		<img width="585" height="390" src="https://i0.wp.com/massispost.com/wp-content/uploads/2018/03/halo-karabakh.jpg?resize=585%2C390&amp;ssl=1" class="attachment-penci-thumb size-penci-thumb wp-post-image" alt="" />								</a>
							</div>
							<div class="penci-mega-meta">
								<h3 class="post-mega-title">
									<a href="https://massispost.com/2018/03/three-armenians-killed-karabakh-landmine-blast/">Three Armenians Killed in Karabakh Landmine Blast</a>
								</h3>
																<p class="penci-mega-date">March 29, 2018</p>
															</div>
						</div>
									</div>
							</div>
		</div>

		</div></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category penci-mega-menu menu-item-3220"><a href="https://massispost.com/category/community/">Community</a>
<ul class="sub-menu">
	<li class="menu-item-0"><div class="penci-megamenu">		
		<div class="penci-content-megamenu">
			<div class="penci-mega-latest-posts col-mn-5 mega-row-1">
								<div class="penci-mega-row penci-mega-6 row-active">
											<div class="penci-mega-post">
							<div class="penci-mega-thumbnail">
																<span class="mega-cat-name">
																			Community																	</span>
																<a href="https://massispost.com/2018/05/groundbreaking-ceremony-of-new-armenian-church-campus-in-san-diego/" title="Groundbreaking Ceremony of New Armenian Church Campus in San Diego">
																		<img width="585" height="390" src="https://i0.wp.com/massispost.com/wp-content/uploads/2018/05/sandiego-1.jpeg?resize=585%2C390&amp;ssl=1" class="attachment-penci-thumb size-penci-thumb wp-post-image" alt="" srcset="https://i0.wp.com/massispost.com/wp-content/uploads/2018/05/sandiego-1.jpeg?w=850&amp;ssl=1 850w, https://i0.wp.com/massispost.com/wp-content/uploads/2018/05/sandiego-1.jpeg?resize=300%2C200&amp;ssl=1 300w, https://i0.wp.com/massispost.com/wp-content/uploads/2018/05/sandiego-1.jpeg?resize=768%2C513&amp;ssl=1 768w, https://i0.wp.com/massispost.com/wp-content/uploads/2018/05/sandiego-1.jpeg?resize=585%2C391&amp;ssl=1 585w" sizes="(max-width: 585px) 100vw, 585px" />								</a>
							</div>
							<div class="penci-mega-meta">
								<h3 class="post-mega-title">
									<a href="https://massispost.com/2018/05/groundbreaking-ceremony-of-new-armenian-church-campus-in-san-diego/">Groundbreaking Ceremony of New Armenian Church Campus in San Diego</a>
								</h3>
																<p class="penci-mega-date">May 13, 2018</p>
															</div>
						</div>
											<div class="penci-mega-post">
							<div class="penci-mega-thumbnail">
																<span class="mega-cat-name">
																			Community																	</span>
																<a href="https://massispost.com/2018/05/world-premiere-of-100-aprils-at-rogue-machine/" title="World Premiere of &#8220;100 Aprils&#8221; at Rogue Machine">
																		<img width="585" height="390" src="https://i0.wp.com/massispost.com/wp-content/uploads/2018/05/100-APRILS.jpg?resize=585%2C390&amp;ssl=1" class="attachment-penci-thumb size-penci-thumb wp-post-image" alt="" />								</a>
							</div>
							<div class="penci-mega-meta">
								<h3 class="post-mega-title">
									<a href="https://massispost.com/2018/05/world-premiere-of-100-aprils-at-rogue-machine/">World Premiere of &#8220;100 Aprils&#8221; at Rogue Machine</a>
								</h3>
																<p class="penci-mega-date">May 13, 2018</p>
															</div>
						</div>
											<div class="penci-mega-post">
							<div class="penci-mega-thumbnail">
																<span class="mega-cat-name">
																			Community																	</span>
																<a href="https://massispost.com/2018/05/ararat-eskijian-museum-presents-an-illustrated-talk-by-dr-gabis-harboyan/" title="Ararat-Eskijian Museum Presents an Illustrated  Talk by Dr. Gabis Harboyan">
																		<img width="585" height="390" src="https://i1.wp.com/massispost.com/wp-content/uploads/2018/05/May-17th-talk-by-Garbis-Harboyan.jpg?resize=585%2C390&amp;ssl=1" class="attachment-penci-thumb size-penci-thumb wp-post-image" alt="" />								</a>
							</div>
							<div class="penci-mega-meta">
								<h3 class="post-mega-title">
									<a href="https://massispost.com/2018/05/ararat-eskijian-museum-presents-an-illustrated-talk-by-dr-gabis-harboyan/">Ararat-Eskijian Museum Presents an Illustrated  Talk by Dr. Gabis Harboyan</a>
								</h3>
																<p class="penci-mega-date">May 10, 2018</p>
															</div>
						</div>
											<div class="penci-mega-post">
							<div class="penci-mega-thumbnail">
																<span class="mega-cat-name">
																			Community																	</span>
																<a href="https://massispost.com/2018/05/armenian-studies-program-30th-annual-banquet/" title="Armenian Studies Program 30th Annual Banquet">
																		<img width="585" height="390" src="https://i2.wp.com/massispost.com/wp-content/uploads/2018/05/1-ASP-Banquet.jpg?resize=585%2C390&amp;ssl=1" class="attachment-penci-thumb size-penci-thumb wp-post-image" alt="" />								</a>
							</div>
							<div class="penci-mega-meta">
								<h3 class="post-mega-title">
									<a href="https://massispost.com/2018/05/armenian-studies-program-30th-annual-banquet/">Armenian Studies Program 30th Annual Banquet</a>
								</h3>
																<p class="penci-mega-date">May 10, 2018</p>
															</div>
						</div>
											<div class="penci-mega-post">
							<div class="penci-mega-thumbnail">
																<span class="mega-cat-name">
																			Community																	</span>
																<a href="https://massispost.com/2018/05/the-mysterious-theater-robert-elibekians-reflections-on-theatrical-art/" title="The Mysterious Theater: Robert Elibekian’s Reflections on Theatrical Art">
																		<img width="585" height="390" src="https://i1.wp.com/massispost.com/wp-content/uploads/2018/05/Robert-Elibekian-dencer-35.5x24.5-cm-14x9.5-inches.jpg?resize=585%2C390&amp;ssl=1" class="attachment-penci-thumb size-penci-thumb wp-post-image" alt="" srcset="https://i1.wp.com/massispost.com/wp-content/uploads/2018/05/Robert-Elibekian-dencer-35.5x24.5-cm-14x9.5-inches.jpg?w=800&amp;ssl=1 800w, https://i1.wp.com/massispost.com/wp-content/uploads/2018/05/Robert-Elibekian-dencer-35.5x24.5-cm-14x9.5-inches.jpg?resize=300%2C200&amp;ssl=1 300w, https://i1.wp.com/massispost.com/wp-content/uploads/2018/05/Robert-Elibekian-dencer-35.5x24.5-cm-14x9.5-inches.jpg?resize=768%2C511&amp;ssl=1 768w, https://i1.wp.com/massispost.com/wp-content/uploads/2018/05/Robert-Elibekian-dencer-35.5x24.5-cm-14x9.5-inches.jpg?resize=585%2C389&amp;ssl=1 585w" sizes="(max-width: 585px) 100vw, 585px" />								</a>
							</div>
							<div class="penci-mega-meta">
								<h3 class="post-mega-title">
									<a href="https://massispost.com/2018/05/the-mysterious-theater-robert-elibekians-reflections-on-theatrical-art/">The Mysterious Theater: Robert Elibekian’s Reflections on Theatrical Art</a>
								</h3>
																<p class="penci-mega-date">May 10, 2018</p>
															</div>
						</div>
									</div>
							</div>
		</div>

		</div></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent penci-mega-menu menu-item-3218"><a href="https://massispost.com/category/world/">World</a>
<ul class="sub-menu">
	<li class="menu-item-0"><div class="penci-megamenu">		
		<div class="penci-content-megamenu">
			<div class="penci-mega-latest-posts col-mn-5 mega-row-1">
								<div class="penci-mega-row penci-mega-4 row-active">
											<div class="penci-mega-post">
							<div class="penci-mega-thumbnail">
																<span class="mega-cat-name">
																			World																	</span>
																<a href="https://massispost.com/2018/05/pm-pashinian-satisfied-with-productive-talks-with-president-putin/" title="PM Pashinian Satisfied With ‘Productive’ Talks With President Putin">
																		<img width="585" height="390" src="https://i1.wp.com/massispost.com/wp-content/uploads/2018/05/pashinyan-putin-2.jpg?resize=585%2C390&amp;ssl=1" class="attachment-penci-thumb size-penci-thumb wp-post-image" alt="" srcset="https://i1.wp.com/massispost.com/wp-content/uploads/2018/05/pashinyan-putin-2.jpg?w=850&amp;ssl=1 850w, https://i1.wp.com/massispost.com/wp-content/uploads/2018/05/pashinyan-putin-2.jpg?resize=300%2C200&amp;ssl=1 300w, https://i1.wp.com/massispost.com/wp-content/uploads/2018/05/pashinyan-putin-2.jpg?resize=768%2C511&amp;ssl=1 768w, https://i1.wp.com/massispost.com/wp-content/uploads/2018/05/pashinyan-putin-2.jpg?resize=585%2C390&amp;ssl=1 585w" sizes="(max-width: 585px) 100vw, 585px" />								</a>
							</div>
							<div class="penci-mega-meta">
								<h3 class="post-mega-title">
									<a href="https://massispost.com/2018/05/pm-pashinian-satisfied-with-productive-talks-with-president-putin/">PM Pashinian Satisfied With ‘Productive’ Talks With President Putin</a>
								</h3>
																<p class="penci-mega-date">May 15, 2018</p>
															</div>
						</div>
											<div class="penci-mega-post">
							<div class="penci-mega-thumbnail">
																<span class="mega-cat-name">
																			World																	</span>
																<a href="https://massispost.com/2018/05/turkey-willing-to-normalize-relations-with-armenia-but-with-preconditions/" title="Turkey Willing to Normalize Relations with Armenia but with Preconditions">
																		<img width="585" height="390" src="https://i0.wp.com/massispost.com/wp-content/uploads/2018/05/yildrim.jpg?resize=585%2C390&amp;ssl=1" class="attachment-penci-thumb size-penci-thumb wp-post-image" alt="" />								</a>
							</div>
							<div class="penci-mega-meta">
								<h3 class="post-mega-title">
									<a href="https://massispost.com/2018/05/turkey-willing-to-normalize-relations-with-armenia-but-with-preconditions/">Turkey Willing to Normalize Relations with Armenia but with Preconditions</a>
								</h3>
																<p class="penci-mega-date">May 13, 2018</p>
															</div>
						</div>
											<div class="penci-mega-post">
							<div class="penci-mega-thumbnail">
																<span class="mega-cat-name">
																			World																	</span>
																<a href="https://massispost.com/2018/05/armenian-pm-russian-president-agree-to-strengthen-bilateral-ties/" title="Armenian PM, Russian President Agree to Strengthen Bilateral Ties">
																		<img width="585" height="390" src="https://i2.wp.com/massispost.com/wp-content/uploads/2018/05/Putin-Pashinyan.png?resize=585%2C390&amp;ssl=1" class="attachment-penci-thumb size-penci-thumb wp-post-image" alt="" />								</a>
							</div>
							<div class="penci-mega-meta">
								<h3 class="post-mega-title">
									<a href="https://massispost.com/2018/05/armenian-pm-russian-president-agree-to-strengthen-bilateral-ties/">Armenian PM, Russian President Agree to Strengthen Bilateral Ties</a>
								</h3>
																<p class="penci-mega-date">May 8, 2018</p>
															</div>
						</div>
											<div class="penci-mega-post">
							<div class="penci-mega-thumbnail">
																<span class="mega-cat-name">
																			World																	</span>
																<a href="https://massispost.com/2018/04/statement-by-president-trump-on-armenian-remembrance-day-2018/" title="Statement by President Trump on Armenian Remembrance Day 2018">
																		<img width="585" height="390" src="https://i2.wp.com/massispost.com/wp-content/uploads/2018/04/The-white-house.jpg?resize=585%2C390&amp;ssl=1" class="attachment-penci-thumb size-penci-thumb wp-post-image" alt="" />								</a>
							</div>
							<div class="penci-mega-meta">
								<h3 class="post-mega-title">
									<a href="https://massispost.com/2018/04/statement-by-president-trump-on-armenian-remembrance-day-2018/">Statement by President Trump on Armenian Remembrance Day 2018</a>
								</h3>
																<p class="penci-mega-date">April 24, 2018</p>
															</div>
						</div>
											<div class="penci-mega-post">
							<div class="penci-mega-thumbnail">
																<span class="mega-cat-name">
																			World																	</span>
																<a href="https://massispost.com/2018/04/emmanuel-macron-france-stands-by-armenia-to-commemorate-genocide-anniversary/" title="Emmanuel Macron &#8211; France Stands by Armenia to Commemorate Genocide Anniversary">
																		<img width="585" height="390" src="https://i0.wp.com/massispost.com/wp-content/uploads/2018/04/Emmanuel-Macron.jpg?resize=585%2C390&amp;ssl=1" class="attachment-penci-thumb size-penci-thumb wp-post-image" alt="" srcset="https://i0.wp.com/massispost.com/wp-content/uploads/2018/04/Emmanuel-Macron.jpg?w=800&amp;ssl=1 800w, https://i0.wp.com/massispost.com/wp-content/uploads/2018/04/Emmanuel-Macron.jpg?resize=300%2C200&amp;ssl=1 300w, https://i0.wp.com/massispost.com/wp-content/uploads/2018/04/Emmanuel-Macron.jpg?resize=768%2C512&amp;ssl=1 768w, https://i0.wp.com/massispost.com/wp-content/uploads/2018/04/Emmanuel-Macron.jpg?resize=585%2C390&amp;ssl=1 585w" sizes="(max-width: 585px) 100vw, 585px" />								</a>
							</div>
							<div class="penci-mega-meta">
								<h3 class="post-mega-title">
									<a href="https://massispost.com/2018/04/emmanuel-macron-france-stands-by-armenia-to-commemorate-genocide-anniversary/">Emmanuel Macron &#8211; France Stands by Armenia to Commemorate Genocide Anniversary</a>
								</h3>
																<p class="penci-mega-date">April 24, 2018</p>
															</div>
						</div>
									</div>
							</div>
		</div>

		</div></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category penci-mega-menu menu-item-3228"><a href="https://massispost.com/category/armenian-genocide/">Armenian Genocide</a>
<ul class="sub-menu">
	<li class="menu-item-0"><div class="penci-megamenu">		
		<div class="penci-content-megamenu">
			<div class="penci-mega-latest-posts col-mn-5 mega-row-1">
								<div class="penci-mega-row penci-mega-12 row-active">
											<div class="penci-mega-post">
							<div class="penci-mega-thumbnail">
																<span class="mega-cat-name">
																			Armenian Genocide																	</span>
																<a href="https://massispost.com/2018/05/commemorative-evening-for-the-armenian-genocide-at-the-hebrew-university-of-jerusalem/" title="Commemorative Evening for the Armenian Genocide at   The Hebrew University of Jerusalem">
																		<img width="585" height="390" src="https://i0.wp.com/massispost.com/wp-content/uploads/2018/05/hebrew-university-1.jpeg?resize=585%2C390&amp;ssl=1" class="attachment-penci-thumb size-penci-thumb wp-post-image" alt="" />								</a>
							</div>
							<div class="penci-mega-meta">
								<h3 class="post-mega-title">
									<a href="https://massispost.com/2018/05/commemorative-evening-for-the-armenian-genocide-at-the-hebrew-university-of-jerusalem/">Commemorative Evening for the Armenian Genocide at   The Hebrew University of Jerusalem</a>
								</h3>
																<p class="penci-mega-date">May 3, 2018</p>
															</div>
						</div>
											<div class="penci-mega-post">
							<div class="penci-mega-thumbnail">
																<span class="mega-cat-name">
																			Armenian Genocide																	</span>
																<a href="https://massispost.com/2018/04/times-square-armenian-genocide-commemoration/" title="Times Square Armenian Genocide Commemoration">
																		<img width="585" height="390" src="https://i1.wp.com/massispost.com/wp-content/uploads/2018/04/ny-Crowd.jpg?resize=585%2C390&amp;ssl=1" class="attachment-penci-thumb size-penci-thumb wp-post-image" alt="" srcset="https://i1.wp.com/massispost.com/wp-content/uploads/2018/04/ny-Crowd.jpg?w=850&amp;ssl=1 850w, https://i1.wp.com/massispost.com/wp-content/uploads/2018/04/ny-Crowd.jpg?resize=300%2C200&amp;ssl=1 300w, https://i1.wp.com/massispost.com/wp-content/uploads/2018/04/ny-Crowd.jpg?resize=768%2C512&amp;ssl=1 768w, https://i1.wp.com/massispost.com/wp-content/uploads/2018/04/ny-Crowd.jpg?resize=585%2C390&amp;ssl=1 585w" sizes="(max-width: 585px) 100vw, 585px" />								</a>
							</div>
							<div class="penci-mega-meta">
								<h3 class="post-mega-title">
									<a href="https://massispost.com/2018/04/times-square-armenian-genocide-commemoration/">Times Square Armenian Genocide Commemoration</a>
								</h3>
																<p class="penci-mega-date">April 27, 2018</p>
															</div>
						</div>
											<div class="penci-mega-post">
							<div class="penci-mega-thumbnail">
																<span class="mega-cat-name">
																			Armenian Genocide																	</span>
																<a href="https://massispost.com/2018/04/statement-by-president-trump-on-armenian-remembrance-day-2018/" title="Statement by President Trump on Armenian Remembrance Day 2018">
																		<img width="585" height="390" src="https://i2.wp.com/massispost.com/wp-content/uploads/2018/04/The-white-house.jpg?resize=585%2C390&amp;ssl=1" class="attachment-penci-thumb size-penci-thumb wp-post-image" alt="" />								</a>
							</div>
							<div class="penci-mega-meta">
								<h3 class="post-mega-title">
									<a href="https://massispost.com/2018/04/statement-by-president-trump-on-armenian-remembrance-day-2018/">Statement by President Trump on Armenian Remembrance Day 2018</a>
								</h3>
																<p class="penci-mega-date">April 24, 2018</p>
															</div>
						</div>
											<div class="penci-mega-post">
							<div class="penci-mega-thumbnail">
																<span class="mega-cat-name">
																			Armenian Genocide																	</span>
																<a href="https://massispost.com/2018/04/emmanuel-macron-france-stands-by-armenia-to-commemorate-genocide-anniversary/" title="Emmanuel Macron &#8211; France Stands by Armenia to Commemorate Genocide Anniversary">
																		<img width="585" height="390" src="https://i0.wp.com/massispost.com/wp-content/uploads/2018/04/Emmanuel-Macron.jpg?resize=585%2C390&amp;ssl=1" class="attachment-penci-thumb size-penci-thumb wp-post-image" alt="" srcset="https://i0.wp.com/massispost.com/wp-content/uploads/2018/04/Emmanuel-Macron.jpg?w=800&amp;ssl=1 800w, https://i0.wp.com/massispost.com/wp-content/uploads/2018/04/Emmanuel-Macron.jpg?resize=300%2C200&amp;ssl=1 300w, https://i0.wp.com/massispost.com/wp-content/uploads/2018/04/Emmanuel-Macron.jpg?resize=768%2C512&amp;ssl=1 768w, https://i0.wp.com/massispost.com/wp-content/uploads/2018/04/Emmanuel-Macron.jpg?resize=585%2C390&amp;ssl=1 585w" sizes="(max-width: 585px) 100vw, 585px" />								</a>
							</div>
							<div class="penci-mega-meta">
								<h3 class="post-mega-title">
									<a href="https://massispost.com/2018/04/emmanuel-macron-france-stands-by-armenia-to-commemorate-genocide-anniversary/">Emmanuel Macron &#8211; France Stands by Armenia to Commemorate Genocide Anniversary</a>
								</h3>
																<p class="penci-mega-date">April 24, 2018</p>
															</div>
						</div>
											<div class="penci-mega-post">
							<div class="penci-mega-thumbnail">
																<span class="mega-cat-name">
																			Armenian Genocide																	</span>
																<a href="https://massispost.com/2018/04/erdogan-turkey-shares-the-historical-pain-of-our-armenian-citizens/" title="Erdogan &#8211; &#8220;Turkey Shares the Historical Pain of Our Armenian Citizens”">
																		<img width="585" height="390" src="https://i1.wp.com/massispost.com/wp-content/uploads/2017/03/erdogan.jpg?resize=585%2C390&amp;ssl=1" class="attachment-penci-thumb size-penci-thumb wp-post-image" alt="" />								</a>
							</div>
							<div class="penci-mega-meta">
								<h3 class="post-mega-title">
									<a href="https://massispost.com/2018/04/erdogan-turkey-shares-the-historical-pain-of-our-armenian-citizens/">Erdogan &#8211; &#8220;Turkey Shares the Historical Pain of Our Armenian Citizens”</a>
								</h3>
																<p class="penci-mega-date">April 24, 2018</p>
															</div>
						</div>
									</div>
							</div>
		</div>

		</div></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category penci-mega-menu menu-item-3223"><a href="https://massispost.com/category/commentary/">Commentary</a>
<ul class="sub-menu">
	<li class="menu-item-0"><div class="penci-megamenu">		
		<div class="penci-content-megamenu">
			<div class="penci-mega-latest-posts col-mn-5 mega-row-1">
								<div class="penci-mega-row penci-mega-9 row-active">
											<div class="penci-mega-post">
							<div class="penci-mega-thumbnail">
																<span class="mega-cat-name">
																			Commentary																	</span>
																<a href="https://massispost.com/2018/04/armenias-democratic-triumph-the-atlantic/" title="Armenia&#8217;s Democratic Triumph &#8211; The Atlantic">
																		<img width="585" height="390" src="https://i0.wp.com/massispost.com/wp-content/uploads/2018/04/pashinyan-24-1.jpg?resize=585%2C390&amp;ssl=1" class="attachment-penci-thumb size-penci-thumb wp-post-image" alt="" srcset="https://i0.wp.com/massispost.com/wp-content/uploads/2018/04/pashinyan-24-1.jpg?resize=300%2C201&amp;ssl=1 300w, https://i0.wp.com/massispost.com/wp-content/uploads/2018/04/pashinyan-24-1.jpg?resize=585%2C390&amp;ssl=1 585w" sizes="(max-width: 585px) 100vw, 585px" />								</a>
							</div>
							<div class="penci-mega-meta">
								<h3 class="post-mega-title">
									<a href="https://massispost.com/2018/04/armenias-democratic-triumph-the-atlantic/">Armenia&#8217;s Democratic Triumph &#8211; The Atlantic</a>
								</h3>
																<p class="penci-mega-date">April 24, 2018</p>
															</div>
						</div>
											<div class="penci-mega-post">
							<div class="penci-mega-thumbnail">
																<span class="mega-cat-name">
																			Commentary																	</span>
																<a href="https://massispost.com/2018/04/genocide-and-independence-the-100-year-journey-of-a-nation/" title="Genocide and Independence: The 100-Year Journey of a Nation">
																		<img width="585" height="390" src="https://i0.wp.com/massispost.com/wp-content/uploads/2018/04/armenians-1.png?resize=585%2C390&amp;ssl=1" class="attachment-penci-thumb size-penci-thumb wp-post-image" alt="" />								</a>
							</div>
							<div class="penci-mega-meta">
								<h3 class="post-mega-title">
									<a href="https://massispost.com/2018/04/genocide-and-independence-the-100-year-journey-of-a-nation/">Genocide and Independence: The 100-Year Journey of a Nation</a>
								</h3>
																<p class="penci-mega-date">April 22, 2018</p>
															</div>
						</div>
											<div class="penci-mega-post">
							<div class="penci-mega-thumbnail">
																<span class="mega-cat-name">
																			Commentary																	</span>
																<a href="https://massispost.com/2018/04/aca-calls-for-immediate-release-of-peaceful-demonstrators/" title="ACA Calls For Immediate Release of Peaceful Demonstrators">
																		<img width="585" height="390" src="https://i0.wp.com/massispost.com/wp-content/uploads/2016/08/aca.jpg?resize=585%2C390&amp;ssl=1" class="attachment-penci-thumb size-penci-thumb wp-post-image" alt="" />								</a>
							</div>
							<div class="penci-mega-meta">
								<h3 class="post-mega-title">
									<a href="https://massispost.com/2018/04/aca-calls-for-immediate-release-of-peaceful-demonstrators/">ACA Calls For Immediate Release of Peaceful Demonstrators</a>
								</h3>
																<p class="penci-mega-date">April 22, 2018</p>
															</div>
						</div>
											<div class="penci-mega-post">
							<div class="penci-mega-thumbnail">
																<span class="mega-cat-name">
																			Commentary																	</span>
																<a href="https://massispost.com/2018/04/arsinee-khanjian-open-letter-serzh-sarkisian/" title="Arsinee Khanjian: Open letter to Serzh Sarkisian">
																		<img width="585" height="390" src="https://i2.wp.com/massispost.com/wp-content/uploads/2018/04/arsinee-khanjian.jpg?resize=585%2C390&amp;ssl=1" class="attachment-penci-thumb size-penci-thumb wp-post-image" alt="" srcset="https://i2.wp.com/massispost.com/wp-content/uploads/2018/04/arsinee-khanjian.jpg?resize=585%2C390&amp;ssl=1 585w, https://i2.wp.com/massispost.com/wp-content/uploads/2018/04/arsinee-khanjian.jpg?zoom=2&amp;resize=585%2C390&amp;ssl=1 1170w" sizes="(max-width: 585px) 100vw, 585px" />								</a>
							</div>
							<div class="penci-mega-meta">
								<h3 class="post-mega-title">
									<a href="https://massispost.com/2018/04/arsinee-khanjian-open-letter-serzh-sarkisian/">Arsinee Khanjian: Open letter to Serzh Sarkisian</a>
								</h3>
																<p class="penci-mega-date">April 17, 2018</p>
															</div>
						</div>
											<div class="penci-mega-post">
							<div class="penci-mega-thumbnail">
																<span class="mega-cat-name">
																			Commentary																	</span>
																<a href="https://massispost.com/2018/04/the-march-for-our-lives/" title="The March for Our Lives">
																		<img width="585" height="390" src="https://i0.wp.com/massispost.com/wp-content/uploads/2018/04/forourlives.jpg?resize=585%2C390&amp;ssl=1" class="attachment-penci-thumb size-penci-thumb wp-post-image" alt="" />								</a>
							</div>
							<div class="penci-mega-meta">
								<h3 class="post-mega-title">
									<a href="https://massispost.com/2018/04/the-march-for-our-lives/">The March for Our Lives</a>
								</h3>
																<p class="penci-mega-date">April 1, 2018</p>
															</div>
						</div>
									</div>
							</div>
		</div>

		</div></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category penci-mega-menu menu-item-23223"><a href="https://massispost.com/category/culture/">Arts &#038; Culture</a>
<ul class="sub-menu">
	<li class="menu-item-0"><div class="penci-megamenu">		
		<div class="penci-content-megamenu">
			<div class="penci-mega-latest-posts col-mn-5 mega-row-1">
								<div class="penci-mega-row penci-mega-10 row-active">
											<div class="penci-mega-post">
							<div class="penci-mega-thumbnail">
																<span class="mega-cat-name">
																			Arts &amp; Culture																	</span>
																<a href="https://massispost.com/2018/05/world-premiere-of-100-aprils-at-rogue-machine/" title="World Premiere of &#8220;100 Aprils&#8221; at Rogue Machine">
																		<img width="585" height="390" src="https://i0.wp.com/massispost.com/wp-content/uploads/2018/05/100-APRILS.jpg?resize=585%2C390&amp;ssl=1" class="attachment-penci-thumb size-penci-thumb wp-post-image" alt="" />								</a>
							</div>
							<div class="penci-mega-meta">
								<h3 class="post-mega-title">
									<a href="https://massispost.com/2018/05/world-premiere-of-100-aprils-at-rogue-machine/">World Premiere of &#8220;100 Aprils&#8221; at Rogue Machine</a>
								</h3>
																<p class="penci-mega-date">May 13, 2018</p>
															</div>
						</div>
											<div class="penci-mega-post">
							<div class="penci-mega-thumbnail">
																<span class="mega-cat-name">
																			Arts &amp; Culture																	</span>
																<a href="https://massispost.com/2018/05/the-mysterious-theater-robert-elibekians-reflections-on-theatrical-art/" title="The Mysterious Theater: Robert Elibekian’s Reflections on Theatrical Art">
																		<img width="585" height="390" src="https://i1.wp.com/massispost.com/wp-content/uploads/2018/05/Robert-Elibekian-dencer-35.5x24.5-cm-14x9.5-inches.jpg?resize=585%2C390&amp;ssl=1" class="attachment-penci-thumb size-penci-thumb wp-post-image" alt="" srcset="https://i1.wp.com/massispost.com/wp-content/uploads/2018/05/Robert-Elibekian-dencer-35.5x24.5-cm-14x9.5-inches.jpg?w=800&amp;ssl=1 800w, https://i1.wp.com/massispost.com/wp-content/uploads/2018/05/Robert-Elibekian-dencer-35.5x24.5-cm-14x9.5-inches.jpg?resize=300%2C200&amp;ssl=1 300w, https://i1.wp.com/massispost.com/wp-content/uploads/2018/05/Robert-Elibekian-dencer-35.5x24.5-cm-14x9.5-inches.jpg?resize=768%2C511&amp;ssl=1 768w, https://i1.wp.com/massispost.com/wp-content/uploads/2018/05/Robert-Elibekian-dencer-35.5x24.5-cm-14x9.5-inches.jpg?resize=585%2C389&amp;ssl=1 585w" sizes="(max-width: 585px) 100vw, 585px" />								</a>
							</div>
							<div class="penci-mega-meta">
								<h3 class="post-mega-title">
									<a href="https://massispost.com/2018/05/the-mysterious-theater-robert-elibekians-reflections-on-theatrical-art/">The Mysterious Theater: Robert Elibekian’s Reflections on Theatrical Art</a>
								</h3>
																<p class="penci-mega-date">May 10, 2018</p>
															</div>
						</div>
											<div class="penci-mega-post">
							<div class="penci-mega-thumbnail">
																<span class="mega-cat-name">
																			Arts &amp; Culture																	</span>
																<a href="https://massispost.com/2018/04/avedis-baghsarian-exhibit-pioneering-art-design-benefit-armenias-students/" title="Avedis Baghsarian to Exhibit His Pioneering Art and Design to Benefit Armenia’s Students">
																		<img width="585" height="390" src="https://i0.wp.com/massispost.com/wp-content/uploads/2018/04/baghdasarian-1.jpg?resize=585%2C390&amp;ssl=1" class="attachment-penci-thumb size-penci-thumb wp-post-image" alt="" />								</a>
							</div>
							<div class="penci-mega-meta">
								<h3 class="post-mega-title">
									<a href="https://massispost.com/2018/04/avedis-baghsarian-exhibit-pioneering-art-design-benefit-armenias-students/">Avedis Baghsarian to Exhibit His Pioneering Art and Design to Benefit Armenia’s Students</a>
								</h3>
																<p class="penci-mega-date">April 14, 2018</p>
															</div>
						</div>
											<div class="penci-mega-post">
							<div class="penci-mega-thumbnail">
																<span class="mega-cat-name">
																			Arts &amp; Culture																	</span>
																<a href="https://massispost.com/2018/04/side-home-fresno-state/" title="“The Other Side of Home” at Fresno State">
																		<img width="585" height="390" src="https://i1.wp.com/massispost.com/wp-content/uploads/2018/04/The-Other-Side-of-Home.jpg?resize=585%2C390&amp;ssl=1" class="attachment-penci-thumb size-penci-thumb wp-post-image" alt="" srcset="https://i1.wp.com/massispost.com/wp-content/uploads/2018/04/The-Other-Side-of-Home.jpg?resize=585%2C390&amp;ssl=1 585w, https://i1.wp.com/massispost.com/wp-content/uploads/2018/04/The-Other-Side-of-Home.jpg?zoom=2&amp;resize=585%2C390&amp;ssl=1 1170w" sizes="(max-width: 585px) 100vw, 585px" />								</a>
							</div>
							<div class="penci-mega-meta">
								<h3 class="post-mega-title">
									<a href="https://massispost.com/2018/04/side-home-fresno-state/">“The Other Side of Home” at Fresno State</a>
								</h3>
																<p class="penci-mega-date">April 13, 2018</p>
															</div>
						</div>
											<div class="penci-mega-post">
							<div class="penci-mega-thumbnail">
																<span class="mega-cat-name">
																			Arts &amp; Culture																	</span>
																<a href="https://massispost.com/2018/04/aca-screens-intent-destroy-sold-crowd/" title="ACA Screens “Intent to Destroy” To Sold Out Crowd">
																		<img width="585" height="390" src="https://i1.wp.com/massispost.com/wp-content/uploads/2018/04/intent-to-destroy.jpg?resize=585%2C390&amp;ssl=1" class="attachment-penci-thumb size-penci-thumb wp-post-image" alt="" />								</a>
							</div>
							<div class="penci-mega-meta">
								<h3 class="post-mega-title">
									<a href="https://massispost.com/2018/04/aca-screens-intent-destroy-sold-crowd/">ACA Screens “Intent to Destroy” To Sold Out Crowd</a>
								</h3>
																<p class="penci-mega-date">April 9, 2018</p>
															</div>
						</div>
									</div>
							</div>
		</div>

		</div></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category penci-mega-menu menu-item-23232"><a href="https://massispost.com/category/sports/">Sports</a>
<ul class="sub-menu">
	<li class="menu-item-0"><div class="penci-megamenu">		
		<div class="penci-content-megamenu">
			<div class="penci-mega-latest-posts col-mn-5 mega-row-1">
								<div class="penci-mega-row penci-mega-186 row-active">
											<div class="penci-mega-post">
							<div class="penci-mega-thumbnail">
																<span class="mega-cat-name">
																			Sports																	</span>
																<a href="https://massispost.com/2018/03/arsen-goulamirian-wins-wba-light-heavyweight-world-champion-title/" title="Arsen Goulamirian Wins WBA Light Heavyweight World Champion Title">
																		<img width="585" height="390" src="https://i2.wp.com/massispost.com/wp-content/uploads/2018/03/arsen-goulamirian.jpg?resize=585%2C390&amp;ssl=1" class="attachment-penci-thumb size-penci-thumb wp-post-image" alt="" />								</a>
							</div>
							<div class="penci-mega-meta">
								<h3 class="post-mega-title">
									<a href="https://massispost.com/2018/03/arsen-goulamirian-wins-wba-light-heavyweight-world-champion-title/">Arsen Goulamirian Wins WBA Light Heavyweight World Champion Title</a>
								</h3>
																<p class="penci-mega-date">March 26, 2018</p>
															</div>
						</div>
											<div class="penci-mega-post">
							<div class="penci-mega-thumbnail">
																<span class="mega-cat-name">
																			Sports																	</span>
																<a href="https://massispost.com/2018/03/yura-movsisyan-joins-swedish-club-djurgarden/" title="Yura Movsisyan Joins Swedish Club Djurgården">
																		<img width="585" height="390" src="https://i2.wp.com/massispost.com/wp-content/uploads/2018/03/Movsisyan-Djurgården.jpg?resize=585%2C390&amp;ssl=1" class="attachment-penci-thumb size-penci-thumb wp-post-image" alt="" />								</a>
							</div>
							<div class="penci-mega-meta">
								<h3 class="post-mega-title">
									<a href="https://massispost.com/2018/03/yura-movsisyan-joins-swedish-club-djurgarden/">Yura Movsisyan Joins Swedish Club Djurgården</a>
								</h3>
																<p class="penci-mega-date">March 26, 2018</p>
															</div>
						</div>
											<div class="penci-mega-post">
							<div class="penci-mega-thumbnail">
																<span class="mega-cat-name">
																			Sports																	</span>
																<a href="https://massispost.com/2018/02/armenia-beats-albania-84-65-eurobasket-2021-pre-qualifiers/" title="Armenia Beats Albania 84-65 in EuroBasket 2021 Pre-Qualifiers">
																		<img width="585" height="390" src="https://i2.wp.com/massispost.com/wp-content/uploads/2018/02/armenia-2.jpg?resize=585%2C390&amp;ssl=1" class="attachment-penci-thumb size-penci-thumb wp-post-image" alt="" srcset="https://i2.wp.com/massispost.com/wp-content/uploads/2018/02/armenia-2.jpg?w=850&amp;ssl=1 850w, https://i2.wp.com/massispost.com/wp-content/uploads/2018/02/armenia-2.jpg?resize=300%2C200&amp;ssl=1 300w, https://i2.wp.com/massispost.com/wp-content/uploads/2018/02/armenia-2.jpg?resize=768%2C512&amp;ssl=1 768w, https://i2.wp.com/massispost.com/wp-content/uploads/2018/02/armenia-2.jpg?resize=585%2C390&amp;ssl=1 585w" sizes="(max-width: 585px) 100vw, 585px" />								</a>
							</div>
							<div class="penci-mega-meta">
								<h3 class="post-mega-title">
									<a href="https://massispost.com/2018/02/armenia-beats-albania-84-65-eurobasket-2021-pre-qualifiers/">Armenia Beats Albania 84-65 in EuroBasket 2021 Pre-Qualifiers</a>
								</h3>
																<p class="penci-mega-date">February 26, 2018</p>
															</div>
						</div>
											<div class="penci-mega-post">
							<div class="penci-mega-thumbnail">
																<span class="mega-cat-name">
																			Sports																	</span>
																<a href="https://massispost.com/2018/02/mkhitaryan-three-assists-first-start-arsenal/" title="Mkhitaryan Has Three Assists in First Start for Arsenal">
																		<img width="585" height="390" src="https://i0.wp.com/massispost.com/wp-content/uploads/2018/02/mkhitaryan.jpg?resize=585%2C390&amp;ssl=1" class="attachment-penci-thumb size-penci-thumb wp-post-image" alt="" srcset="https://i0.wp.com/massispost.com/wp-content/uploads/2018/02/mkhitaryan.jpg?w=800&amp;ssl=1 800w, https://i0.wp.com/massispost.com/wp-content/uploads/2018/02/mkhitaryan.jpg?resize=300%2C200&amp;ssl=1 300w, https://i0.wp.com/massispost.com/wp-content/uploads/2018/02/mkhitaryan.jpg?resize=768%2C512&amp;ssl=1 768w, https://i0.wp.com/massispost.com/wp-content/uploads/2018/02/mkhitaryan.jpg?resize=585%2C390&amp;ssl=1 585w" sizes="(max-width: 585px) 100vw, 585px" />								</a>
							</div>
							<div class="penci-mega-meta">
								<h3 class="post-mega-title">
									<a href="https://massispost.com/2018/02/mkhitaryan-three-assists-first-start-arsenal/">Mkhitaryan Has Three Assists in First Start for Arsenal</a>
								</h3>
																<p class="penci-mega-date">February 3, 2018</p>
															</div>
						</div>
											<div class="penci-mega-post">
							<div class="penci-mega-thumbnail">
																<span class="mega-cat-name">
																			Sports																	</span>
																<a href="https://massispost.com/2018/01/uefa-nations-league-armenia-play-macedonia-lichtenstein-gibraltar/" title="UEFA Nations League: Armenia to Play Macedonia, Lichtenstein and Gibraltar">
																		<img width="585" height="390" src="https://i1.wp.com/massispost.com/wp-content/uploads/2018/01/uefa-d.jpg?resize=585%2C390&amp;ssl=1" class="attachment-penci-thumb size-penci-thumb wp-post-image" alt="" />								</a>
							</div>
							<div class="penci-mega-meta">
								<h3 class="post-mega-title">
									<a href="https://massispost.com/2018/01/uefa-nations-league-armenia-play-macedonia-lichtenstein-gibraltar/">UEFA Nations League: Armenia to Play Macedonia, Lichtenstein and Gibraltar</a>
								</h3>
																<p class="penci-mega-date">January 24, 2018</p>
															</div>
						</div>
									</div>
							</div>
		</div>

		</div></li>
</ul>
</li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-23225"><a href="https://massispost.com/am"><span class="visuallyhidden">Հայերէն</span><img src="https://cdn5.massispost.com/wp-content/uploads/2016/07/Flag_of_Armenia.svg-1.png" class="_mi _svg" aria-hidden="true" style="width:3em;" /></a></li>
</ul>
				
									<div id="top-search">
						<a class="search-click"><i class="fa fa-search"></i></a>
						<div class="show-search">
							<form role="search" method="get" id="searchform" action="https://massispost.com/">
    <div>
		<input type="text" class="search-input" placeholder="Type and hit enter..." name="s" id="s" />
	 </div>
</form>							<a class="search-click close-search"><i class="fa fa-close"></i></a>
						</div>
					</div>
				
							</div>
		</nav><!-- End Navigation -->
	</header>
<!-- end #header -->



			<div class="container penci-breadcrumb single-breadcrumb">
			<span><a class="crumb" href="https://massispost.com/">Home</a></span><i class="fa fa-angle-right"></i>
				<span>
					<a href="https://massispost.com/category/armenia/">Armenia</a>				</span><i class="fa fa-angle-right"></i>
			<span>PM Pashinian Satisfied With ‘Productive’ Talks With President Putin</span>
		</div>
	
	
	<div class="container container-single container-single-magazine penci_sidebar right-sidebar penci-enable-lightbox">
		<div id="main" class="penci-main-sticky-sidebar">
			<div class="theiaStickySidebar">
														<article id="post-31553" class="post-31553 post type-post status-publish format-standard has-post-thumbnail hentry category-armenia category-featured category-news category-politics category-world">

	
	
	
									<div class="post-image">
					<a href="https://cdn5.massispost.com/wp-content/uploads/2018/05/pashinyan-putin-2.jpg" data-rel="penci-gallery-image-content"><img width="850" height="566" src="https://i1.wp.com/massispost.com/wp-content/uploads/2018/05/pashinyan-putin-2.jpg?resize=850%2C566&amp;ssl=1" class="attachment-penci-full-thumb size-penci-full-thumb wp-post-image" alt="" srcset="https://i1.wp.com/massispost.com/wp-content/uploads/2018/05/pashinyan-putin-2.jpg?w=850&amp;ssl=1 850w, https://i1.wp.com/massispost.com/wp-content/uploads/2018/05/pashinyan-putin-2.jpg?resize=300%2C200&amp;ssl=1 300w, https://i1.wp.com/massispost.com/wp-content/uploads/2018/05/pashinyan-putin-2.jpg?resize=768%2C511&amp;ssl=1 768w, https://i1.wp.com/massispost.com/wp-content/uploads/2018/05/pashinyan-putin-2.jpg?resize=585%2C390&amp;ssl=1 585w" sizes="(max-width: 850px) 100vw, 850px" /></a>				</div>
					
	
	
	
	
		<div class="header-standard header-classic single-header">
							<div class="penci-standard-cat"><span class="cat"><a class="penci-cat-name" href="https://massispost.com/category/armenia/" title="View all posts in Armenia" >Armenia</a><a class="penci-cat-name" href="https://massispost.com/category/featured/" title="View all posts in Featured" >Featured</a><a class="penci-cat-name" href="https://massispost.com/category/news/" title="View all posts in News" >News</a><a class="penci-cat-name" href="https://massispost.com/category/politics/" title="View all posts in Politics" >Politics</a><a class="penci-cat-name" href="https://massispost.com/category/world/" title="View all posts in World" >World</a></span></div>
			
			<h1 class="post-title single-post-title">PM Pashinian Satisfied With ‘Productive’ Talks With President Putin</h1>

							<div class="post-box-meta-single">
																<span>May 15, 2018</span>
									</div>
					</div>

		
	
	<div class="post-entry">
		<div class="inner-post-entry">
			<div class="at-above-post addthis_tool" data-url="https://massispost.com/2018/05/pm-pashinian-satisfied-with-productive-talks-with-president-putin/"></div><p>YEREVAN (RFE/RL) &#8212; Armenian Prime Minister Nikol Pashinian on Tuesday described as “very productive” his first meeting with Russian President Vladimir Putin which was held in Sochi on Monday.</p>
<p>“We discussed a very broad range of issues and it was a very productive meeting,” he told RFE/RL’s Armenian service (Azatutyun.am). He declined to elaborate.</p>
<p>Pashinian confirmed that the unresolved Nagorno-Karabakh was also on the agenda of the talks with Putin. “It was a general discussion. We didn’t really go into details,” he said.</p>
<p>In his opening remarks at the talks, the Armenian premier, who took office on May 8, reaffirmed his commitment to maintaining “strategic allied relations” with Russia. “I can assure you that there is basically a consensus on this issue in Armenia, and nobody has cast doubt and, I think, will cast doubt on the strategic importance of Russian-Armenian relations,” he said.</p>
<p>For his part, Putin told Pashinian that he regards Armenia as “our closest partner and ally in the region” and hopes Russian-Armenia ties will “develop as steadily as has been the case until now.”</p>
<p>“I want to wish you success in the post of the head of government,” Putin told Pashinian in his opening remarks at their first-ever face-to-face talks. “I hope that our relations will develop as steadily as has been the case until now and we will be working together just as actively in the international arena, in international organizations … in the area of security and in the area of economic development.”</p>
<p>Russia continues to regard Armenia as “our closest partner and ally in the region,” he said, pointing to close defense and security ties as well as economic cooperation between the two nations.</p>
<p>Putin went on to praise recent years’ rapid growth in bilateral trade and, in particular, Armenian exports to Russia. He said he hopes that Yerevan and Moscow will “not only preserve but also multiply” that “very good dynamics.”</p>
<p>Neither the Kremlin nor the Armenian government issued any statements on the results of the Putin-Pashinian encounter which took place in the presence of other senior Armenian and Russian officials.</p>
<p>The two leaders met in the Russian Black Sea city just hours before a summit of the five former Soviet republics making up the Eurasian Economic Union (EEU).</p>
<p>“It’s an interesting format,” Pashinian said when asked about his impressions of the EEU summit in Sochi. “It was very interesting.”</p>
<div class="hatom-extra" style="display:none !important;visibility:hidden;"><span class="entry-title">PM Pashinian Satisfied With ‘Productive’ Talks With President Putin</span> was last modified: <span class="updated"> May 15th, 2018</span> by <span class="author vcard"><span class="fn">MassisPost</span></span></div><!-- AddThis Advanced Settings above via filter on the_content --><!-- AddThis Advanced Settings below via filter on the_content --><!-- AddThis Advanced Settings generic via filter on the_content --><!-- AddThis Share Buttons above via filter on the_content --><!-- AddThis Share Buttons below via filter on the_content --><div class="at-below-post addthis_tool" data-url="https://massispost.com/2018/05/pm-pashinian-satisfied-with-productive-talks-with-president-putin/"></div><!-- AddThis Share Buttons generic via filter on the_content -->								</div>
	</div>

	
			<div class="tags-share-box center-box">

							<span class="single-comment-o"><i class="fa fa-comment-o"></i>0 comment</span>
			
							<div class="post-share">
					<span class="count-number-like">0</span><a class="penci-post-like single-like-button" data-post_id="31553" title="Like" data-like="Like" data-unlike="Unlike"><i class="fa fa-heart-o"></i></a>					<div class="list-posts-share">
												<a target="_blank" href="https://www.facebook.com/sharer/sharer.php?u=https://massispost.com/2018/05/pm-pashinian-satisfied-with-productive-talks-with-president-putin/"><i class="fa fa-facebook"></i><span class="dt-share">Facebook</span></a>
						<a target="_blank" href="https://twitter.com/home?status=Check%20out%20this%20article:%20PM%20Pashinian%20Satisfied%20With%20‘Productive’%20Talks%20With%20President%20Putin%20-%20https://massispost.com/2018/05/pm-pashinian-satisfied-with-productive-talks-with-president-putin/"><i class="fa fa-twitter"></i><span class="dt-share">Twitter</span></a>
						<a target="_blank" href="https://plus.google.com/share?url=https://massispost.com/2018/05/pm-pashinian-satisfied-with-productive-talks-with-president-putin/"><i class="fa fa-google-plus"></i><span class="dt-share">Google +</span></a>
						<a data-pin-do="none" target="_blank" href="https://pinterest.com/pin/create/button/?url=https://massispost.com/2018/05/pm-pashinian-satisfied-with-productive-talks-with-president-putin/&#038;media=https://cdn5.massispost.com/wp-content/uploads/2018/05/pashinyan-putin-2.jpg&#038;description=PM%20Pashinian%20Satisfied%20With%20‘Productive’%20Talks%20With%20President%20Putin"><i class="fa fa-pinterest"></i><span class="dt-share">Pinterest</span></a>
					</div>
				</div>
					</div>
	
			<div class="post-author">
	<div class="author-img">
		<img alt='' src='https://secure.gravatar.com/avatar/670508df3ed5048abc6774a98a687f9a?s=100&#038;d=mm&#038;r=g' srcset="https://secure.gravatar.com/avatar/670508df3ed5048abc6774a98a687f9a?s=200&#038;d=mm&#038;r=g 2x" class='avatar avatar-100 photo' height='100' width='100' />	</div>
	<div class="author-content">
		<h5><a href="https://massispost.com/author/admin/" title="Posts by MassisPost" rel="author">MassisPost</a></h5>
		<p></p>
													</div>
</div>	
			<div class="post-pagination">
				<div class="prev-post">
						<div class="prev-post-inner">
				<div class="prev-post-title">
					<span>previous post</span>
				</div>
				<a href="https://massispost.com/2018/05/new-armenian-government-formed/">
					<div class="pagi-text">
						<h5 class="prev-title">New Armenian Government Formed</h5>
					</div>
				</a>
			</div>
		</div>
	
	</div>	
					<div class="post-related">
		<div class="post-title-box"><h4 class="post-box-title">Related News</h4></div>
		<div class="penci-carousel penci-related-carousel" data-auto="false" data-dots="true" data-arrows="false">
						<div class="item-related">
											<a class="related-thumb" href="https://massispost.com/2017/06/austrian-mps-heads-diplomatic-corps-visit-viennas-mekhitarist-congregation/">
														<img width="585" height="390" src="https://i2.wp.com/massispost.com/wp-content/uploads/2017/06/mkhitarists.jpg?resize=585%2C390&amp;ssl=1" class="attachment-penci-thumb size-penci-thumb wp-post-image" alt="" srcset="https://i2.wp.com/massispost.com/wp-content/uploads/2017/06/mkhitarists.jpg?resize=300%2C201&amp;ssl=1 300w, https://i2.wp.com/massispost.com/wp-content/uploads/2017/06/mkhitarists.jpg?resize=585%2C390&amp;ssl=1 585w" sizes="(max-width: 585px) 100vw, 585px" />						</a>
										<h3><a href="https://massispost.com/2017/06/austrian-mps-heads-diplomatic-corps-visit-viennas-mekhitarist-congregation/">Austrian MPs and Heads of Diplomatic Corps Visit Vienna’s Mekhitarist Congregation</a></h3>
										<span class="date">June 8, 2017</span>
									</div>
						<div class="item-related">
											<a class="related-thumb" href="https://massispost.com/2011/05/presence-of-armenian-peacekeepers-in-afghanistan-to-triple/">
														<img width="360" height="270" src="https://i2.wp.com/massispost.com/wp-content/uploads/2011/05/ArmenianPeacekeepers.jpg?resize=360%2C270&amp;ssl=1" class="attachment-penci-thumb size-penci-thumb wp-post-image" alt="" srcset="https://i2.wp.com/massispost.com/wp-content/uploads/2011/05/ArmenianPeacekeepers.jpg?w=360&amp;ssl=1 360w, https://i2.wp.com/massispost.com/wp-content/uploads/2011/05/ArmenianPeacekeepers.jpg?resize=300%2C225&amp;ssl=1 300w, https://i2.wp.com/massispost.com/wp-content/uploads/2011/05/ArmenianPeacekeepers.jpg?resize=342%2C256&amp;ssl=1 342w, https://i2.wp.com/massispost.com/wp-content/uploads/2011/05/ArmenianPeacekeepers.jpg?resize=60%2C45&amp;ssl=1 60w, https://i2.wp.com/massispost.com/wp-content/uploads/2011/05/ArmenianPeacekeepers.jpg?resize=150%2C113&amp;ssl=1 150w, https://i2.wp.com/massispost.com/wp-content/uploads/2011/05/ArmenianPeacekeepers.jpg?resize=269%2C201&amp;ssl=1 269w" sizes="(max-width: 360px) 100vw, 360px" />						</a>
										<h3><a href="https://massispost.com/2011/05/presence-of-armenian-peacekeepers-in-afghanistan-to-triple/">Presence Of Armenian Peacekeepers In Afghanistan To Triple</a></h3>
										<span class="date">May 11, 2011</span>
									</div>
						<div class="item-related">
											<a class="related-thumb" href="https://massispost.com/2011/05/armenia-marks-soviet-victory-over-nazi-germany/">
														<img width="585" height="390" src="https://i2.wp.com/massispost.com/wp-content/uploads/2011/05/ww2.jpg?resize=585%2C390&amp;ssl=1" class="attachment-penci-thumb size-penci-thumb wp-post-image" alt="" srcset="https://i2.wp.com/massispost.com/wp-content/uploads/2011/05/ww2.jpg?zoom=2&amp;resize=585%2C390&amp;ssl=1 1170w, https://i2.wp.com/massispost.com/wp-content/uploads/2011/05/ww2.jpg?zoom=3&amp;resize=585%2C390&amp;ssl=1 1755w" sizes="(max-width: 585px) 100vw, 585px" />						</a>
										<h3><a href="https://massispost.com/2011/05/armenia-marks-soviet-victory-over-nazi-germany/">Armenia Marks Soviet Victory Over Nazi Germany</a></h3>
										<span class="date">May 9, 2011</span>
									</div>
						<div class="item-related">
											<a class="related-thumb" href="https://massispost.com/2015/02/rebuilding-from-the-rubble-of-sumgait/">
														<img width="585" height="390" src="https://i2.wp.com/massispost.com/wp-content/uploads/2015/02/Rebuilding.jpg?resize=585%2C390&amp;ssl=1" class="attachment-penci-thumb size-penci-thumb wp-post-image" alt="" />						</a>
										<h3><a href="https://massispost.com/2015/02/rebuilding-from-the-rubble-of-sumgait/">Rebuilding from the Rubble of Sumgait</a></h3>
										<span class="date">February 27, 2015</span>
									</div>
						<div class="item-related">
											<a class="related-thumb" href="https://massispost.com/2016/03/four-pianos-on-one-stage-european-musicians-to-play-unique-concert-in-yerevan/">
														<img width="585" height="390" src="https://i2.wp.com/massispost.com/wp-content/uploads/2016/03/4-pianos.jpg?resize=585%2C390&amp;ssl=1" class="attachment-penci-thumb size-penci-thumb wp-post-image" alt="" srcset="https://i2.wp.com/massispost.com/wp-content/uploads/2016/03/4-pianos.jpg?resize=254%2C168&amp;ssl=1 254w, https://i2.wp.com/massispost.com/wp-content/uploads/2016/03/4-pianos.jpg?resize=125%2C83&amp;ssl=1 125w" sizes="(max-width: 585px) 100vw, 585px" />						</a>
										<h3><a href="https://massispost.com/2016/03/four-pianos-on-one-stage-european-musicians-to-play-unique-concert-in-yerevan/">\&#8217;Four Pianos on One Stage\&#8217;: European Musicians to Play Unique Concert in Yerevan</a></h3>
										<span class="date">March 7, 2016</span>
									</div>
						<div class="item-related">
											<a class="related-thumb" href="https://massispost.com/2016/12/congressman-schiff-concerned-president-elect-donald-trumps-economic-interests-turkey-azerbaijan/">
														<img width="585" height="390" src="https://i2.wp.com/massispost.com/wp-content/uploads/2013/06/adam_schiff.jpg?resize=585%2C390&amp;ssl=1" class="attachment-penci-thumb size-penci-thumb wp-post-image" alt="" srcset="https://i2.wp.com/massispost.com/wp-content/uploads/2013/06/adam_schiff.jpg?zoom=2&amp;resize=585%2C390&amp;ssl=1 1170w, https://i2.wp.com/massispost.com/wp-content/uploads/2013/06/adam_schiff.jpg?zoom=3&amp;resize=585%2C390&amp;ssl=1 1755w" sizes="(max-width: 585px) 100vw, 585px" />						</a>
										<h3><a href="https://massispost.com/2016/12/congressman-schiff-concerned-president-elect-donald-trumps-economic-interests-turkey-azerbaijan/">Congressman Schiff Concerned with President-Elect Donald Trump’s Economic Interests in Turkey and Azerbaijan</a></h3>
										<span class="date">December 7, 2016</span>
									</div>
						<div class="item-related">
											<a class="related-thumb" href="https://massispost.com/2011/03/turkey-spend-over-3-million-to-block-armenian-genocide-resolution-in-us-congress/">
														<img width="250" height="235" src="https://i2.wp.com/massispost.com/wp-content/uploads/2011/03/Turkey-USLobby.jpg?resize=250%2C235&amp;ssl=1" class="attachment-penci-thumb size-penci-thumb wp-post-image" alt="" />						</a>
										<h3><a href="https://massispost.com/2011/03/turkey-spend-over-3-million-to-block-armenian-genocide-resolution-in-us-congress/">Turkey Spend Over $3 Million to Block Armenian Genocide Resolution in US Congress</a></h3>
										<span class="date">March 14, 2011</span>
									</div>
						<div class="item-related">
											<a class="related-thumb" href="https://massispost.com/2012/06/us-ambassador-armenia-turkey-protocols-must-be-ratified-without-preconditions/">
														<img width="585" height="350" src="https://i1.wp.com/massispost.com/wp-content/uploads/2012/06/john-heffern.jpg?resize=585%2C350&amp;ssl=1" class="attachment-penci-thumb size-penci-thumb wp-post-image" alt="" srcset="https://i1.wp.com/massispost.com/wp-content/uploads/2012/06/john-heffern.jpg?zoom=2&amp;resize=585%2C350&amp;ssl=1 1170w, https://i1.wp.com/massispost.com/wp-content/uploads/2012/06/john-heffern.jpg?zoom=3&amp;resize=585%2C350&amp;ssl=1 1755w" sizes="(max-width: 585px) 100vw, 585px" />						</a>
										<h3><a href="https://massispost.com/2012/06/us-ambassador-armenia-turkey-protocols-must-be-ratified-without-preconditions/">US Ambassador: Armenia-Turkey Protocols Must Be Ratified Without Preconditions</a></h3>
										<span class="date">June 28, 2012</span>
									</div>
						<div class="item-related">
											<a class="related-thumb" href="https://massispost.com/2017/10/distinguished-luminaries-attend-october-21-amaa-centennial-banquet/">
														<img width="585" height="390" src="https://i1.wp.com/massispost.com/wp-content/uploads/2017/10/amaa.jpg?resize=585%2C390&amp;ssl=1" class="attachment-penci-thumb size-penci-thumb wp-post-image" alt="" />						</a>
										<h3><a href="https://massispost.com/2017/10/distinguished-luminaries-attend-october-21-amaa-centennial-banquet/">Distinguished Luminaries to Attend October 21 AMAA Centennial Banquet</a></h3>
										<span class="date">October 13, 2017</span>
									</div>
						<div class="item-related">
										<h3><a href="https://massispost.com/2017/05/kaloosdians-book-tadem-reviewed-april-issue-holocaust-genocide-studies/">Kaloosdian\&#8217;s Book Tadem Reviewed in April Issue of Holocaust and Genocide Studies</a></h3>
										<span class="date">May 10, 2017</span>
									</div>
		</div></div>	
			<div class="post-comments no-comment-yet" id="comments">
	<div id='comments_pagination'></div>
		<div id="respond" class="comment-respond">
							<h3 id="reply-title" class="comment-reply-title">Leave a Reply					<small><a rel="nofollow" id="cancel-comment-reply-link" href="/2018/05/pm-pashinian-satisfied-with-productive-talks-with-president-putin/#respond" style="display:none;">Cancel reply</a></small>
				</h3>
						<form id="commentform" class="comment-form">
				<iframe title="Comment Form" src="https://jetpack.wordpress.com/jetpack-comment/?blogid=47534632&#038;postid=31553&#038;comment_registration=0&#038;require_name_email=1&#038;stc_enabled=0&#038;stb_enabled=0&#038;show_avatars=1&#038;avatar_default=mystery&#038;greeting=Leave+a+Reply&#038;greeting_reply=Leave+a+Reply+to+%25s&#038;color_scheme=transparent&#038;lang=en_US&#038;jetpack_version=6.0&#038;sig=c9ed664d6dd52c58bb40151ec7922467247fc3a5#parent=https%3A%2F%2Fmassispost.com%2F2018%2F05%2Fpm-pashinian-satisfied-with-productive-talks-with-president-putin%2F" style="width:100%; height: 430px; border:0;" name="jetpack_remote_comment" class="jetpack_remote_comment" id="jetpack_remote_comment"></iframe>
				<!--[if !IE]><!-->
				<script>
					document.addEventListener('DOMContentLoaded', function () {
						var commentForms = document.getElementsByClassName('jetpack_remote_comment');
						for (var i = 0; i < commentForms.length; i++) {
							commentForms[i].allowTransparency = true;
							commentForms[i].scrolling = 'no';
						}
					});
				</script>
				<!--<![endif]-->
			</form>
		</div>

		
		<input type="hidden" name="comment_parent" id="comment_parent" value="" />

		</div> <!-- end comments div -->
	
</article>							</div>
		</div>
					
<div id="sidebar" class="penci-sticky-sidebar">
	<div class="theiaStickySidebar">
		<aside id="penci_facebook_widget-3" class="widget penci_facebook_widget"><h4 class="widget-title penci-border-arrow"><span class="inner-arrow">Like Us on Facebook</span></h4>			<div class="fb-page" data-href="http://www.facebook.com/massispost" data-height="290" data-small-header="false" data-adapt-container-width="true" data-hide-cover="false" data-show-facepile="true" data-show-posts="true"><div class="fb-xfbml-parse-ignore"><blockquote cite="http://www.facebook.com/massispost"><a href="http://www.facebook.com/massispost">Facebook</a></blockquote></div></div>
		</aside><aside id="text-2" class="widget widget_text"><h4 class="widget-title penci-border-arrow"><span class="inner-arrow">Current Issue</span></h4>			<div class="textwidget"><p><a href="https://massisweekly.com/current.html" target="_blank" rel="noopener"><img class="aligncenter size-large wp-image-31484" src="https://i0.wp.com/massisweekly.com/images/pg1.jpg?fit=1024%2C1024&#038;ssl=1" alt="" data-recalc-dims="1" /></a></p>
<p>&nbsp;</p>
</div>
		</aside>	</div>
</div>		
<!-- END CONTAINER -->
</div>
<div class="clear-footer"></div>

<div id="penci-end-sidebar-sticky"></div>


<footer id="footer-section">
	<div class="container">
							<div class="footer-logo-copyright footer-not-logo">
				
				
									<div id="footer-copyright">
						<p>@2017 - MassisPost. All Right Reserved. Designed by NK Web Services Inc.</p>
					</div>
													<div class="go-to-top-parent"><a href="#" class="go-to-top"><span><i class="fa fa-angle-up"></i><br>Back To Top</span></a></div>
							</div>
			</div>
</footer>

</div><!-- End .wrapper-boxed -->

<div id="fb-root"></div>


<!-- This site is optimized with Phil Singleton's WP SEO Structured Data Plugin v2.4.1 - https://kcseopro.com/wordpress-seo-structured-data-schema-plugin/ -->
<script type="application/ld+json">{
    "@context": "http://schema.org",
    "@type": "Organization",
    "additionalType": "https://massispost.com",
    "name": "MassisPost",
    "logo": "https://cdn5.massispost.com/wp-content/uploads/2017/11/512.png",
    "url": "https://massispost.com",
    "sameAs": [
        "https://www.facebook.com/MassisPost/",
        "https://twitter.com/massisPost"
    ],
    "contactPoint": {
        "@type": "ContactPoint",
        "telephone": "",
        "contactType": "Customer Service",
        "email": "",
        "contactOption": "",
        "areaServed": "",
        "availableLanguage": null
    },
    "address": {
        "@type": "PostalAddress",
        "addressCountry": "United States",
        "addressLocality": null,
        "addressRegion": null,
        "postalCode": null,
        "streetAddress": null
    }
}</script>
<!-- / WP SEO Structured Data Plugin. -->

<script data-cfasync="false" type="text/javascript">if (window.addthis_product === undefined) { window.addthis_product = "wpp"; } if (window.wp_product_version === undefined) { window.wp_product_version = "wpp-6.1.4"; } if (window.wp_blog_version === undefined) { window.wp_blog_version = "4.9.5"; } if (window.addthis_share === undefined) { window.addthis_share = {"passthrough":{"twitter":{"via":"massispost"}}}; } if (window.addthis_config === undefined) { window.addthis_config = {"data_track_clickback":true,"ui_atversion":"300"}; } if (window.addthis_plugin_info === undefined) { window.addthis_plugin_info = {"info_status":"enabled","cms_name":"WordPress","plugin_name":"Share Buttons by AddThis","plugin_version":"6.1.4","plugin_mode":"AddThis","anonymous_profile_id":"wp-124fd03a99562b90b1e685623158cd5c","page_info":{"template":"posts","post_type":""},"sharing_enabled_on_post_via_metabox":false}; } 
                    (function() {
                      var first_load_interval_id = setInterval(function () {
                        if (typeof window.addthis !== 'undefined') {
                          window.clearInterval(first_load_interval_id);
                          if (typeof window.addthis_layers !== 'undefined' && Object.getOwnPropertyNames(window.addthis_layers).length > 0) {
                            window.addthis.layers(window.addthis_layers);
                          }
                          if (Array.isArray(window.addthis_layers_tools)) {
                            for (i = 0; i < window.addthis_layers_tools.length; i++) {
                              window.addthis.layers(window.addthis_layers_tools[i]);
                            }
                          }
                        }
                     },1000)
                    }());
                </script><script type='text/javascript' src='https://cdn2.massispost.com/wp-content/plugins/jetpack/_inc/build/photon/photon.min.js?ver=20130122'></script>
<script type='text/javascript' src='https://s7.addthis.com/js/300/addthis_widget.js?ver=4.9.5#pubid=ra-5556226714325ad2'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var wpcf7 = {"apiSettings":{"root":"https:\/\/massispost.com\/wp-json\/contact-form-7\/v1","namespace":"contact-form-7\/v1"},"recaptcha":{"messages":{"empty":"Please verify that you are not a robot."}},"cached":"1"};
/* ]]> */
</script>
<script type='text/javascript' src='https://cdn2.massispost.com/wp-content/plugins/contact-form-7/includes/js/scripts.js?ver=4.9.1'></script>
<script type='text/javascript' src='https://s0.wp.com/wp-content/js/devicepx-jetpack.js?ver=201820'></script>
<script type='text/javascript' src='https://cdn2.massispost.com/wp-content/themes/soledad/js/libs-script.min.js?ver=2.6.1'></script>
<script type='text/javascript' src='https://cdn2.massispost.com/wp-content/themes/soledad/js/main.js?ver=2.6.1'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var ajax_var = {"url":"https:\/\/massispost.com\/wp-admin\/admin-ajax.php","nonce":"1045855898"};
/* ]]> */
</script>
<script type='text/javascript' src='https://cdn2.massispost.com/wp-content/themes/soledad/js/post-like.js?ver=2.6.1'></script>
<script type='text/javascript' src='https://cdn2.massispost.com/wp-includes/js/comment-reply.min.js?ver=4.9.5'></script>
<script type='text/javascript' src='https://cdn2.massispost.com/wp-content/plugins/jetpack/modules/likes/queuehandler.js?ver=6.0'></script>
<script type='text/javascript' src='https://cdn2.massispost.com/wp-includes/js/hoverIntent.min.js?ver=1.8.1'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var megamenu = {"timeout":"300","interval":"100"};
/* ]]> */
</script>
<script type='text/javascript' src='https://cdn2.massispost.com/wp-content/plugins/megamenu/js/maxmegamenu.js?ver=2.4.1.2'></script>
<script type='text/javascript' src='https://cdn2.massispost.com/wp-includes/js/wp-embed.min.js?ver=4.9.5'></script>
<script async="async" type='text/javascript' src='https://cdn2.massispost.com/wp-content/plugins/akismet/_inc/form.js?ver=4.0.3'></script>

		<!--[if IE]>
		<script type="text/javascript">
			if ( 0 === window.location.hash.indexOf( '#comment-' ) ) {
				// window.location.reload() doesn't respect the Hash in IE
				window.location.hash = window.location.hash;
			}
		</script>
		<![endif]-->
		<script type="text/javascript">
			(function () {
				var comm_par_el = document.getElementById( 'comment_parent' ),
					comm_par = ( comm_par_el && comm_par_el.value ) ? comm_par_el.value : '',
					frame = document.getElementById( 'jetpack_remote_comment' ),
					tellFrameNewParent;

				tellFrameNewParent = function () {
					if ( comm_par ) {
						frame.src = "https://jetpack.wordpress.com/jetpack-comment/?blogid=47534632&postid=31553&comment_registration=0&require_name_email=1&stc_enabled=0&stb_enabled=0&show_avatars=1&avatar_default=mystery&greeting=Leave+a+Reply&greeting_reply=Leave+a+Reply+to+%25s&color_scheme=transparent&lang=en_US&jetpack_version=6.0&sig=c9ed664d6dd52c58bb40151ec7922467247fc3a5#parent=https%3A%2F%2Fmassispost.com%2F2018%2F05%2Fpm-pashinian-satisfied-with-productive-talks-with-president-putin%2F" + '&replytocom=' + parseInt( comm_par, 10 ).toString();
					} else {
						frame.src = "https://jetpack.wordpress.com/jetpack-comment/?blogid=47534632&postid=31553&comment_registration=0&require_name_email=1&stc_enabled=0&stb_enabled=0&show_avatars=1&avatar_default=mystery&greeting=Leave+a+Reply&greeting_reply=Leave+a+Reply+to+%25s&color_scheme=transparent&lang=en_US&jetpack_version=6.0&sig=c9ed664d6dd52c58bb40151ec7922467247fc3a5#parent=https%3A%2F%2Fmassispost.com%2F2018%2F05%2Fpm-pashinian-satisfied-with-productive-talks-with-president-putin%2F";
					}
				};

				
				if ( 'undefined' !== typeof addComment ) {
					addComment._Jetpack_moveForm = addComment.moveForm;

					addComment.moveForm = function ( commId, parentId, respondId, postId ) {
						var returnValue = addComment._Jetpack_moveForm( commId, parentId, respondId, postId ),
							cancelClick, cancel;

						if ( false === returnValue ) {
							cancel = document.getElementById( 'cancel-comment-reply-link' );
							cancelClick = cancel.onclick;
							cancel.onclick = function () {
								var cancelReturn = cancelClick.call( this );
								if ( false !== cancelReturn ) {
									return cancelReturn;
								}

								if ( ! comm_par ) {
									return cancelReturn;
								}

								comm_par = 0;

								tellFrameNewParent();

								return cancelReturn;
							};
						}

						if ( comm_par == parentId ) {
							return returnValue;
						}

						comm_par = parentId;

						tellFrameNewParent();

						return returnValue;
					};
				}

				
				// Do the post message bit after the dom has loaded.
				document.addEventListener( 'DOMContentLoaded', function () {
					var iframe_url = "https:\/\/jetpack.wordpress.com";
					if ( window.postMessage ) {
						if ( document.addEventListener ) {
							window.addEventListener( 'message', function ( event ) {
								var origin = event.origin.replace( /^http:\/\//i, 'https://' );
								if ( iframe_url.replace( /^http:\/\//i, 'https://' ) !== origin ) {
									return;
								}
								jQuery( frame ).height( event.data );
							});
						} else if ( document.attachEvent ) {
							window.attachEvent( 'message', function ( event ) {
								var origin = event.origin.replace( /^http:\/\//i, 'https://' );
								if ( iframe_url.replace( /^http:\/\//i, 'https://' ) !== origin ) {
									return;
								}
								jQuery( frame ).height( event.data );
							});
						}
					}
				})

			})();
		</script>

		</body>
</html>
<!--
Performance optimized by W3 Total Cache. Learn more: https://www.w3-edge.com/products/

Object Caching 12974/323 objects using disk
Page Caching using disk: enhanced 
Content Delivery Network via cdn5.massispost.com
Minified using disk

Served from: massispost.com @ 2018-05-15 08:45:30 by W3 Total Cache
-->